This is the old SliTaz forum - Please use the main

Slitaz New Cooking Release: 20100221
  • jozeejozee February 2010
    For those who may have missed the announcement ( a new cooking iso is released for testing.

  • newusernewuser February 2010
    I just tried the new ISO and I found the following problem.
    I only have a wireless connection available but I found two things.
    1- With the 2.6.30 kernel I am unable to auto connect to the wireless, no matter which version I try. I am using an AMD 2x board. Don´t know with Intel. .
    2- In the new ISO I am unable to connect to the wireless conection either way.
    I tried the scripts in the init.d older version and I am able to connect.

    Other than that Everything else worked OK.

  • newusernewuser February 2010
    Another problem I found: Tried to surf the web and get the message that I am running low on memory. I have 2 Gig of memory.
  • LineaLinea February 2010
    Hi, is there an easy way to change screen resolution?

    I seem to be stuck on 800x600



    Screen 0: minimum 640 x 480, current 800 x 600, maximum 800 x 600
    default connected 800x600+0+0 0mm x 0mm
    800x600 61.0*
    640x480 60.0

  • jozeejozee February 2010
    @newuser: for wireless connection (intel cards especially), you need to install non-free firmware files. SliTaz does not yet distribute them because of the legal license.

    If you have an active ethernet connection, you can open tazhwbox and check auto-install non-free firmware OR you can type:

     tazhw detect-pci --get-firmware 
  • jozeejozee February 2010
    @Linea : cvt/xrandr can help adding new/higher mode of resolution. Its not straightforward though. Google will give you the right links. I think the problem may be due to some missing modules (try linux-agp;)
  • mojomojo February 2010
    @newuser : which /etc/init.d scripts from what version of slitaz will get wireless working on cooking-20100221 ?

    cooking-20100221 see's my accesspoint(no encryption), but can't get an ip with udhcpc or get ping reply from accesspoint if I assign it an ip.

    I'm multibooting on same hardware slitaz stable-2.0 and cooking-20091104 and wireless works ok with them.
  • jozeejozee February 2010
    @mojo: see if the following raw file helps for statis ip:

    Please test. Static ip problem was fixed :
  • AyortanoAyortano February 2010
    Please, resolve my problem (Detect Huawei E160 in SliTaz 2 Cooking)
    In Stable version no syced. Im speak spanish, ES forum discussion, respond in your language!
  • deadwaitdeadwait February 2010
    new cooking version still does not detect lan card on acer aspire one d250 plus, so graphics? startx does not start anything giving a .xsession error , if you add .xsession using the same options of /root/.xsession it gives a DISPLAY variable not set error.
    Jozee: im still working on the older cooking with the driver you provided for atl1e, yet slitaz tries to detect it as atl1c even on the new cooking,
  • jozeejozee February 2010
    @deadwait : I haven't added atl1e yet to repos because last time when I checked it was a testing version. Can you check if with the new cooking atl1e testing version works? Then, I can add it to repos.

    @Ayotano: Please describe your problem further or point to the corresponding forum page.
  • davesurreydavesurrey February 2010
    My opinion of the new Cooking 20100221 was initially very positive. Many of the problems I had experienced with the earlier Cooking seem to have been fixed. Notably the GUI-based tazpkgbox works well now and I can now setup a username other than "tux". Many thanks.


    1. There is still a problem wth Abiword which many have reported before. It doesn't launch via the menu and at cli it gives the message "Pango warning shaping..." see "AbiWord not Working" in English_General section.
    Then when I downloaded many other packages suddenly AbiWord ran okay. No idea which package did it. If any dev is interested in fixing this long long running issue then please ask and I'll list out all the packages I downloaded.

    2. aMSN won't run...says needs libxss

    3. firefox simple mail 2.7.2 says it won't run as incompatible with Firefox 3.5.7

    4. get-opera doesn't download opera

    5. get-skype only seems to download a tar.bz2 file into /home/user even if I use install on tazpkg.

    6. sylpheed says "warning GnuPG is not installed properly..or too old."

    7. downloaded nvidia but Menu>Preferences>NVIDIA X server settings doesn't run. Added linux-agp just in case. No difference.

    8. Menu>Preferences>Panel doesn't do anything

    9. Menu>Utilities>Search for Files or Folders doesn't find many files. eg I have htop installed but Search for File and Folders doesn't find it. I downloaded Searchmonkey which finds it immediately.

    There are other apps I am still looking at but the ones above seem basic and disappointing.

    10. On install it has set a screen resolution that is too high for me. I estimate it as 1280x1024 but want 1024x728. No idea how to do that but surely it should be a simple proceedure.

    11. In general I don't know why we have lost a lot of the right-click-on-the-desktop modes and I'm sure I'll get used to it but I now am having to learn again how to change things. Seems to me there are not enough wizards to personalise the desktop for example.


  • NikNik February 2010
    hey everyone
    I did just install the new slitaz-cooking-20100221 and I liked the look of the "lxpanel-Taskbar".
    I wanted to change that in my slitaz-20091104 partition.
    So if anybody is interested... the file to change is:
    Open that file as root look for the plugin "taskbar" and change the number behind "FlatButton=" to 1. That's it.
    I think it is obvious that this will also work the other way around in case someone likes the old style in the new cooking.

    I think I have a solution for your 2nd problem, too, Dave:
    you need to search for libXss in the slitaz package manager and install xorg-libXss. ---> mind the capital X in libXss
    I always tend to forget it and get confused why I can't find it ;)
  • davesurreydavesurrey February 2010
    Thanks Nik,
    I installed xorg-libXss (stupidly I should have looked for that rather than just libXss) but now it comes upo with error message:
    "There's a problem loading ...TkCxImage...couldnt load utils/ cannot be opened. "
    I checked and tk and ts are installed.
    Like a lot of dependancy issues when you fix one another one raises it's head.
    Thanks anyway.
  • NikNik February 2010
    I think thats a pretty easy one :-)
    Just search for libv4l and install it
    That worked for me... I had the same problem when installing it!
  • panksopankso February 2010
    Amsn dependencies fixed, thanks:
  • davesurreydavesurrey February 2010
    Nik & pankso,
    Works fine now with the two files above. Appreciate your help.
  • LuXLuX February 2010

    will the iso's of the Cooking-snow flavors (and specially the Xorg one) be updated too?

    By the way, I purposed to help improving a little bit the visibility of the flavors in the "Download" page. The link to the flavors in this "Download" page now points to this page:
    from which the Cooking and Cooking-snow flavors are not visible. Indeed this later page contains only one link to 2.0 flavors, and no description at all of the aim of available flavors.

  • taylorchutaylorchu February 2010
    I test this cooking, and it is nice
    it boots faster. However, I do not feel any speed improvement in tazpkg.
    every time I install a package, it freezes there for about 30 sec.

    another suggestion, please double check package dependency. some packages just do not run.

    please update firefox!!
  • davesurreydavesurrey February 2010
    New problem:
    I wanted to see why I can't get a decent resolution using xorg so tried to edit /etc/X11/xorg.conf using leafpad but when I try to run leafpad from root I get:
    # leafpad
    Xlib: connection to "0.0" refused by server
    Xlib: no protocol specified
    leafpad: cannot open display
  • NikNik February 2010
    I don't know an answer to that problem, but you could try to use Geany IDE to edit the xorg.conf... Geany is better for that stuff in my opinion
  • davesurreydavesurrey February 2010
    Hi Nik,
    Well the same happens if I try to run Thunar as root. Same error message. So I think this is something much more fundamental than just a leafpad issue.

    To try to work around this I logged in as root and then saw that there was just a black desktop plus tray. Also right clicking on the desktop shows the usual choice of:
    Favourite Apps
    Desktop Files & Icons
    Open Folder
    Desktop effects

    But as user tux I only see:
    Create New
    Desktop Settings

    All this even running the Live CD not even trying to install to a hard disk.

    Also boot.log says "your xorg.conf file is /root/"
    No it isn't it's still there at the usual place /etc/X11/xorg.conf

    Tried running tazx as root.
    Clicked on Install xorg.
    tazpkg seemed to do its job then asked which driver. I have an Nvidia n34 card so selected nv as the most obvious.
    It then says run X -config /root/ which freezes everything and needs a reboot.
    I guess it needs to be X -config /etc/X11/xorg.conf but confusing to newbies.

    Tried installing nvidia 190.42 from tazpkg manager, rebooted but still didnt see this driver in the list given by tazx.

    And still can't see how to change the resolution. It was easy in xorg 7.3 but xorg 7.4 is a bit too clever for its own good. :)

    I'd like to help to squash some of the many bugs I see here but to be frank I never seem to get much response to what I write so it's not very motivating Im afraid to say.

    So i do appreciate your help and response.


  • jozeejozee February 2010

    Thanks, we have frozen the wok and we have started working on removing all the bugs now for the stable release. This cooking is a major change from Xvesa to X-org, so things will take some time. Your reports, even though not replied back as frequently as we would like, are very useful.

    For nvidia, see if this helps.

    nvidia (non-free) comes with its own utilities.
    To autoset xorg.cong,try:

    For settings:
  • davesurreydavesurrey February 2010
    Hi Jozee,
    Thank you for your helpful reply.

    I agree that going from Xvesa to X-org is a major change and of course accept that it will take time to fix the inevitable bugs. If I can give any helpful feedback please just ask.

    Previously I tried nvidia-xconfig as root which gives:

    Using X config file : /etc/X11/xorg.conf.backup
    New X config file written to /etc/X11/xorg.conf

    which seemed okay.

    With nvidia-settings as root I get:
    Xlib: connection to the "0.0" refused by server
    Xlib: No protocol specified

    With nvidia-settings runnign as user tux then the nvidia gui appears saying

    You don't appear to be using the nvidia X driver.

    As regards AbiWord. I have found that if I install ntop then abiword it works fine. Therefore there must be somethng that ntop installs that AbiWord needs.

    Hope this helps

    In general would you and the other devs prefer one list of issues that I spot or several individual posts?


  • LuXLuX February 2010

    so this new cooking is using Xorg, this is a very good news! I'll try it soon, but let me already point out the following bug, very simple to fix:

  • slicelslicel February 2010

    9. I reported the search problem on the old forum last year or so but I do not remember any answer except that someone suggested to use searchmonkey.

    When you say that abiword works, do you mean that you can copy and paste from one doc file to another and you can edit, close, and reopen a doc or rtf and it displays correctly?

    Thank you.
  • davesurreydavesurrey February 2010
    Yes I have imported a MS Word doc, added to it, saved it, opened it again and pasted a new section from another doc and saved that. It all works okay as far as I can see.

    It took a while to do this as when I came to reboot slitaz I couldn't even get an x server so I had to reinstall yet again.

    As I've spent a good 2 days on (time I can't afford) I feel it best I leave it and come back when hopefully the devs have further debugged it.
  • papl2papl2 February 2010
    Hi Slitaz Team

    I'm a noob, but read that one of your goal for slitaz 3.0 would be that it will work "Out-of-the-box" for every eee pc

    Though, I've tested Slitaz 2.0 on my EEE 900A and it has worked "OutoftheBox"

    -Song (Intel Corporation 82801G)
    -Wifi Connection (AR242x ... ath5k module)
    -OpenBox display automaticaly the usb key plugged
    -Modules displayed/loaded? when i push on Lsmod button

    On your last cooking (as the previous one) none of these item works

    Is it normal ? And what about camera ? Shortcut buttons configuration ? Powerbox ?

    ok, it's not to critizise your excellent job but it's just to warn you
  • papl2papl2 February 2010
    Other thing i've notice on the last cooking .

    When i launch some applcation like alsaplayer , i can see a terminal lauching the application just during a eye blink before the application's gui is displayed.

    Not very beautifull .. :(
  • slicelslicel February 2010
    [quote]Yes I have imported a MS Word doc, added to it, saved it, opened it again and pasted a new section from another doc and saved that. It all works okay as far as I can see.[/quote]

    I tried different abiword versions on different slitazes on different computers for over a year and slitaz abiword would not display content after editing and reopening (but the same file worked in ubuntu abiword).

    I have not tried this new cooking yet.

    Thank you for checking.
  • davesurreydavesurrey February 2010
    Hi slicel,
    May I just emphasise that these tests on Abiword where after I had done a clean install to my HDD of AbiWord and ntop. Without ntop I couldn't even get AbiWord to launch.

    Also yes I am using Searchmonkey ( a very nice app IMO) instead of the Menu>Utilities>Search for Files or Folders. Works very well although it seems a lot slower.

  • slicelslicel February 2010
    I never would have thought that ntop would be related but I am reluctant to try ntop on my current version because of recent tazpkg bugs so I will wait for the developers to fix more bugs before I erase slitaz and start over again.

    Searchmonkey will search all mounted drives when it follows the /media tree but you can search faster if you unmount drives or restrict the path.
  • davesurreydavesurrey February 2010
    Well it's not the first time I have found that I have needed to install what seemed like a totally unrelated app to get another one working. I assume ntop contains a dep that AbiWord needs.

    I didn't have any other partition mounted so my search speed comparisons were like-for-like.
    It may well be that Menu>Utilities>Search for Files or Folders isn't searching as deeply as I believe it to be. Hence the speed difference and lack of search success.
  • LuXLuX February 2010
    Hello Dave!

    I have found something for your Abiword problem: among ntop dependencies there is glibc, which all the devs as well as everybody who build a package, has installed. And among the numerous dependencies of glibc there is glibc-locale, which is one of the first thing I install in Slitaz, probably like anybody else using UTF-8 encoding (at least they should).

    Since I never experience in Slitaz any of the problem you and Slicel reported about Abiword, I decided to test this intuition. I started from a fresh install of the last available Cooking, release 20100221, and followed this steps:
    - I installed only abiword. It doesn't work, that is to say it crashes just after starting.
    - I installed glibc-locale. Run abiword and it works. Well I haven't tested it much like you did, but at least it doesn't crash just after starting and seems to work nicely.

    So one can understand now not only a solution (add glibc-locale or some of its dependance among the dependencies of abiword) but also the reason why the devs, as well as a lot of normal users like me, never encountered your problem, hence could not solve it.

    But this proves also that people who write new receipts should always test the resulting package not only in their usual Slitaz environment but in a fresh installed one, and even in the smallest possible flavor, namely Slitaz-base.

    Hope this helps (no, I know this helps ;-))
  • davesurreydavesurrey February 2010
    Hello Lux,
    Yes this is very helpful for two reasons.

    Firstly you have identified the source of the problem and the fix. Many thanks. I assumed it was something to do with glibc but had no way (or time) to investigate further. Thanks for that. :)

    Secondly thank you for saying what I have said in other forums when I have reported things not working but the devs there say it's okay with them. That is, one really must start with a clean install to be absolutely sure that an app works in isolation. So I am grateful for you saying this here. IMO it's very good advice.

  • cngsoftcngsoft February 2010
    Good afternoon. I've been regularly using Slitaz since its 2nd release; it's the best portable Linux distro ever and it makes a lightweight yet practical stable distro as well.

    That's why I've been following the development of the cooking packages and the 3rd release; and now that I see that dependency problems are arising, I'd like to warn about several inconsistences that arise when creating handmade flavors, or simply when installing software on a minimal flavor, as well as to suggest some few bugfixes and improvements:

    * The package netsurf-2.1 has been needing libgsf[-1.14.9] for a while to work, but it has yet to mention it in its DEPENDS section.
    * Similarly, the latest qemu-0.10.5 needs (from bluez[-4.54], that in turn needs linux-bluetooth[-]) to work, but the receipt doesn't state it. Besides, is the BlueTooth support really necessary? QEMU worked perfectly without it and these libraries add to the overhead.
    * Another package that got broken by a recent update is xarchive-0.2.8-6; the new sees all archives as empty, and so far the only workaround I know is to keep the old version of that file (22 Oct 2009). It's worth to say that even the old script misreads CPIO archives if, rather than using BusyBox's own "cpio" command, we installed cpio-2.10 that generates file lists with a different format.
    * The keyboard support has improved thru the times (I remember when a virtual Slitaz session inside a QEMU run by Slitaz would miss the cursor keys, accents... that Slitaz itself recognized correctly) but GTK+ apps still ignore the Shift-Tab and Shift-Control-Tab combinations.
    * Firefox recognizes those combinations because it doesn't fully depend on GTK+ to run, but that same partial independence makes its menus look different: it ignores the LX Appearance font sizes as well as the general DPI value; I need to edit the layout.css.dpi value from about:config.
    * The DPI value itself is troublesome in the current Xorg flavor (default 96), because it's not the same used by XVesa (default 72); things that looked uniformly sized in XVesa look either too big or too small in Xorg. For instance, the bottom panel's taskbar shows oversized captions in comparison to the GTK+ texts.
    * And back to the keyboard shortcuts, it would be handy if /etc/xdg/openbox/rc.xml included default shortcuts to LXPanel's "menu" and "run" operations. For instance, <keybind key="A-F1"><action name="Execute"><command>lxpanelctl menu</command></action></keybind> and <keybind key="A-F2"><action name="Execute"><command>lxpanelctl run</command></action></keybind> would give Ubuntu-like shortcuts for Alt-F1 and Alt-F2.

    This is all for now, but I'll keep an eye on Slitaz in the hope of catching further issues. Thanks for reading!
  • linuxfanlinuxfan February 2010
    where can I report problems with the new version?
    (Feb 21, 2010)
  • time4medstime4meds February 2010
    First of all I must say I completely agree with LuX's post above, these are some
    good idea's, which will only make sliTaz better.
    Second I just want to say, I really like the new cooking 20100221, I mean, I had
    to install linux kernel source and headers manualy offline, plus of course a whole bunch of dependencies, so that I could compile ndiswrapper off SVN, just
    to get my usb network adaptor going, (not to mention, had to fix sound, yet again) but other then that, its running really
    smooth. Good job to the people involved with putting the developement tools,
    and libraries on the repos. I need fairly up to date stuff to compile. And for me
    it all works pretty good, slick distro, give yourselfs a pat on the back.
  • LineaLinea February 2010

    I think having a team of official testers to report back to the package maintainers and the developers is a great idea.
  • davesurreydavesurrey February 2010
    Hi Lux,
    Thanks for that very thoughtful and useful post. You raise many interesting points. You are correct and I should have said package contributors rather than devs when suggesting testing. But I was, and still am, unsure who is a dev and who a package contributor and I guess some do both.

    It will be interesting to see how the devs want to play this but I think that all users need to help in this and report back what they can. I only wish there were a specific place on the forum where those comments could be collected.

  • marcolphusmarcolphus February 2010
    Ok, I finally managed to run new cooking on my home notebook and... I can't use it.
    First of all I can't change the resolution!! It's always 800x600x16. When I start Slitaz with command vga=791 it fails to execute login command.
    Sound is not working (via82xx) and wireless networking either.
    That's all for now...
  • LuXLuX February 2010

    * davesurrey wrote:
    It will be interesting to see how the devs want to play this

    Apparently Linea is a member of the administrator team, so hopefully his/her post (I suppose it's "her" without knowing :)) is kind of an answer.

    You're right that the developpers of the distro and the contributors of the packages are sometimes the same persons. Although these two functions are quite different they are also quite complementary. In my opinion however this confusion (which is quite normal) may have nasty side effects sometimes, precisely because they do not require the same balance between creativity and rigour.

    @marcophuls: It's sad to say that all the problems you report are not exceptionnal with Linux, since they are all related to material and drivers.

    Problems of resolution mostly depend on Xorg and your video card. I experienced it myself in Slitaz and in Xubuntu. Try this:

    - Set option "screen=your_resolution" at bootime (option vga=* is mostly used for tty, I think). If you're using a permanently installed Slitaz (in your HDD, not a live system) it may be that this will take effect only if you set it the first time you boot Slitaz, when Xorg is installed and configured automatically by tazx.

    - If there exists a specific driver for your video card, install it with tazpkg and specify it in /etc/X11/xorg.conf (changing the value "vesa" by the name of your driver). The list of available drivers is obtained with CLI "tazpkg search xorg-xf86-video". The name of your video card is obtained with CLI "lspci | grep VGA", I think.

    - If it isn't sufficient, edit /etc/X11/xorg.conf as root (keep a backup of it in case of) and modify it as you need. There are uncountably many posts on Linux's forums on the various possile ways to do it (in every distro). I reported some of them in this forum. Google "set resolution xorg.conf" for examples.

    For sound and wireless connection, you may search in this forum (and others) using keywords related to your material, and maybe open a new thread on this. It's all I can say, sorry.

    Hope this helps,
  • babaorumbabaorum February 2010
    Hi, you can also log out of graphic session ("logout"), return to Slim then exit from it (login: "exit", password: root password ["root"] ).
    You get back to pure console, where you need to log in as root: login = "root", password = root password = "root".

    Then run "tazx" and choose Xorg as X server, then choose your graphic driver (as an example: "nv" for nvidia graphic cards).

    Then you can start again graphic session by running "startx", to get back to slim and login as "normal" user.
    By this way, the "screen=AAAxBBBxCCC" specification of screen resolution at boot time will be processed, as the Xorg server is correctly configured.

    You can also try this on console as root: "Xorg -configure"... but I'm definitively not an expert in Xorg managing, I've always been using XVesa with great results.

  • ZoevZoev February 2010
    I cannot get Slitaz to boot. I put the new cooking with wifi (29MB) on a flashdrive with unetbootin, then at the startup screen select Slitaz.
    The boot process gets to the line "Switched to NOHz mode on CPU #0" then crashes after a few minutes no error message
    I tried the same thing again by transferring over the mounted .iso and reworking it with syslinux. I was greeted by the slitaz screen and the prompt "boot:" and after hitting enter recived the same error
  • RuppRupp February 2010
    This may seem weird to some but after I get everything setup ie. video drivers. I boot up puppy and set X and copy the xorg.conf from it and use it in slitaz. I did that in Arch and it ran perfectly. May seem weird to do but saves you some time. I have backups of the xorg.conf now if I need them so no need to boot into puppy.

  • seawolfseawolf March 2010
    @Zoev -- You could try turning off a couple of things like power management; I've had a similar problem on some laptops. At the "boot:" prompt, try:
    slitaz noapic noacpi apic=off acpi=off

    Please also be aware that the entrie file-system has to be de-compressed & extracted in to RAM before SliTaz can actually start, so a good few seconds wait is needed at one point.

    @Rupp The entire /etc directory is highly recommended in regular back-ups! X, users, network, SAMBA config etc. are all in there :)

  • jozeejozee March 2010
    @LuX and @davesurrey : Thanks for your comments. You will be happy to note that we have taken steps to address some of your concerns about the missing dependencies in the pkgs. You may like to look in:

    One of the major improvement that we have been working on for Slitaz 3.0 is to reduce the maintenance load and automate pkg building and tracking ( at the backend. We have now added automatic package dependency tracking. It means, in future, any commit to repos will automatically be checked for any updates on the corresponding pkg dependencies.

    This full automated pkg maintenance is a very unique and distinctive feature for Slitaz 3.0 which we hope will improve user satisfaction in future.

    Like Linea, I also support an idea of a team of official testers. Would you be willing to take this task?


  • RuppRupp March 2010
    I would like to.
  • davesurreydavesurrey March 2010
    jozee (or Rohit...sorry but not sure which you prefer to be addressed by) :-)
    Thank you for the information about deps and pkg builds in the future. That's very good news for all as it sounds a very practical and pragmatic approach.

    Regarding a testing team, although I believe Lux has made several valuable suggestions I am not wholly in agreeement with the idea of a dedicated testing team. Why?

    As I said above
    It will be interesting to see how the devs want to play this but I think that all users need to help in this and report back what they can

    I have just 2 PCs, a laptop and 2 netbooks. Hopefully I will install SliTaz 3 on a few more PCs of friends etc but it's still a very very small subset. I truly believe that we need to encourage all users to submit reports as a small band of testers would never catch all possibilities.

    So my personal preference would be to have a very visible and easy to input section of this forum for all to make input. At the moment bug reports are scattered all over the forum which helps no-one not-least the devs and pkg builders. Of course the ideal would be to hope that everyone will use the labs site to input bugs reports but IMO that's an ideal situation which will not likely occur for sometime (if ever.)

    May I take this opportunity to say that I have been rather honest recently in making some comments and criticisms of SliTaz but I have done that only because I feel it has many very good things going for it and I want it to succeed and expand. If I did not care about SliTaz I would not have bothered. Thank you in turn for taking my comments very positively.
    It's very much appreciated.

    Best wishes

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social