This is the old SliTaz forum - Please use the main

kompozer - unknown trouble
  • michaelkbischofmichaelkbischof January 2011
    Hallo everybody,

    I tried to run kompozer - but it does not run and does not give any clear error message. So I tried to download ldconfig (within glibc-dev) but no success ldconfig either.

    ot@slitaz-cooking-hda8:~# ldconfig
    ldconfig: /usr/lib/ is not an ELF file - it has the wrong magic bytes at the start

    Any idea, anybody?
  • mojomojo January 2011
    slitaz-3.0 install with thunderbird seamonkey and firefox installed
    Inside kompozer folder double click kompozer
    In terminal ./kompozer
    Program starts.

    slitaz-cooking-core fresh install with no mozilla products installed:
    Version 0.8b3 wouldn't start so I try the stable version which works:

  • michaelkbischofmichaelkbischof January 2011

    thanks a lot for the speed and the precision of your answer. This afternoon I will check it. Stay tuned! ;-)

  • michaelkbischofmichaelkbischof January 2011
    <By the way: under slitaz-cooking I cannot write a reply here using midori>

    I am too curious. So this answer comes quick, mojo:

    Yes, it starts - and crashed when one inserts a table:

    tux@slitaz-cooking-hda8:~/Desktop/kompozer.0.77.10.gcc.4.0.3/kompozer$ ./kompozer
    /home/tux/Desktop/kompozer.0.77.10.gcc.4.0.3/kompozer/ line 159:  1375 Segmentation fault      "$prog" ${1+"$@"}

    So I look at what happens in that line 159:

        ## Make sure the program is executable
        if [ ! -x "$prog" ]
            moz_bail "Cannot execute $prog."
        ## Use md5sum to crc a core file.  If md5sum is not found on the system,
        ## then dont debug core files.
        moz_test_binary /bin/type
        if [ $? -eq 1 ]
            crc_prog=`type md5sum 2>/dev/null | awk '{print $3;}' 2>/dev/null | sed -e 's/\.$//'`
            crc_prog=`which md5sum 2>/dev/null`

    That means: some mozilla-program is started. The kompozer opens on slitaz-cooking but in the very moment where I try to insert a table it crashes. Firefox is installed on this cooking installation here.

    Of course I do not give up! ;-)
    So I installed java runtime and seamonkey suite (with a lot of dependencies) and tried it again - but with the same result! :-)


  • michaelkbischofmichaelkbischof January 2011
    Puh, this is not my kompozer day...
    I downloaded the debian-Version kompozer-0.7.10-i386.deb and used
       tazpkg convert kompozer-0.7.10-i386.deb kompozer-0.7.10-i386.tazpkg

    The result was very heay cpu-load for almost 30' and a package that exhibited the same problem: it crashes when one inserts a table. Not usable then...
  • michaelkbischofmichaelkbischof January 2011
    Ongoing with this never ending story.
    I checked the very new fluxflux based on Slackware 13.1. There is only a Slackware 12.2 package available of the kompozer 0.71 version, in English but a German language package addition is there (and functions. Important: as often those do not function). The Slackware package can be installed in fluxflux with the pkgtool with ease.

    And the surprise: the 0.83b - version, using the *.tar.gz-package, works in fluxflux without installation with ease. There was a German localized package available.

    The importance of kompozer from my point of view is the fact that it is plattform-independant. I intend to use it in a school environment, where the difference between ,,save" and ,,save as..." is beyond the limits of most kids. In a win2000 environment all they learn are some ,,muscle memory" type of tricks in using some Microsoft applications. Therefore I need applications that are
    • German
    • platform independant
    Until I am happy for that with fluxflux, Mandriva and slitaz stable. Slitaz-cooking remains unsolved.
  • kultexkultex January 2011
    therefore it is called Slitaz-cooking - there are still a lot of errors...
  • michaelkbischofmichaelkbischof January 2011
    Ok, and one of those I report here in the vague hope that this message is transferred to the kitchen, to the cooks. And, well, I am none of them. If I can obtain an error message after having opened an application via a konsole then I might get an idea into which direction I have to look for obtaining a solution. But a silent crash I cannot repair.
    Please notice that I did not get angry from such mistakes. Shit happens! And the same application runs with ease on Slitaz 3.0 and on fluxflux. I gave some hints about the importance of kompozer for a German school environment in provincial areas.

    A little bit more background:
    I just gave an older laptop computer, gifted from a member of our local Linux user group, to a 14 year old pupil. What I did with it I made public.
    I got it with an encrypted filesystem = not bootable at all. There was a floppy drive, but at the weekend it appeared that the CD-drive is defect. Under Windows or Mac an absolutely hopeless situation.
    Under Linux? I obtained a PXE-boot-floppy from Slitaz, connected a DSL-cable to a pcmcia-ethernet-slot-card and got a useful (mini-) installation within some minutes. For the school I need Open Office, localization German, but slitaz did not contain the desired thing (was outdated, this get-OpenOffice3 script).
    Under Linux solutions are obtained by cooperation, not from single geniusses that charge a lot of money in case they are successful (Steve Jobs, who marketed the results of real nerds without being one of them; Gates being the same type). No, Linux is community. And community can be shown - and tested. Slitaz is a young plant, international, with an unusual high percentage of French-speaking ,,nerds" (I suppose) as compared to other distris. Until now I could solve all apparent problems of the day in the frame of slitaz and I documented that - especially those that are out of reach, out of thought even for young Microsoft adapters like my pupils are.
    I gifted to them an old USB-WLAN-Card, no name, 11 MB/s with the request to establish it under their beloved Windows. Nearly hopeless for them. Under Slitaz the solution was counted not in minutes. To use seconds was more appropriate. Open a root konsole, put the card in, look at the dmesg output: precise identification of the card, Slitaz even gave an URL where to look for the firmware, load it down, depmod -a -m and then establish it. Done.
    ... to be continued! ;-)
  • michaelkbischofmichaelkbischof January 2011
    And now the final contribution to this thread, the Canossa type one, when being at the point where only good humour can help.
    On a fresh hd-install of slitaz stable I first installed firefox and then seamonkey (as I was told this is the condition to make kompozer 0.71 run).
    Then, being curious, I just tried the 08b-version that was on an USB-stick. What a surprise: it worked! ;-)
    So I copied it to ~/bin and applied a soft link to ~/.local/bin.
    And it worked!
    Dear reader, do not stop here:
    of course one wants to know where the previous trouble came from. In this case it is important to see to which libraries the executable is linking.

    root@slitaz:~# ldd /home/tux/bin/kompozer.08b/kompozer

    /home/tux/bin/kompozer.08b/kompozer: error while loading shared libraries: /home/tux/bin/kompozer.08b/kompozer: invalid ELF header

    (But is really works!)
    Anybody here to comment that?

    (Again: why isn't possible to write contributions to this forum with midori?)

    So slitaz is fun, yes?
  • Trixar_zaTrixar_za January 2011
    It's more a problem with the forums software (Vanilla) than Midori. It's problems with the javascript and css. There is no real fix, except to turn off javascripts, but then you can't post anything...

    Anyway, if you're like me and fixing and playing around with a Linux is your idea of fun, then yes, SliTaz is fun :P
  • michaelkbischofmichaelkbischof January 2011
    The question was plain rhetoric, of course. Otherwise I wouldn't have continued with this issue. But, seriously:
    anybody here to explain why a programs runs when the konsole output is like given here:

    root@slitaz:~# ldd /home/tux/bin/kompozer.08b/kompozer
    /home/tux/bin/kompozer.08b/kompozer: error while loading shared libraries: /home/tux/bin/kompozer.08b/kompozer: invalid ELF header

    For me as a non-technician it is just mystery. Though I like its result.
  • mojomojo January 2011
    kompozer is a bash startup script,not the binarie executable.

    ldd /home/tux/kompozer.08b/kompozer-bin
    Cooking was missing 3 libraries that were in the kompozer folder. Copy to /usr/lib ran ldconfig as root. Recheck ldd , no missing libs.
    kompozer won't start with no errors reported :(

  • michaelkbischofmichaelkbischof January 2011
    Thanks a lot. So no more mystery in slitaz! :-(
    To make it perfect: for running ldconfig one needs to install glibc-dev plus its dependencies.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social