This is the old SliTaz forum - Please use the main

Please help me install this.
  • tnt1tnt1 January 2011
    I have an old Dell Latitude, with no cdrom, and bios that wont boot from usb. I take the hdd out, put it in ide enclosure, boot live slitaz cd on my own laptop, and install, targeting the usb attached hdd from the Dell. all goes fine. I take hdd out of enclosure, put back in dell, at grub,I edit the lines from sdb1 to hda1 and from hd1,0 to hd0,0 and I get continual kernel panic error, can't start init and so on.

    I understand it is an issue to do with partitions. Can someone direct me as to what partition table to create on the Dell hdd to get this working.
  • gdesilvagdesilva January 2011
    I came across a similar problem resulting in kernel panic with pclinuxos installation but the issue was with Grub2. It turns out that grub2 starts counting from 1 and not from 0 as it was done in earlier versions of grub. So the simple solution was to change hd0,0 to hd0,1 etc. Of course if you are not installing grub2 this probably will not fix it.
  • tnt1tnt1 January 2011
    Hi, thanks, but I'm using Grub 1.5 still.
  • TheForsakenTheForsaken January 2011
    I've been through the same hassle.

    In case you're using "USB Enclosure" then I don't think it will work. Installing SliTaz into an USB Drive is differnet and not like installing it into a Hard Drive.

    GRUB2 in my case solved the issue. All what I had to do is to find an OS with GRUB2 and should be light enough for my laptop.

    So, are you using USB Enclosure?
  • mojomojo January 2011
    You installed stable slitaz-3.0.iso
    Does your /boot/grub/menu.lst look similar to this?
    title  SliTaz GNU/Linux 1.0 (Kernel
           kernel /boot/vmlinuz- root=/dev/hda1

    If it does the menu.lst is likely correct so try adding acpi=off  or apic=off to the end of the kernel line.

    Post your menu.lst if you need further assistance.

  • tnt1tnt1 January 2011

    It doesn't... I installed from 3.0.iso, and my menu.lst refers to (hd1,0) which I have to change to (hd0,0); and root=/dev/sdb1 - and that's the one that is causing kernel panic. I knowit refers sdb,as the drive was mounted as sdb when I installed, I don't know what I should rename it to,I have tried hda1, hd1, hd0, hda0, and still kernel panic.
  • tnt1tnt1 January 2011

    I am using a hard drive from a laptop, but the laptop has no boot from usb and no cdrom, it is really old, I have to take the hd out, put it in a ide external case, and connect it to another machine via usb. I have successfully done this with antix, but I cannot get it right with slitaz, and |I really want slitaz on here.

    (on your ubuntu forum link, I have posted regarding my old antiX install...)
  • TheForsakenTheForsaken January 2011
    Hi tnt1,

    I expected that :)
    SliTaz has its own method when it comes to USB-Installation. I'm not on SliTaz right now but once I'll go to my other room, I'll edit this post.

    In my case, NOTHING with GRUB Legacy worked. I had another hassle with antiX and if you're interesed, I could post the link of my thread here. The guys on antiX's forum did their very best to help but it just did not work.
    At the end, as you may read it in my thread, I installed Mint Fluxbox and it worked without any problems.

    So, I had exactly the same scenario of yours. I might try again to install SliTaz but to be honest I don't have much time these days to play with that old laptop. I did what I want ... proved that Linux can work on 12 yeas old machines while Windows can't :)

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social