This is the old SliTaz forum - Please use the main

noob, how to install/reconfig wireless network drivers without network?
  • grumpygrumpy March 2011
    hi, just installed slitaz GNU/linux 3.0, so save an old pc (amd k6, 348mb ram) and runs perfectly with no lag whatsoever , but i cannot connect to web via wireless usb dongle (belkin 54g).
    if i go to sys tools>wireless man.>auto detect devices>discover pci/usb devices i get..
    detected pci devices kernel modules
    module in use: tulip
    module in use: snd_cmipci

    det usb dev kernel mod
    belkin 54g usb network adaptor
    sh: rt73usb-firmware: unknown operand
    *loaded module: rt2500usb
    sed: unmatched '/'

    enter to close...

    so what do i need to do?
    and please pretend i am a six year old, never really used the command line but have a VERY basic understanding of term. (i use ubuntu 10.10 on main main pc after ditching windows about a year ago.)
    any help greatly appreciated.
  • slicelslicel March 2011
    I think this page has the latest instructions-
  • grumpygrumpy March 2011

    thanks guys, tried that but still stuck
    tazhw detect-usb..
    belkin 54g usb network adaptor
    sh: rt73usb-firmware: unknown operand
    *loaded module: rt2500usb
    sed: unmatched '/'
    but fall down at the next step..
    tazpkg get-install get-wifi-firmware
    due to bad address (prob cos i have no network?)
    any suggestions?
  • mojomojo March 2011

    If  computer with slitaz has no wired ethernet connection with internet access to setup wireless download the files with a computer with internet access , copy files to common media ie. floppy disk,flash drive, cdrom, etc. and transfer/install on slitaz computer. 

    To setup a wireless usb adapter you need: usbutils.tazpkg , libusb.tazpkg , libusb-compat.tazpkg , linux-wireless.tazpkg plus firmware specific to your wireless chipset 

    slitaz does not have wireless firmware on the repos. A get script for firmware is provided to download/extract/install but requires the computer to have an internet connection.

    Download tazpkg here:

    To install :

    Logon to slitaz as root password is root

    Open xterminal:  #tazpkg install

    With wireless adapter plugged in type lsusb in xterm 

    Post the complete line with of the wireless device.

    I will post instructions on download/extraction/installation of wireless firmware after you post the ID info from your wireless adapter.

  • techkathytechkathy March 2011
    have same problem but instead of usb have old pci intel abg wireless adapter.  I need to get wireless working too, no wired ethernet available.  Someone sent me a taz package but I don't know where to install it in cooking version of slitaz.  Any help would be appreciated
  • ms3811ms3811 March 2011
    @techkathy, have you tried

    tazhw detect-pci

    from the command line as root? That should provide you with information on your wifi hardware, as well as, if available, load the correct drivers. Not sure what you mean by 'where to install it' but this is how you can install a something.tazpkg file (if that's what you have for the wifi adapter),

    Using command line, as root
    # tazpkg install filename.tazpkg

    This will install the package. However, if that pacakage has dependencies that are not already installed, tazpkg will attempt to connect to the repos and download the dependencies. But since you don't have Internet, this won't work. If this is the case, you can follow @mojo's instructions above, i.e. download the dependencies from the packages database on this forum, then copy and install using the command prompt.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership


SliTaz Social