This is the old SliTaz forum - Please use the main

Xorg fails to start on boot up
  • ms3811ms3811 March 2011
    I just installed a fresh box with a .36 cooking, which I then upgraded to kernel .37. Had some issues initially with an external DWA-125 USB wireless, but anyway, that's fixed now.

    For some reason, when the OS boots up, it does not start xorg automatically. It lands on the text login screen. Once logged in, I can run 'startx' and start the X server just fine. Although, xorg does not seem to remember my desktop effects, but that's not really a deal breaker. Or maybe that's related to the first issue.

    I looked into Xorg.0.log, but no errors there. Anyone have any ideas what's going on here? Or should I just start with a fresh cooking iso? Thanks.
  • moulefritemoulefrite March 2011

    How can one safe a Xorg Configuration ?  After each X logout , I need to reconfigure my Lxrandr
    (Which is working now !! :D ) . I'm on cooking version
  • mojomojo March 2011

    How slitaz autostarts Xorg on boot:


    /var/log/boot.log -> Starting slim login manager: Slim... [ OK ]

    Log on as root and type slim instead of startx followed by enter.

    If slim starts add it /etc/rcS RUN_DAEMONS=   after dbus/hald

    If slim fails to start post the errors  


    Set lxrandr to your liking, open xterm

    xrandr -q

    The current configuration is with the + to the right

    Now add to bottom of ~/.config/openbox/

    For example if I add to /home/tux/.config/openbox/

    xrandr -s 1280x800

    Then after slim login for tux openbox-session screen size is set to 1280x800

    There are many options for xrandr:

    xrandr --help

    I prefer add Modes to xorg.conf because it's global and set's the display manager login screen to the desired resolution.
  • moulefritemoulefrite March 2011

    Hi mojo,

    Yep it works .. I put this at the bottom of the file

    xrandr --output LVDS1 --off
    xrandr -s 1920x1080

    but if you set the option " Manage the desktop and set the icons"
    (to have a wallpaper) then you will have a kind of "composite"
    desktop with a sort of patchworked wallpapers .
    So I needed to disabled this option ... but I won't .
    I want wallpaper :(

    How can I add some resolutions to Xorg ?  
    I did the X -configure  and recuperate the
    and put it content to /etc/X11/xorg.conf   .. whatever ..
    there are nothing which looks like a screen resolution and it change strictly nothing as at each logout X
    800x600 appears (as I said up).

  • ms3811ms3811 March 2011
    @moulefrite, to configure xorg resolution you can edit the file /etc/X11/xorg.conf.d/70-Screen.conf (if you have it, else /etc/X11/xorg.conf) and go to the section "Screen", scroll down to the SubSection where it says Depth 24 and add the line

    Modes    "1024x768" 

    below Depth. The SubSection should then look like this:

    SubSection "Display"
          Viewport      0 0
          Depth          24
          Modes         "1024x768"

    You can replace 1024x768 with whatever your correct resolution is. For more details, look up the Documentation link on this forum, there is a guide to configure xorg.
  • ms3811ms3811 March 2011
    @mojo, thanks for the response. Slim is setup to load in rcS.conf, however it doesn't. I tried manually typing in slim at the command prompt, right after boot, no luck. No error message, nothing, simply returns to the prompt.

    I am running kernel .37, do you think the upgrade could have broken it? Are there any logs for slim that I can check? Thanks for the help.
  • mojomojo March 2011
    Move the existing /var/log/slim.log to ~/
    As root attempt to start slim:
    /etc/init.d/slim start
    Attach the new slim.log to your reply.

  • ms3811ms3811 March 2011
    Actually, I ended up reinstalling and this time slim started loading correclty, but I had a different problem. The keyboard and mouse would freeze when xorg loaded. Turned out xorg-xf86-input-evdev was missing -- not sure why, since this was a stable intall, then upgraded to cooking -- once I installed that, the problem went away.

    Thanks for the help.

    Ps: I think the mistake I was making earlier was that I was typing just slim at the prompt, instead of slim start.
  • moulefritemoulefrite March 2011
    mojo, you are nice guy .  But now , is there a way I can switch off automaticaly my netbOok screen  by editing Xorg ? Or do I have to do it with Xrandr in /.config/openbox/ ?

    Thx 4 all 
  • mojomojo March 2011
    Without a config file computer screen should turn off after 10 minutes.

    If not you must install the xorg-xf86-video driver specific to your graphics chip.
    My laptop with intel graphics chip the vesa driver would not shutoff the screen.
    Had to install xorg-xf86-video-intel.tazpkg for screen to blank.
    On my nvidia desktop the vesa driver shutoff the screen.

    DPMS screen configuration:
    Make file named 01-dpms-blank-conf
    Paste this:

    Section "ServerFlags"
    Option "BlankTime" "5"
    Option "StandbyTime" "5"
    Option "SuspendTime" "5"
    Option "OffTime" "5"

    This would turn off screen after 5 minutes.
    Move file to /etc/X11/xorg.conf.d

    DPMS screen blanking can also be controlled with a utility called xorg-xset

  • slicelslicel March 2011
    Slitaz 3 stable xvesa with xorg-xf86-video-intel.tazpkg

    My screen never shuts off and there is no /etc/X11/xorg.conf.d.

    How can I get the screen to shut off on idle?

    Thank you

  • mojomojo March 2011
    Options are passed as arguments to Xvesa

    See options:

    Xvesa -h

    Slim display manager starts Xvesa with options configured in /etc/slim.conf -> xserver_arguments

    On my hardware which is ati mach64 graphics with 19" Dell LCD

    Screen turns off after default 10 minutes:    dpms

    Screen turns off after X  minutes:               dpms v -s X

    Screen turns off after 4 minutes:                dpms v -s 4
  • slicelslicel March 2011
    I tried dpms, v, -h and -s before,  The default live cd screen shuts off after 10 minutes.  On my hd installation, however, I noticed today that the arguments line was commented out but uncommenting it did not fix the problem and now prevents the gui login.  What other program or setting would break the original screen timer like that?

    Thank you
  • slicelslicel March 2011
    It works now after changing slim.conf default_xserver from Xorg to Xvesa in addition to uncommenting xserver_arguments.

    I do not know why xorg replaced xvesa or why xorg broke user settings for the screen timer.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership


SliTaz Social