This is the old SliTaz forum - Please use the main

[SOLVED] cups sign in problem
  • wetterauwetterau October 2010
    Hi, cups installation is a real trip! Have tried many approaches suggested in the forum, but can't get past the sign in to add/modify printers. Have done addgroup tux lp, addgroup root lp, and so on. Error message on the cups admin page says: local authentication certificate not found. This happens from system login as root or as tux. Any suggestions? I agree with posters who say that these printer setup hassles are a deal breaker for many newbies. I'm able to configure this Thinkpad T23 and Canon i950 (using an i850 driver) in Puppy in two minutes. The Puppy cups is an earlier version, 1.3 something. Slitaz 3.0 is terrific otherwise. Thanks, john

    SOLUTION: install cups, following the instructions in the "guides" documentation for printers (as mojo details in a comment below.) The installation starts the cups daemon. If you don't realize this, and enter "#/etc/init.d/cupsd start", the system starts a second cups process and you will be unable to login. You will have to reboot and enter the above start command. You will then have only one cups running and will be able to login.
  • erniaernia October 2010
    did you try to reboot? i've installed it yesterday and it makes me the same issue.
    after a poweroff (dinner pause :-) ) it let me in as root
  • wetterauwetterau October 2010
    ernia, pure genius! Rebooting did it, at least for cups & open office. That's what I get for not taking a lunch break. Thanks, john
  • mojomojo October 2010
    I suggest you reference Documentation before the forum.
    Pick your language,go to Guides
    This information is from:

    Installing a Network Printer

    Do as root in xterm:
    # tazpkg get-install cups
    # addgroup tux lp

    Change some lines in /etc/cupsd.conf (# leafpad /etc/cupsd.conf):
    # Administrator user group...
    SystemGroup lp

    # Restrict access to the admin pages...

    Order allow,deny

    # Restrict access to configuration files...

    AuthType Default
    Require user @SYSTEM
    Order allow,deny
    Deny From None
    Allow From

    Set the admin password for cups:
    # lppasswd -g lp -a tux

    Now you should be able to have access to administration in cups with your browser with http://localhost:631/

    Go to:
    to see the rest of the tutorial.

  • wetterauwetterau October 2010
    Thanks, mojo. I did all that, but apparently I needed to reboot before it would work. john
  • erniaernia October 2010
    the steps that you report are required to admin cup as tux user or lp group, but you should be able by default to login and do administration tasks as root. i have not been able until i have rebooted, and i'm not so glad to receive too much RTFM . It think that you can't expect that every new user has already read every page and every row in the docs ;-)
    me and you must be two jackass :-)
    i bet that you, like me, have started the daemon in the very same moment you installed cups. here's the result:
    root@sl3:/home/fabio# ps aux | grep cups
    1779 root /usr/sbin/cupsd -C /etc/cups/cupsd.conf
    1976 root /usr/sbin/cupsd -C /etc/cups/cupsd.conf
    the /post_install() script of the package launches the daemon itself and /etc/init.d/cupsd script does not check if cups is already running (e.g. if /var/run/cups/cups.sock is there or not) so it launches another session of cups and as a result you can't login ...
    so, in your pc that now let you login in cups close the browser, run
    /etc/init.d/cupsd start
    and try to login again. if you can't login put solved in the topic title,put the solution (or the error to avoid :-) ) in the first post, and i will fill a bug (or a dumbproof feature request) in slitaz labs
    Now that you can handle the forum make more readable the post about getopenoffice, i would delete the new one and put solved in the original topic title :-)
  • erniaernia October 2010
    this /etc/init.d/cupsd does not let you start two istances of cups:
    # /etc/init.d/cups: Start, stop and restart Cups deamon on SliTaz, at boot
    # time or with the command line.
    # To start daemon at boot time, just put the right name in the $RUN_DAEMONS
    # variable of /etc/rcS.conf and configure options with /etc/daemons.conf.
    . /etc/init.d/rc.functions
    . /etc/daemons.conf

    DESC="cups deamon"

    case "$1" in
    echo -n "Stopping $DESC: $NAME... "
    killall -q cupsd
    rm -f $PIDFILE
    if [ ! -e $PIDFILE ] ; then
    echo -n "Starting $DESC: $NAME... "
    echo -n "Not starting $DESC: $DESC is already running"
    echo ""
    echo -e "\033[1mUsage:\033[0m /etc/init.d/`basename $0` [start|stop]"
    echo ""
    exit 1

    exit 0

    i've submitted it in slitaz labs, if you trust me you can download it from here:
  • 788pkn788pkn March 2011
    Yesterday I managed to configure my HP 6500 Officejet as a network printer using the cups admin web page (after downloading and unpacking the hplip source (3.11.1) to get the right ppd file).
    Today when I started up and logged in, the webpage (localhost:631) wasn't available. When I grepped for cupsd in the output of ps, it wasn't there.
    Is the cups installer supposed to modify rcS.conf to put it into the DAEMONS section? Are you supposed to always run the cups daemon manually?
    I faithfully followed the installation docs to do everything right (they're now a little out of date for slitaz 3.0 as the cups configuration has changed), but I'm not sure about the daemon thing. Did I miss a step?
    I made the mod to rcS.conf and rebooted. Now I can print again!

    Thanks for an awesome distro that runs like a charm on my ancient Emachines M5305 laptop.
  • mojomojo March 2011
    The cups post_install script starts cupsd once when it's installed and stops it if it's running in pre_remove.
    The user has to add cups to RUN_DAEMONS of /etc/rcS.conf so it will autostart on every boot.
    Not what I'd call user friendly.
  • Trixar_zaTrixar_za March 2011
    The post_install script could be made to add cupsd to RUN_DAEMONS... but I'm not sure people would want that :/

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social