This is the old SliTaz forum - Please use the main

Request : boot screen
  • molmol October 2010
    how can one hide the booting code ?
  • seawolfseawolf October 2010
    You can add 'quiet' to the kernel line in GRUB to hide the kernel output; all the other messages could probably be hidden by removing all the 'print' / 'status' lines in each /etc/init.d script. The latter would probably be reverted on each upgrade of slitaz-boot-scripts and packages such as MySQL that put scripts there.

    The idea of a splash screen has been mentioned before, it would no doubt require some regeneration of initramfs or suchlike as well as other (root) user-level configuration.

    Anyone have better ideas?
  • ms3811ms3811 November 2010
    To display a custom background instead of the default for grub, you can upgrade to grub2 (it's easier, although grub1 also supports a background, I couldn't get it to work).

    To replace the kernel messages with an image/progress bar, try splashy (
  • seawolfseawolf November 2010
    Good spot with Splashy. I quickly compiled DirectFB from the Undigest repo okay (after modification to v1.1.1) and converted Debian's Splashy packages, in which three libs need symlinking). It was then a matter of adding vga=0x315 (intel fb) to GRUB and inserting Splashy's progress reports at various stages of /etc/init.d/rcS.

    It doesn't seem to be particularly well maintained though, the latest package I can see is from 2008?

    Still one to look at if it works however.
  • panksopankso November 2010

    @seawolf I have done some quick test with Busybox fbsplash and we could easely use it I think. Will do some investigations these days.
  • ms3811ms3811 November 2010
    Seems like it works better with grub1 atleast on Slitaz. I had a lot of trouble getting it to work using grub2. In any case, you guys seem to have made better progress than I have, but splashy seems to be an easier workaround to patching the kernel.

    Which brings to the question: Theoretically speaking, wouldn't patching the kernel be more efficient? Especially if the goal is to have a light and fast distro? Am I wrong in assuming that using an external tool such as splashy, although easier, would unnecessarily increase the burden on the distro size?
  • ms3811ms3811 November 2010
    @seawolf, did you manage to get the splash screen to display on bootup? I set the parameters in menu.lst "vga=791 splash" and on bootup the resolution changes and I get a penguin on the top left corner of the screen, but no splash. When I try to run "splashy test" the screen briefly blanks and then returns to the prompt with the error "Splashy ERROR: Couldn't splashy_start_splashy(). Error -3".

    Also attempting to run splashy from /etc/init.d/ throws the following error "Could not read file /lib/lsb/init-functions. Please install lsb-base". Since Slitaz uses /etc/init.d/functions, what's the workaround for this?

  • seawolfseawolf November 2010
    Yes, @ms3811, I did. Instead of putting splashy in the Run Daemons, I inserted the following lines in /etc/init.d/rcS at various points:

    echo -n "Starting Splashy... "
    /sbin/splashy boot

    splashy_update "progress 5" 2> /dev/null...
    splashy_update exit

    As the penguin appears, you have frame-buffering and the video mode okay, good start.
    seems to show the -3 message as "connection refused" and complaints about the version of (lib)DirectFB. As I said I had to alter the version number from the undigest receipt before building it, and symlink a little to get the correct versions of the *.so* files it looks for. Check the installation/requirements page, it lists them in good detail.

    (Side note: I think a -2 error i means that the framebuffer/modesetting/expected video mode isn't enabled.)
  • ms3811ms3811 November 2010
    I actually downloaded libdirectfb from debian and converted to tazpkg to install. But it's version 1.0.*. I guess I will need to try to get it 0.9.22. If I add the lines in /etc/rcS as shown in your post, I get a Error -3. Connection refused at boot time.

    Thanks so much for the response.
  • seawolfseawolf November 2010
    Hmmm, I've v1.1.1 of directfb proper:

    seawolf@sammy:~ $ tazpkg search direct

    Search result for : direct

    Installed packages
    coreutils-directory 7.6 system-tools
    coreutils-redirection 7.6 system-tools
    directfb 1.1.1 system-tools
    3 installed package(s) found for : direct

    seawolf@sammy:~ $ ls /usr/lib/libdirect* -l
    lrwxrwxrwx 1 root root 27 2010-11-02 10:43 /usr/lib/ -> /usr/lib/
    lrwxrwxrwx 1 root root 22 2010-11-02 09:52 /usr/lib/ ->
    -rwxr-xr-x 1 root root 80948 2010-11-02 09:42 /usr/lib/
    lrwxrwxrwx 1 root root 29 2010-11-02 10:39 /usr/lib/ -> /usr/lib/
    lrwxrwxrwx 1 root root 24 2010-11-02 09:52 /usr/lib/ ->
    -rwxr-xr-x 1 root root 467668 2010-11-02 09:42 /usr/lib/
    lrwxrwxrwx 1 root root 24 2010-11-02 09:52 /usr/lib/ ->
    lrwxrwxrwx 1 root root 22 2010-11-02 09:52 /usr/lib/ ->

    seawolf@sammy:~ $

    I'm not too sure what's going on without playing around, I think I just was lucky!
  • ms3811ms3811 November 2010
    Hm. I installed libdirectfb from the debian site and the latest available there was 1.0. As of now I cannot get past the -3 error. I guess I can find 1.1 and try that as well.
  • ms3811ms3811 November 2010
    Can you tell me where I can get libdirectfb-1.1? I can only find 1.2. Sorry for the bother (I tried 1.2, same error).

    Also, I have noticed, whenever I add the parameter vga=791 in menu.lst, I cannot get the text screen if I kill xorg. If I hit CTRL + ALT + BACKSPACE, xorg is killed but I get only a blank screen. It seems to be a display only issue, because I can type blind and login as root and reboot the box. Removing vga=791 eliminates this issue.
  • seawolfseawolf November 2010
    No bother, I saw that directfb was in the Undigest repo so I just modified the receipt and built it. I've put my version in my DropBox:

    I had to see which video modes were supported by my card; I used vga=12345 with one boot (edited GRUB directly before boot) and it listed the available modes. I think this has to do with whether mode-setting is turned on/off. My Intel chip has been very picky before, especially on Fedora WRT brightness control, the Plymouth graphical boot-up screen and text-mode. I think with mode-setting off it has finally found a compromise! It confuses me the number of things that one has to configure here!

    I do wonder if there is any text-based theme we could use so we don't have to configure everything...!

    Good luck!
  • ms3811ms3811 November 2010
    Thanks. I'll give it another shot before giving up :).

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social