This is the old SliTaz forum - Please use the main

[SOLVED] open office install
  • wetterauwetterau October 2010
    Hi, am unable to install working oo. pkgmanager says it is installed, but only the files are in /usr/share/applications and are without icons. No error messages. Have no idea what to try next. Thanks, john
    SOLUTION: use ernia's script (provided in the comment below) to get-install OpenOffice3. The comment provides a link to a free hosting site which allows a download of the script after a one minute wait. Follow ernia's instructions.
  • ChristopheChristophe October 2010
    Though I cannot point you directly to it, there has been a dicussion about this recently (i believe it was in the french forum) with instruction on what to change to make the script work.

    You may want to try to download a .deb file and convert it then install it

    May or may not work.

    You may also try the Go-OO package here
    it has a better support for macros and is used by ubuntu. also advertised to be faster.
  • babaorumbabaorum October 2010
    You also have a stable OpenOffice Slitaz package shared by bittorent here
    This is a stable version that I've been using daily on Slitaz 3.0 stable w/o any trouble.
  • _ez182_ez182 October 2010
    I installed mine with the help of this thread:

    The script get-OpenOffice3 seems to be broken. So after installing the package "get-OpenOffice3" I edited the file
    and did the following changes:
    Line 19: SUFFIX="Linux_x86_install-rpm_en-US.tar.gz";;
    Line 22: VERSION="3.2.1"

    Finally I run /usr/bin/get-OpenOffice3 manually (as root).
  • erniaernia October 2010
    In this way you loose the ability to get new versions and different localizations.
    The problem is due to a change in filenames in the download server, if you subsitute the content of /usr/bin/get-OpenOffice3 with

    # get-OpenOffice3, install everything for exept KDE/Gnome integration and testsuite.
    # (C) 2008 SliTaz - GNU General Public License v3.
    # Author : Eric Joseph-Alexandre


    case "$LANG" in

    VERSION="$(basename $(wget -O -$DIR/ \
    2> /dev/null | grep href=\"[0-9] | tail -1 | sed 's/.*href=\"\(.*\)\".*/\1/'))"
    if [ -z "$VERSION" ]; then
    echo "Can't find VERSION. Abort."
    exit 0
    LOG="/tmp/$(basename $0 .sh).log"

    # Status function with color (supported by Ash).
    local CHECK=$?
    echo -en "\\033[70G[ "
    if [ $CHECK = 0 ]; then
    echo -en "\\033[1;33mOK"
    echo -en "\\033[1;31mFailed"
    echo -e "\\033[0;39m ]"
    return $CHECK

    # Check if user is root to install, or remove packages.
    if test $(id -u) != 0 ; then
    echo -e "\nYou must be root to run `basename $0` with this option."
    echo -e "Please use 'su' and root password to become super-user.\n"
    exit 0

    # Avoid reinstall
    if [ -d $ROOT/var/lib/tazpkg/installed/$PACKAGE ];then
    return 0
    return 1

    #We need to bee root

    #check if package already installed
    if (check_if_installed $PACKAGE); then
    echo "$PACKAGE is already installed."
    [ -n "$ROOT" ] && exit 0
    echo -n "Would you like to remove and reinstall this package [y/n]? "
    read answer
    case "$answer" in
    tazpkg remove $PACKAGE ;;
    exit 0 ;;


    # Check if we have the tarball before.
    if [ ! -f $SOURCE_DIR/$TARBALL ]; then
    echo "Downloading tarball (it's time to have a break)... "
    #Check if $SOURCE_DIR exist
    test -d $SOURCE_DIR || mkdir -p $SOURCE_DIR
    # Get the file.

    # Creates TEMP_DIR and extract tarball
    mkdir -p $TEMP_DIR
    echo -n "Extract files from archive..."
    tar xvzf $SOURCE_DIR/$TARBALL -C $TEMP_DIR > $LOG 2>&1 || \
    (echo "Failed to extract $TARBALL" ; exit 1)

    # extracted pkg can be removed: Save RAM
    rm -rf $SOURCE_DIR

    cd $TEMP_DIR/*/RPMS

    # Extract everything from RPMS
    for i in *.rpm
    if (! echo $i | egrep -qi $EXCLUDE); then
    (rpm2cpio $i | cpio -id >> $LOG 2>&1 ) && rm -f $i
    rpm2cpio desktop-integration/*freedesktop*.rpm | cpio -id >> $LOG 2>&1

    # extracted pkg can be removed: Save RAM
    rm -f desktop-integration/*freedesktop*.rpm

    # Make the package
    mkdir -p $PACKAGE-$VERSION/fs/usr/lib/openoffice \

    # use mv instead of 'cp -a' to save RAM
    mv opt/openoffice* $PACKAGE-$VERSION/fs/usr/lib/openoffice
    mv usr/share/mime $PACKAGE-$VERSION/fs/usr/share
    mv usr/share/icons $PACKAGE-$VERSION/fs/usr/share
    mv usr/bin $PACKAGE-$VERSION/fs/usr

    # relocalized OOo libexec directory
    sed -i 's#/opt/#/usr/lib/openoffice/#' $PACKAGE-$VERSION/fs/usr/bin/openoffice*

    # Create receipt
    cat > $PACKAGE-$VERSION/receipt <<EOT<br /># SliTaz package receipt.

    SHORT_DESC="Productivity suite."

    cd /usr/share/applications
    ln -s /usr/lib/openoffice/openoffice.org3/share/xdg/base.desktop openoffice.org3-base.desktop
    ln -s /usr/lib/openoffice/openoffice.org3/share/xdg/impress.desktop openoffice.org3-impress.desktop
    ln -s /usr/lib/openoffice/openoffice.org3/share/xdg/writer.desktop openoffice.org3-writer.desktop
    ln -s /usr/lib/openoffice/openoffice.org3/share/xdg/calc.desktop openoffice.org3-calc.desktop
    ln -s /usr/lib/openoffice/openoffice.org3/share/xdg/math.desktop openoffice.org3-math.desktop
    ln -s /usr/lib/openoffice/openoffice.org3/share/xdg/draw.desktop openoffice.org3-draw.desktop
    ln -s /usr/lib/openoffice/openoffice.org3/share/xdg/printeradmin.desktop openoffice.org3-printeradmin.desktop

    cd /usr/bin
    ln -sf /usr/lib/openoffice/openoffice.org3/program/soffice

    rm -f /usr/share/applications/openoffice.org3-*


    # Pack
    tazpkg pack $PACKAGE-$VERSION

    # Clean to save RAM memory
    rm -rf $PACKAGE-$VERSION

    # Install pseudo package
    tazpkg install $PACKAGE-$VERSION.tazpkg --root=$ROOT

    # Clean
    rm -rf $TEMP_DIR

    eventually editing it to match your locale.
    it worked for me, i've installed openoffice right now.
    you can dowload it here:

    if it works put SOLVED in the topic title
  • wetterauwetterau October 2010
    Thank you all for your suggestions. I thought it might be helpful to try ernia's get script, so I downloaded it and followed instructions. It worked perfectly. Very good work!
  • wetterauwetterau October 2010
    Thank you all for your suggestions. I thought it might be helpful to try ernia's get script, so I downloaded it and followed instructions. It worked perfectly. Very good work!
  • harrungharrung December 2010
    Just tried to run this script.

    Always I get following:
    BusyBox v1.12.0 (2010-11-30 13:25:03 CET) multi-call binary
    Usage: basename FILE [SUFFIX]

    Strip directory path and suffixes from FILE.
    If specified, also remove any trailing SUFFIX.

    Can't find VERSION. Abort.

    What the hell does he want from me? I installed OpenOffice two month ago. Just changed the suffix and ran the new script. But now I don´t know further!

    Could need some help!

  • erniaernia December 2010 is not active anymore, script should be modified.
    if you don't have time to debug the script change VERSION="$(basename ...
    with VERSION="3.2.1" and check if it works
  • gdesilvagdesilva December 2010
    Yes, specifying the version number fixes the problem.
  • gdesilvagdesilva December 2010
    Yes, specifying the version number fixes the problem.
  • michaelkbischofmichaelkbischof January 2011
    No, if I follow the description it does not work right now (6.1.2011). Any suggestions here? I want to avoid to use too much RAM. Is anywhere a ,,ready package" available?

    [A little more information for the cracks in this forum: today I wanted to write a contribution with Midori on a 3.0-hdd-install Slitaz. It was impossible: this page was never correctly shown though I was logged in]
  • erniaernia January 2011
    what does it mean "it does not work"? may you please be more verbose about it :-) ?
    does the download start or not? did you change the two-row
    VERSION="$(basename $(wget -O -$DIR/ \
     2> /dev/null | grep href=\"[0-9] | tail -1 | sed 's/.*href=\"\(.*\)\".*/\1/'))"
  • michaelkbischofmichaelkbischof January 2011
    Yes, I did - but apparently I did it wrong? Now I have corrected it - but still no success:

    root@slitaz:/home/michael/Downloads# get-OpenOffice3
    Downloading tarball (it's time to have a break)...
    Connecting to (
    wget: bad response to RETR: 550 Failed to open file.
                                                                         [ Failed ]
    Could not download OOo_.2.1_Linux_x86_install-rpm_de.tar.gz. Exiting.

  • kultexkultex January 2011
    I think, that was down, when you tried to install - now it is up.
    I have tried it a year ago and it worked just by changing the wget adress - just checking a acual download adress - you are german - so here:

    and the correct wget adress would be now - it changes quite often:

    but I did not try it since then, because I use softmaker office
  • erniaernia January 2011
    did you downolad and edit the script from the link that you can find ten posts above ?
    i don't remember well but i should have edited the repo file to correct some problem when i posted it and it donwnload the tarball if i change VERSION in it.
    your file is where it should be:
  • michaelkbischofmichaelkbischof January 2011
    Thank you, ernia,

    now it works and started the download. Even the German version!
    As a newbie to Slitaz I may ask:
    in case the program is installed (it must have been changed from the tar.gz-Version to a tazpkg-Version, yes?) how could I store this tazpkg-file extra on my PC - as I intend to hand it over to other people?
    Background: I am a teacher and I have to do with pupils that do not understand well about IT-related things, as opposite to the main gossip German school kids do not ,,know" more than to apply MS Word.
    I like Slitaz not that much because it is small but becaue it is much more easy to understand (if installed on the harddrive) than other Linuxes. In former times I used Xwoaf for this purpose (a Linux with Xserver on a boot-floppy) that this is deprecated now.

    Thanks a lot for your help! This encourages me to put one more question: wouldn't it be possible to apply the same thing to the program kompozer?
    The download URL is

    , but I do not know whether I could just put it into your OpenOffice-script,rename it to get-Kompozer and act correspondingly. By the way: your modified script that works just now (the download is not finished) is attached below.

    Yours sincerely,

  • erniaernia January 2011
    the script is not mine, it's an adapted version of slitaz's one, i can barely understand what it does :-)
    if you need the pkg you can edit the end of the script to make the script to copy the package somewhere before to install and delete it, eg putting
    $PACKAGE-$VERSION.tazpkg /home/tux (or your username)
    tazpkg install $PACKAGE-$VERSION.tazpkg --root=$ROOT
    same principle can be applied to all of the get-* packages
    i don't think that slitaz is so simple, and i can't help you with your kompozer problem, search for similar packages or read cookbook in docs
    you could open a thread about Kompozer, maybe someone has alredy done it
  • michaelkbischofmichaelkbischof January 2011
    Now OpenOffice is installed and worked. The registration process asked me for a working Installation of Java on my PC. As I hadn't installed one the registration for claiming future updates went wrong. After I had installed java-jre (1.6.1) it was not possible to retry it: Sun said this page is outdated.

    [To attach the successful file was did not work. I try it again now]
  • kultexkultex January 2011
    I think you can install compozer like this:

    there is no need for a script, because it is not a .deb or .rpm
  • michaelkbischofmichaelkbischof January 2011
    Yes, thank you very much kultex! Worked like a charm, in a second. Nice, so I can easily give away this software as well to other people.
    After I have now installed OpenOffice on this slitaz installation the only remaining question is: is it possible to get one tazpkg-package out of this program on my machine? My aim is to store it as a *.pkg and then forward it.
    [I try it the 3. time to attach a file: I work under Firefox on slitaz as Midori crashes cannot be used with this website. I login but I cannot write a draft...after attaching this little file of 4,6 KB Firefox tells me all the time: ,,Uploading..." but may be this does not happen? Anyway, this issue we might solve with PM]
  • erniaernia January 2011
    did you read my previous post?
  • michaelkbischofmichaelkbischof January 2011
    thank you, I had overlooked your previous post. Ok, I will try this the next time on another machine. The CPU-load doing such an install is so heavy that one tends to do that only once! The Kompozer problem is solved by the contribution of kultex.

    Slitaz is not that easy? Well, to understand it thoroughly it might not be easy: but if you have installed it on hd the remaining problem is to understand how to make own pkg-files. Installing something ready is incredibly quick.
    If you imagine that such a plain install is 242 MB, with firefox and some extras I was at 400 MB, including OpenOffice (and still something to clean on it) I am at 970 MB.
    To remember: a fresh install of Windows7 is 8,4 GB, naked (!). In old times Windows 98 claimed about 600 MB (the Nerds could bring it down to about 450 MB). Plus: the working speed you cannot compare! Anything under win97 on a quick machine takes much more time, especially manoevering within the file system. Not that there are no issues with Slitaz. But it is a nice community, very international. I enhance the idea of ,,open" where I can, against approaches of Apple, Facebook etc.

    => Anybody who wants the changed script that worked here my try PM to me. I simply cannot move Firefox to upload this little thing.
  • kultexkultex January 2011
    there are quite a lot more programs in cooking (still buggy), but you can also try tazpkg convert

    Converts a Debian package (.deb), Redhat (.rpm), Slackware (.tgz) or Archlinux (.pkg.tar.gz) package into a SliTaz package (.tazpkg):

  • michaelkbischofmichaelkbischof January 2011
    Thank you, kultex! Funny: on another machine I tried (see above) to install Kompozer 0.8 (under Slitaz 3.0) and it worked immedialy. With a laptop, but Slitaz 3.0 as well, it did not work.
    To convert Kompozer 0.7 from a .deb-file was successful; but for a 8 MB-program it took 20' with very heavy CPU-load. So I would not do that again. The .tazpkg-package works, though and I am ready to give it away to anybody who wants it. Just how to do it I do not know. PM?
    May be later I might try with ,,tazpkg repack" to make a tazpkg-package out of the already installed OpenOffice.
  • avamkavamk January 2011
    By the way, are there plans for a package for the newer LibreOffice?
  • Trixar_zaTrixar_za January 2011
    LibreOffice isn't exactly newer.

    It's just a free fork of OpenOffice because Oracle decide to sell a fully featured OpenOffice (called StarOffice) and change the old OpenOffice to be a semi-closed sourced 'free' and cutdown alternative. It's still in early development and internationalization. At the moment GO-OO is currently futher along in development than LibreOffice.
  • seawolfseawolf January 2011
    I've put get-LibreOffice in Cooking anyways. If you're on Stable, just download the get-LibreOffice/stuff/get-LibreOffice script from the repos website -- -- and run it as root.
  • erniaernia January 2011
    Thanks, seawolf
    if i did not get it wromg Go-oo patches to openoffice are already in Libreoffice
  • avamkavamk January 2011
    @ Trixar_za: thanks for the info.
    @ seawolf: thanks for putting it in Cooking!
  • Trixar_zaTrixar_za January 2011
    @ernia Ok, then it might be of some use. It's still a pretty early fork considering that Oracle made it's move pretty unexpectantly. Hopefully they got the internationalization up to scratch since I last tried it.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social