This is the old SliTaz forum - Please use the main

[SOLVED] no WLAN with broadcom (acer extensa)
  • kernelpanickernelpanic November 2009
    hello everybody,

    didn`t succeed in getting WLAN working on my notebook acer extensa (built-in broadcom wireless).

    tried it with b43-firmware and module b43, which I think should be the correct ones. no luck.
    then I looked up what driver windows vista (yes ... it`s still there) is using, tried to install this one with ndiswrapper, again no luck.
    am I doing something wrong here?

    my ubuntu-based distro "wattos" uses a linux driver that works well.
    is there any chance to use it in slitaz?
    thanks for any help!
  • jozeejozee November 2009
    I have a broadcom card too. All broadcom wireless cards are now fully supported in slitaz (wl driver, the new broadcom driver, being the latest commit: ). We have also rebuilt the linux package. Rebuilt linux pkg is now compatible with the latest broadcom drivers (now there is no problem with "ssb" module). Hopefully its on the mirrors. Can you recharge and upgrade your system again? Ndiswrapper will also work now on broadcom drivers. You can also download the linux pkgs from my undigest dir:

  • kernelpanickernelpanic November 2009
    thanks for your answer, jozee!

    no, the broadcom driver is not on the mirror yet. I downloaded it from your undigest dir and installed it via tazpkg install. still no success. to be sure I have the latest version I also reinstalled the linux-wireless pkg. still no contact to my WLAN.

    finally I gave slitaz a fresh reinstall on my HD (Acer Extensa 5220 Notebook), just to make sure there was no old driver sitting somewhere in the system and installed linux-wireless and broadcom-wl again.
    it still doesn't work. eth0-connection is working fine. now I`m pretty much much out of ideas.

  • jozeejozee November 2009
    You also need to download the linux package. Also post your lspci | grep Network
  • kernelpanickernelpanic November 2009
    tux@slitaz:~$ lspci | grep Network
    04:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)

    ok, upgraded the linux package (since I wasn`t sure if the package on the mirror is the latest, I downloaded it from your undigest dir and installed it via tazpkg install --forced.
    still no contact to my WLAN.

    broadcom-wl driver is installed. is there some way to recognize if I really have the latest linux package supporting broadcom wl-driver?
  • jozeejozee November 2009
    After installing linux pkg, reboot. Then,

    modprobe wl
    dmesg | tail
    /etc/init.d/ restart
    ifconfig -a

    Do the above. If "modprobe" didn't give any errors, you are using new linux package. If network is not up, try ndiswrapper. It should also work with the new linux pkg.

    If nothing works, post the output of above code.
  • jozeejozee November 2009
    @kernelpanic : I was going through the old forums archive and thought this post of mine would be helpful to you :
  • kernelpanickernelpanic November 2009
    @jozee : doing modprobe wl gives follwing results:

    (sorry, I didn`t figure out how to set codelines in those nice formatting yellow boxes...)

    tux@slitaz:~$ modprobe wl
    insmod: cannot insert '/lib/modules/': Operation not permitted
    insmod: cannot insert '/lib/modules/': Operation not permitted
    modprobe: failed to load module wl: No such file or directory

    does this tell me that I am NOT using the updated linux package? (I forced tazpkg install of linux- from your undigest dir).

    tux@slitaz:~$ dmesg | tail
    pcmcia_socket pcmcia_socket0: cs: IO port probe 0x100-0x3af: clean.
    pcmcia_socket pcmcia_socket0: cs: IO port probe 0x3e0-0x4ff: excluding 0x4d0-0x4d7
    pcmcia_socket pcmcia_socket0: cs: IO port probe 0x820-0x8ff: clean.
    pcmcia_socket pcmcia_socket0: cs: IO port probe 0xc00-0xcf7: clean.
    pcmcia_socket pcmcia_socket0: cs: IO port probe 0xa00-0xaff: clean.
    Adding 1445808k swap on /dev/sda7. Priority:-1 extents:1 across:1445808k
    tg3 0000:02:00.0: wake-up capability disabled by ACPI
    tg3 0000:02:00.0: PME# disabled
    tg3: eth0: Link is up at 100 Mbps, full duplex.
    tg3: eth0: Flow control is on for TX and on for RX.

    does this tell you anything what the problem is?

    tomorrow I will work through the old posts you gave me, maybe I get some idea there.
    anyway ... thankyou for your help!
  • jozeejozee November 2009
    @kernelpanic: you need to be "root" to do "modprobe" :-) . For formatting, read Erjo's post in Announcements.
  • octaviooctavio November 2009
    hey, first of all, check that you have the driver up by typing "lsmod" if the b43 driver is not there u must load it with the command "modprobe b43". If u can't load it, then u should post new discussion. Bytheway b43 and bcm43xx will not support PCI ID 14e4:4315 and Wireless-N cards
    to determine the PCI ID of your wireless device under linux, enter "lspci -nn", but is always better if u try.
    "depmode -ae" then "modprobe b43".\\
    be shure u have the modules in ur distribution.
  • kernelpanickernelpanic November 2009
    @jozee: thanks for the hint with "root" ... should have figured that out for myself ;-)
    ok, running modprobe wl doesn`t give any errors, so I think I`m using the updated linux package.

    dmesg | tail showes the following:
    tg3: eth0: Flow control is on for TX and on for RX.
    lib80211: common routines for IEEE802.11 drivers
    lib80211_crypt: registered algorithm 'NULL'
    wl: module license 'unspecified' taints kernel.
    Disabling lock debugging due to kernel taint
    wl 0000:04:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
    wl 0000:04:00.0: setting latency timer to 64
    eth1 (wl): not using net_device_ops yet
    lib80211_crypt: registered algorithm 'TKIP'
    eth1: Broadcom BCM4311 802.11 Wireless Controller

    /etc/init.d/ restart:

    Stopping all interfaces
    ifconfig: SIOCGIFFLAGS: No such device
    Killing all daemons
    wlan0 No such device

    Starting udhcpc client on: eth0...
    udhcpc (v1.12.0) started
    Sending discover...
    Sending discover...
    Sending discover...
    No lease, forking to background

    so all I can figure out is "wlan0 No such device" ... what now? ;-)

    @octavio: I tried to use the b43 driver with "wireless manager" and had no success.
    that`s the reason why I installed the broadcomm-wl from jozee`s packages dir.
    obviously I`m doing something wrong here, because both drivers are not working for my BCM4311 adapter.

    sorry guys for my dumb questions, but I`m not very experienced in linux yet, so the command line code details look very cryptic for me and don`t tell me too much.

    since slitaz obviously is a distro for experienced users, why do I use it then?
    because I just love this "race cart feeling", and we all learn by doing, don`t we?

    thanks for your patience and help! :-)
  • jozeejozee November 2009
    @Kernelpanic: BCM4311 needs wl driver as per broadcom site. Your questions are not dumb. We all want everything to go smooth. But this type of debugging exercise helps and gives you a lot more confidence in linux.

    Hey, your dmesg output looks good. It seems your card is recognized. Interface is "eth1" and not "wlan0". I also have "eth1".

    Now, the last problem is "ifconfig: SIOCGIFFLAGS: No such device ". This problem may occur for few reasons. Please check if your card is not disabled in BIOS.

    Actually, is smart enough to change wlan0 to eth1 automatically. But lets do it manually. Please change "wlan0" (default value) to "eth1" using Wireless Configuration Manager (Configuration tab).

    Then after modprobe wl, can you also do
    ifconfig eth1 up

    Let me know the output. I hope it works
  • kernelpanickernelpanic November 2009
    @jozee: my card is not disabled in bios, because I can use it with onother linux-distri (wattOS, ubuntu-based).

    following your suggestions I changed "wlan0" to "eth1".

    modprobe wl returns no errors.


    Module Size Used by Tainted: P
    lib80211_crypt_tkip 7608 0
    wl 1269612 0
    lib80211 4804 2 lib80211_crypt_tkip,wl
    yenta_socket 20988 0
    rsrc_nonstatic 9136 1 yenta_socket
    pcmcia_core 27628 2 yenta_socket,rsrc_nonstatic
    tg3 93600 0
    libphy 16236 1 tg3
    snd_hda_codec_realtek 178336 1
    snd_hda_intel 21200 1
    snd_hda_codec 47116 2 snd_hda_codec_realtek,snd_hda_intel
    snd_pcm 51780 2 snd_hda_intel,snd_hda_codec
    snd_timer 16344 1 snd_pcm
    snd 43584 7 snd_hda_codec_realtek,snd_hda_intel,snd_hda_code
    soundcore 5180 1 snd
    snd_page_alloc 7256 2 snd_hda_intel,snd_pcm

    iwconfig gives following result:

    lo no wireless extensions.

    dummy0 no wireless extensions.

    eth0 no wireless extensions.

    eth1 IEEE 802.11bg ESSID:"" Nickname:""
    Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
    Bit Rate:54 Mb/s Tx-Power:32 dBm
    Retry min limit:7 RTS thr:off Fragment thr:off
    Power Managementmode:All packets received
    Link Quality=5/5 Signal level=0 dBm Noise level=0 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    still no contact to my WLAN :-(
  • jozeejozee November 2009
    Everything looks good. Still no WLAN, this must be really frustating :-(

    BTW, can you do this in order:

    modprobe wl
    dmesg | tail
    ifconfig eth1 up
    ifconfig -a
    /etc/init.d/ restart
    ifconfig -a

    I want to check if you still get "ifconfig: SIOCGIFFLAGS: No such device " errors. If not, then everything should work. If its still not working, please check the Wireless Configuration manager for any possible typo in your network name and/or passwd. Also, if no errors, use "control box" -> Initialization Tab -> Load modules (at startup) and add wl to it. Reboot. Sometime everything works after reboot.

  • kernelpanickernelpanic November 2009
    @jozee: WLAN works!!!!

    I followed your advices, and I don`t know exactly WHAT it was ...
    I think it worked after I added wl to "Load modules" and rebootet.

    thank you so much for your help!!! :-)))
  • jozeejozee November 2009
    great!!!. Please also edit the discussion title and add "SOLVED"
This discussion has been closed.
← All Discussions

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social