This is the old SliTaz forum - Please use the main

Atheros AR2425 dhcp issues [SOLVED]
  • ms3811ms3811 August 2010
    My Dell laptop has a Atheros 2425 chipset wireless card. Slitaz automatically detected and installed the driver for it (ath5k), but I cannot seem to get it to connect to the wireless router. Udhcpc simply keeps sending discovers with no luck. I read in many places that there is an issue with this card with most Linux kernels. There appears to be a solution (, but that requires compiling the driver (not too comfortable with that).

    Does anyone know of another solution to this issue?

    Ps: The router is configured for WPA2-Personal.

    lspci | grep Atheros returns:

    0c:00.0 Network controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)

    dmesg | grep Atheros returns:

    ath5k phy0: Atheros AR2425 chip found (MAC: 0xe2, PHY: 0x70)
    Atheros(R) AR8121/AR8113/AR8114/AR8131/AR8132 PCI-E Ethernet Network Driver - version
    Copyright (c) 2007 - 2009 Atheros Corporation.
    ath5k phy1: Atheros AR2425 chip found (MAC: 0xe2, PHY: 0x70)
  • ms3811ms3811 September 2010
  • kultexkultex September 2010
    can you give the output of

    iwlist wlan0 scan
    or whatever your wlan is named like wlan0 eth1....
  • ms3811ms3811 September 2010
    it randomly alternates between:

    wlan0 No scan results


    wlan0 Interface doesn't support scanning : Device or resource busy
  • kultexkultex September 2010
    it seems, that the module is not loaded - check with lsmod if ath5k is present - if not load it as root with modprobe ath5k
  • Trixar_zaTrixar_za September 2010
    If it's not being loaded, you have to added it @ menu--->system tools--->control box--->initailization--->load modules

    This should load ath5k module everytime the machine is started now.
  • ms3811ms3811 September 2010
    I'm quite sure it is loading, I remember checking with lsmod to see if ath5k is present. in any case I'll confirm, also it's definitely in rcS.conf.
  • ms3811ms3811 September 2010
    so yes, it is loaded, I also tried rmmod ath5k, then modprobe ath5k, then restart, just to be sure. This is the output of restart:

    Stopping all interfaces
    Killing all daemons
    killall: udhcpc: no process killed
    Shutting down wifi card
    Configuring wlan0...
    Starting wpa_supplicant for WPA-PSK...
    Starting udhcpc client on: wlan0...
    Selected interface 'wlan0'

    Typically after the above, atleast with my other laptops that use wl, in a few seconds udhcpc will procure an ip address. However, with this laptop that never happens.

    One other thing that's a bit unusual. ifconfig outputs three interfaces, 1. the default loopback adapter, 2. wlan0 and 3. wmaster0. Now I have never seen wmaster0 anywhere else except with this laptop. This interface has the same MAC as wlan0 except the MAC is followed by quite a few 00-00-00s. The Link encap says UNSPEC. Not sure if this is helpful, but thought I would mention it.

    Thanks for taking the time.
  • ms3811ms3811 September 2010
    any ideas where I can look next?
  • kultexkultex September 2010
    what I would do - take another distro and look if and how it is working there
  • ms3811ms3811 September 2010
    ouch! that laptop has a lot of stuff on it. I've been using it for awhile with a wired connection.

    In the post,

    jozee has a fix, but its for the Ar8132 chipset. I need something similar. Maybe I will just have to compile the driver for this box -- just that compiling stuff is really not my cup of tea. I've done it before, so I guess it's time to do it again :(!
  • ms3811ms3811 September 2010
    ok, this is kinda embarrassing. Turns out the wireless radio was off :|!!!

    So I turned it on by pressing [Fn]+[F11] (button with the wireless antenna icon), then restarted network and bingo.

    Sorry for wasting everyone's time and thanks for taking the trouble to try and help.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social