This is the old SliTaz forum - Please use the main

tazpkg fs.cpio.gz not found... fs.cpio.lzma?
  • darkdragndarkdragn February 2010
    Kept getting fs.cpio.gz not found with every install i tried, so i get a little fed up, ran the file through cpio (copy-in mode) and much to my surprise the fs.cpio.gz was instead fs.cpio.lzma. Ran a quick decompress, ran it through gzip, and threw it back into an archive with the same name as the orig file and it installed perfectly.
    The new lzma compression sure will save space, but is there an update for tazpkg to actually use it yet? lol, Nice surprise though guys.

    ## For anyone else wanting to do the same
    #mkdir tmp
    #cd tmp
    #cpio -id < ../$PKG_NAME.tazpkg
    #lzma d fs.cpio.lzma fs.cpio
    #gzip fs.cpio
    #rm fs.cpio.lzma
    #find . |cpio -o -H newc >../$PKG_NAME.tazpkg
    #cd ..
    #rm -R tmp
    #tazpkg install $PKG_NAME.tazpkg --forced
    ##The --forced is because even though it failed before,
    ##it thinks it's installed, >_<<br />
    I'm sorry if this has already been addressed. Oh, and if you're wondering, i just booted this across network (pxelinux), i think someone mentioned there's something wrong with the livebootable. I just mounted it and ripped the kernel and rootfs. Works like a charm except for this... Oh, and the desktop interface is beautiful. Amazing work, guys. I just wanted to let you all know, out of all of the lightweight distro's i try out for my disk-less boots, i keep coming back, because slitaz is simply amazing!
  • darkdragndarkdragn February 2010
    Looked over tazpkg, a quick change at line 393 fixes the issue. Changing it from:
    zcat fs.cpio.gz | cpio -idm && rm fs.cpio.gz

    if [ -e $TMP_DIR/fs.cpio.gz ];then
    zcat fs.cpio.gz | cpio -idm && rm fs.cpio.gz
    lzma d fs.cpio.lzma -so | cpio -idm && rm fs.cpio.lzma

    Fixes the issue. You guys can make the change, right? If you want i can put the altered tazpkg up somewhere, just ask. (I'm on the USS Bataan, right outside of Haiti at the moment, so it takes me a while to get around to putting it up... we have limited bandwidth, you understand... Plz... :/ (Yeah, i'm a 20 yr old loser in the navy, lol, you guessed right)

    Have a good day, guys.
  • plmdayplmday February 2010
    Same trouble here. But fortunately I have one machine that runs the latest SliTaz. It has not problem. I'd like to suggest that `tazpkg upgrade' first update `tazpkg' itself, then others. Then such a problem could be avoided.
  • jozeejozee February 2010
    Please refer to the recent msg on mailing list by pascal:

  • NikNik February 2010
    just wanted to know where you found that tazpkg file you looked over
    thank you
  • NikNik February 2010
    never mind...
    found it in /usr/bin/tazpkg
  • plmdayplmday February 2010
    Thanks for the link, jozee, and bellard, for the annoucement. Though I still think it's good to build into tazpkg the feature that when the user issue `tazpkg upgrade' from the CLI or does the same thing the GUI way, tazpkg first checks to see if itself needs upgrading, if it does, upgrade itself first then other installed packages. You know, this is how `pacman' of Arch Linux does. It's a nice feature.
  • jozeejozee February 2010
    good idea
  • newusernewuser February 2010
    I have tried everything wit tazpkg but nothing seems to work, always the installed list shows, If I put the cooking DVD with the packages it works ok.
    I even re-downloaded the cooking.iso still the same problem.
  • newusernewuser February 2010
    I think I solved the tazpkg mystery.
    This is what I did:
    At first I Installed the 2.6.30 kernel but that gave me more problems than it solved, for one I am using an AMD 2 core at 3GH , the system will give me a lot of erros with the loading of modules , wireless and audio will not work, the same if I download the latest cooking.iso. I extracted the iso file system thd checked the differences, copied the lzma stand alone and to be sure the complete lzma . I then went to the /etc directory and copied the slitaz directory to my system, also in init.d replaced the

    I think that is all I did remade the iso and booted from the CDROM and it read the whole thing. However I don't see any modules needing update.
  • kaldorkaldor August 2010
    thank you for the fix darkdragn, it worked!

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social