This is the old SliTaz forum - Please use the main

Sound problem
  • xorxxorx February 2010

    I've been using Slitaz for some time now, but I've a problem I've not been able to fix: sound.
    It's strange because it worked before I upgraded to the last cooking version.

    When I type alsamixer in the commad line window, I get the following error:

    tux@slitaz:~$ alsamixer
    cannot open mixer: No such file or directory

    I've added tux to the audio group just in case.

    I've noticed the following warning/errors when I boot Slitaz (log from /var/log/boot.log):
    Detecting PCI devices Kernel modules...
    * Loaded module: yenta_socket
    * Loaded module: rtl8180
    ! Missing module: snd_via82xx
    * Loaded module: snd_via82xx_modem
    > Module in use: ac
    * Loaded module: battery
    Detecting USB devices Kernel modules...
    [more stuff]
    Setting default mixer volumes...
    amixer: Mixer attach default error: No such file or directory
    amixer: Mixer attach default error: No such file or directory
    Building card database..
    [Here I got a new screen with two choices, my integrated sound car and a legacy one, I choose the first.]

    Thank you very much in advance.
  • slicelslicel February 2010
    Add any user to audio group in /etc/group and try .
  • xorxxorx February 2010
    thank you very much for your quick response.
    I followed the steps by iegubkin and now alsamixer works, but I've run into another issue:
    When I run Slitaz Packager Manager and try to install epdfview (for instance, but it happens the same with vlc) I got the following error:

    Copying libvlc-0.9.9a... [ OK ]
    Extracting libvlc-0.9.9a... 4796 blocks
    Extracting the pseudo fs... zcat: fs.cpio.gz: No such file or directory
    rm: cannot remove 'fs.cpio.gz': No such file or directory
    Installing libvlc... cp: cannot stat 'fs/*': No such file or directory
    [ Failed ]

    Thank you very much again.
  • mojomojo February 2010
    Have to upgrade to tazpkg-3.2
    root@slitaz:tazpkg get-install tazpkg --forced
  • xorxxorx February 2010
    Thank you! Works fin!
  • xorxxorx February 2010
    Hi again,

    I just upgraded to last cooking and sound is broken again.
    I did the same steps as the last time (install jozee linux-sound package and then running soundconf) and it works.
    Although I got the following warning when installing jozee package:

    WARNING: Can't read module /lib/modules/ Exec format error

    Just to inform you. Thanks!
  • mojomojo February 2010
    modprobe -l | grep ndiswrapper

    tazndis,ndiswrapper-driver,perl-core tazpkgs are not included in cooking20100221

    You could get more errors, old scripts and configurations pointing to files removed,folders renamed,paths changed, etc, during the upgrade.

    When multiple things break where do you start ?

    I never upgrade.

  • xorxxorx February 2010

    modprobe -l | grep ndiswrapper gives no output. However the file ndiswrapper.ko.gz exists in /lib/modules/

    Now I have no sound with the user tux (only with root), even if he is included in the audio group... in fact I had to change the group of /dev/snd to audio because it was set to root... but to no avail.

    alsamixer gives:
    cannot open mixer: Permission denied

  • jozeejozee February 2010
    Please see if this helps:

    download ndiswrapper (and related pkgs) from pkg manager. I am using ndiswrapper too. My linux-sound pkg was done quite sometime back. pkg format has changed after that.
  • xorxxorx February 2010
    Hi jozee,

    I did a tazpkg get-install ndiswrapper and I got some errors:

    tazpkg get-install ndiswrapper

    It downloads ndiswrapper-1.55 and its dependencies (ndiswrapper-utils-1.55,
    perl-5.10.0, libdb-4.7.25). Then it starts by installing libdb-4.7.25, perl-5.10.0, ndiswrapper-utils-1.55 and ndiswrapper-1.55:

    libdb-4.7.25 is OK.

    perl-5.10.0 casts the following errors:
    /usr/bin/tazpkg: line 42: can't open ndiswrapper/files.list: no such file
    /usr/bin/tazpkg: line 42: can't open ndiswrapper-utils/files.list: no such file

    /usr/bin/tazpkg: line 29: can't open ndiswrapper/files.list: no such file

    ndiswrapper-1.55 is OK.

    Then, I reinstall (--forced) perl, ndiswrapper-utils and ndiswrapper to see if that fixs the above errors and all seems OK.

    I do a tazpkg get-install linux-sound --forced but I got again the warning:
    WARNING: Can't read module /lib/modules/ Exec format error

    alsamixer work as root, but not as tux.

    I followed the link you gave me in your last post (it fixed my issues in last cooking, but not in this one). The file /etc/udev/rules.d/40-alsa.rules actually exists and contains the same lines.
    Executing udevadm trigger does not seem to give results to me...

    I just tried soundconf, but alsamixer keeps on insulting me with mixer: Permission denied.

    Thankyou anyway!

    P.D: How do you put code between boxes?
  • LuXLuX February 2010
    Hello Xorx,

    * Xorx has written
    How do you put code between boxes?

    Look here:


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social