This is the old SliTaz forum - Please use the main

** A little help pls, SliTaz Packages Manager
  • time4medstime4meds February 2010
    Hello, I've been using sliTaz for several weeks now, and recently I've upgraded tazpkg using "tazpkg get-install tazpkg --forced" and now the gui will only show 'installed' and does not list 'installable' No matter what I do, the
    recharge does not solve the problem. If I do a "tazpkg upgrade from terminal, it provides a very long list of all
    my installed programs, and tells me to upgrade to the exact same version (for every pkg). Is there any way to 'reset' or somehow fix this, I miss the ability to browse packages that are not installed.
  • newusernewuser February 2010
    Go to and download the 3.1 version of the tazpkg, I had the same problem, and don't have the time right now to check it, I want to try the Slackware portion of the program. Make sure you erase the /var/lib/tazpkg and go back to the package manager.
  • NikNik February 2010
    Actually I have the same problem!
    I work around by just using the terminal.
    This way I am still able to add any package offered to slitaz.
    But I have to look up my possibilities here :
  • LuXLuX February 2010
    Hello !

    * Time4meds wrote
    If I do a "tazpkg upgrade from terminal, it provides a very long list of all my installed programs, and tells me to upgrade to the exact same version (for every pkg).

    I think that this is normal, due to the change of compression of the *.tazpkg files. Have you tried to upgrade every installed package as suggested? If not, I'm not surprised that tazpkg (and its GUI frontend) cannot determine properly what is installed and what is not: it is not only a question of version number, I think (without being sure) that it is a question of *.tazpkg files installed in /var/cache/tazpkg.

    Best regards,
  • RuppRupp February 2010
    I just went along and upgraded everything because I figured it wanted them all updated because of the new compression. I was right and after updating them all they no longer are asking to be ugraded.
  • GokhlayehGokhlayeh February 2010

    There's two different problem here. LuX have right for the first : you need to upgrade all your packages due to the new compression method.

    The second :
    In my Slitaz, I can't list installable package since a month, and I can't view them if I list all, I think it's a bug in the new version of tazpkgbox (the file /usr/lib/tazpkg//var/lib/tazpkg/packages.installable_list.all is empty). If you erase /usr/lib/tazpkg, it's worse because you erase the datas wich contain wich packages are installed on you're system, then you can list nothing at all.
  • newusernewuser February 2010
    I downloaded both files and I only get the list for installed packages.
    right now the package manager is useless.
  • newusernewuser February 2010
    I think I solved the tazpkg mystery.
    This is what I did:
    At first I Installed the 2.6.30 kernel but that gave me more problems than it solved, for one I am using an AMD 2 core at 3GH , the system will give me a lot of erros with the loading of modules , wireless and audio will not work, the same if I download the latest cooking.iso. I extracted the isoś file system thd checked the differences, copied the lzma stand alone and to be sure the complete lzma . I then went to the /etc directory and copied the slitaz directory to my system, also in init.d replaced the

    I think that is all I did remade the iso and booted from the CDROM and it read the whole thing. However I don't see any modules needing update.
  • time4medstime4meds February 2010
    Thanks for all the replies
    First of all - upgrading all the pkgs to the same version, just sounds wrong.
    newuser - I just don't know what to say -- sorry
    How I fixed tazpkg on my system, it might have been because i installed
    perl-extutils-pkgconfig as well as perl-extutils-depends. The 'Packages' tab
    still does not work for me. But the "Search" tab with nothing entered in the
    box, then click Packages, will give me a full list, of installed and installable.
    Works like a charm.
  • RobertugoRobertugo February 2010
    Hello to all, in this link:

    I put my restlessness about the tazpkg bugs 3.2 and some solution... Does somebody know when this will be remedied? Thank you in advance...
  • davesurreydavesurrey February 2010
    As first I thought it was just my install that was broken but it now seems it's a general problem with tazpkg 3.2
    So once more I have to use other linux distros.
    What a shame as SliTaz shows so much promise but the lack of response to user feedback, not just this but many other things that I have seen reported with no reply such as setting up another user account, makes it hard to use and recommend.
    Sorry but it has to be said.
  • TotoetsasoeurTotoetsasoeur February 2010

    You should not put off using slitaz. It's a great distro.

    I don't agree with you. tazpkg 3.2 works just fine in console mode. No bug as far as I know.

    And setting another user account is not that hard. Maybe, you should just forget about using GUI and follow the standard linux way of adding users via terminal.

    Hope this helps.
  • davesurreydavesurrey February 2010
    Hello Stephane

    I agree that SliTaz has all the makings to be a great distro (I wouldn't have spent time here otherwise) but a lot of distros have been good but died through the lack of good support or their community.

    Using the latest Cooking (oct 09) I tried to add another user (as I mentioned at the time I dislike the user being automatically set as tux on install and prefer to be asked my name as with almost all other distros) but it didn't work as reported by several other folk. I just couldn't log-in. Eventually I found I had to copy /home/tux/.config files to the new user to be able to log-in. Also I found a way to change from tux to my_user_name. Simple to do when you know how but not as easy as any other distro however.

    Now, when I did an upgrade of apps using the GUI Package Manager it broke the system. Couldn't log in any more, even as root . Nada. Had to do a fresh install. Read up and found the package structure had changed but still had to search to find that I needed to use CLI and upgrade tazpkg first. Then CLI for the rest. As also reported by others. So a very poor way of changing things IMO without clear warnings or instructions what to do.

    Now I have it working except I cannot see any installable apps in the tazpkg gui. I have to use CLI to add any apps (first searching to see what exists.)
    Conclusion the tazpkg GUI is broken. Again I'm not the only one to report this.

    Could you perhaps try using the GUI and see if you have the same experience. or perhaps you could suggest what we should do to get the gui based Tazpkg up and running again. Hopefully one of the devs will tell us this is acknowledged as a problem and will be fixed.
    I would look in Labs but that has been showing "Offline" for a few days now. :(


  • RuppRupp February 2010
    I don't have a problem with the gui after the full upgrade. I did have little problems with tazpkg though at times. Those were caused by myself having a folder on my partition as a repo. I mainly use cli anyway but like you I do use the GUI to search when I need to.

  • davesurreydavesurrey February 2010
    Thanks Rupp,
    Well it seems you have no probs but Gokhlayeh and I still can't see installable packages in the GUI.
    Okay I'm willing to give it another try ie reinstall everything but to help could you kindly tell me what you did to do a full upgrade.
    Thank you
  • RuppRupp February 2010
    tazpkg get-install tazpkg --forced

    "I still can't see installable packages in the GUI."

    Come to mention it that doesn't work for me either. I always search for what I want and have never really used that. So I guess I do have a problem with GUI. I thought we were talking about something different. I had a "brain fart" I guess. I will look into it and see what I can do.

  • davesurreydavesurrey February 2010
    Rupp, thanks for confirming that I am not going mad. :)

    Based on what you said that it was working okay for you I did a complete reinstall and even accepted that my name was tux (in other words I didn't change the user name to make sure that wasn't the problem) but I still have the problem that tazpkg gui doesn't show or allow access to the installable packages.

    So as I said I'll use something else until someone somewhere in the devs admits it's broken. I do accept making a distro is an incredibly difficult thing but my gripe is really the lack of feedback and response we get when we raise an issue. It seems like we are talking into a black hole. IMO that's what kills off distros.

    If you do find a fix I am sure I am not the only one who would appreciate it.
  • LuXLuX February 2010
    Hello Davesurrey,

    * Davesurrey wrote
    I do accept making a distro is an incredibly difficult thing but my gripe is really the lack of feedback and response we get when we raise an issue. It seems like we are talking into a black hole. IMO that's what kills off distros.

    I'm a basic Linux user (never used any other Linux distro but *ubuntu before, except a short disappointing experience with puppy) and in spite of this I didn't find difficult at all to use Slitaz, add new users and use tazpkg CLI: I found it easer than the GUI user's management system of Xubuntu, which is partly broken in my system (probably my fault).

    Anyway I can understand pretty well your feeling. Indeed I agree with you that, compared with *ubuntu, Slitaz is undoubtly lacking a large and active comunity, building thousands of pages of Wiki and forums. Perhaps money helps for that too (not every distro has a sponsor like Canonical Ltd) but after all Slitaz is a very young distro compared with others.

    Devs cannot do everything by themselves, as you know. I'm quite surprised that they still do answer however in the forum from time to time. I was lucky enough to receive answers from Pankso (alias Christophe Lincoln), Bellard and Erjo among others... and you received one too (although not suited for your need). Did you ever receive any answer from Mark Shuttleworth by posting on Ubuntu's forum?

    I'm not at all saying that you are wrong and that everything is your fault! ;-)
    I'm just saying that devs cannot be both devs and the community. But it seems to me that a good thing with the small size of Slitaz's community is that you can get closer to its staff if you want. Did you see for example this ?

    And for your problem with tazpkg: maybe you should try to repost it in the thread open by Bellard on the new tazpkg, or open a new thread with a more precise title like "Can't see installable packages in tazpkg GUI (even after upgrading tazpkg)" or something like that. You can even start your title: "to Bellard" or "to Pankso", why not? :-)

    Hope this helps,
  • davesurreydavesurrey February 2010
    Hello LuX
    Thank you for your comments. I will be honest and say that if I had written what I wrote in some of the other Linux forums then I am sure I would have received many negative and abusive replies. But not here and I see that as a very positive aspect of the SliTaz community. But it is not quality but quantity that I feel is the issue with the Community and feedback.

    I do agree that it's asking too much to expect the devs to answer every forum post but on such fundamental issues such as setting up a new user or getting the gui package manager to work I feel some sort of acknowledgment of the problem might be expected. As it stands I don't know whether it is my fault (although I see others have similar problems so I think not) or an issue they are aware of and will fix...but when...or even whether they care?

    I did report the user issue and another one in Labs a long while back but received no ack for a good while and frankly lost interest and thought no one cared.

    No, I have never received a missive from Shuttleworth nor would I expect one. In fact I don't view the official Ubuntu forum as very responsive ..more a repository of information,. But other unofficial Ubuntu forums are much better and more responsive. But there is more than Ubuntu. You mentioned Puppy and I can say that they have a great community where I usually get answers within 24 hours, rather than 24 days or not at all. And so is the TinyCore community and that of Crunchbang. I can't speak for the rest.

    At the end of the day the SliTaz devs are free to do what they want. It's their distro. I only offered my admittedly frank observations in the hope they would be seen as positive, well meant feedback.

    Thanks for yours
  • bellardbellard February 2010

    Tazpkg 3.2.1 should fix it. Please upgrade or install
  • davesurreydavesurrey February 2010
    Thank you bellard.
    I installed the new tazpkg package 3.2.1 and after a reboot the GUI is now working fine. I appreciate your help in this as I am sure others will.

    I have since tried to install some apps from the GUI tazpkg manager:
    Abiword: downloaded but wouldn't run either from menu or terminal. In terminal get "Pango warning.........Aborted"
    Then tried Fotoxx: wouldn't run. In terminal get "missing exiv2" so installed exiv2. Then got "missing printoxx". So installed printoxx. Now get seg fault. Won't run.
    Note: auto-install deps is selected
    Tried Gnumeneric, htop, pan...all worked okay.


  • time4medstime4meds February 2010
    re davesurrey
    has anyone tried what i posted above
    tazpkg 3.2 works fine for me now
    I just choose the second tab which is called "search"
    I do not enter anything in the search box, and then I just
    click packages. It then lists everything 1800+ pkgs with
    descriptions, and comfirms which are installed with that
    little green arrow icon.
  • TotoetsasoeurTotoetsasoeur February 2010

    Abiword works just fine for me. Even if I did not check all functionnalities, for sure I have no error message when starting and stopping it (sometimes few warnings when closing, but not a big deal):

    ~$ abiword

    I am far away from beeing an abiword expert, but if I remember well, I had to install few more packages (from cooking):

    ~$ su
    ~$ tazpkg get-install abiword-dev
    ~$ tazpkg get-install abiword-extras

    Hope this helps.

    If I may, I think it would be clearer if you start a new discussion related to every problem you may encounted instead of putting all of them within the same discussion.

    For example, a new discussion titled "can't start abiword", etc..

    Easier to find when needed - easier to close when solved.
  • davesurreydavesurrey February 2010
    Previously you wrote [quote]I don't agree with you. tazpkg 3.2 works just fine in console mode. No bug as far as I know[/quote] but I was talking about using the GUI not the CLI. And I believe it has now been proved that tazpkg 3.2 was in error as bellard has issued a patch in tazpkg 3.2.1 which works well for me.

    Now, you say Abiword works well for you. I have tried installing both by cli and gui and I get the same problem (as above.) I doubted adding any other abiword apps, as you suggested, would change anything but I tried. And nothing changed.

    As you say yours works, are you using tazpkg 3.2.1 ?? If not then it's not the same situation as mine.
    I'd appreciate it if you'd let me know.
    Could you let me know your line 528 of /usr/bin/tazpkgbox please.

    [quote] I think it would be clearer if you start a new discussion related to every problem[/quote]
    Yes you are correct. My fault. I'll try to do this from now onwards.

  • TotoetsasoeurTotoetsasoeur February 2010
    Hi Dave,

    This is the tazpkg I am using:

    ~$ tazpkg info tazpkg

    Tazpkg information
    Package : tazpkg
    Version : 3.2
    Category : base-system
    Short desc : SliTaz packages manager.
    Maintainer :
    Depends : busybox
    Web site :


    As requested here is line 528 of /usr/bin/tazpkgbox (this line starts with < input > and ends with < /input > which is an html balise, then not shown...):

    installed=`ls /var/lib/tazpkg/installed | wc -l`; mirrored=`cat /var/lib/tazpkg/packages.list | wc -l`; undigest=`cat /var/lib/tazpkg/undigest/*/packages.list 2> /dev/null | wc -l`; blocked=`cat /var/lib/tazpkg/blocked-packages.list 2> /dev/null | wc -l`; installable=$(($mirrored + $undigest - $installed)); [ $installable -lt 0 ] && installable=0; echo -n "Packages statistics: $installed installed, $blocked blocked, $installable installable, $undigest undigest, $mirrored mirrored, `cat /var/lib/tazpkg/upgradable-packages.list 2> /dev/null | wc -l` to upgrade "

    Then I recharge and upgrade with:

    $ su
    $ tazpkg recharge
    $ tazpkg upgrade
    $ $ tazpkg info tazpkg

    Tazpkg information
    Package : tazpkg
    Version : 3.2.1
    Category : base-system
    Short desc : SliTaz packages manager.
    Maintainer :
    Depends : busybox
    Web site :

    And here is line 528 after upgrading:

    installed=`ls /var/lib/tazpkg/installed | wc -l`; mirrored=`cat /var/lib/tazpkg/packages.list | wc -l`; undigest=`cat /var/lib/tazpkg/undigest/*/packages.list 2> /dev/null | wc -l`; blocked=`cat /var/lib/tazpkg/blocked-packages.list 2> /dev/null | wc -l`; installable=$(($mirrored + $undigest - $installed)); [ $installable -lt 0 ] && installable=0; echo -n "Packages statistics: $installed installed, $blocked blocked, $installable installable, $undigest undigest, $mirrored mirrored, `cat /var/lib/tazpkg/upgradeable-packages.list 2> /dev/null | wc -l` to upgrade "

    And we can see that word "upgradable" has been changed to "upgradeable" in line 528:

    blabla.... upgradable-packages.list .... blabla


    blabla.... upgradeable-packages.list .... blabla

    Let me known how is going.
  • davesurreydavesurrey February 2010
    Hello Stephane,
    Thank you for taking the time to give me this information.
    I see you are still using tazpkg 3.2 but I have updated to tazpkg 3.2.1
    Also my line 528 has "upgradeable-packages rather than yours which has upgradable-packages. Not sure which is correct.
    This may be why we are seeing different things.

    But again I can't get tazpkg 3.2 to update the list of installables from the gui.

    So I guess either I use 3.2 and the CLI or I use 3.2.1 and know some right click cmds won't work.

    Hopefully slitaz 3 will have all this fixed.

    Thanks for your help.

    ps how do you get text to be highlighted. I tried using [quote] [/quote] but it didn't work here.
  • TotoetsasoeurTotoetsasoeur February 2010
    a) Yea you're right, actually I was editing my post when you sent yours... Please have a look to my last comment, I have upgraded to 3.2.1 and checked line 528 again.

    b) I am a kind of console addict, so for me the best tazpkg usage is:
    - find via slitaz web page the package you are looking for,
    - then use tazpkg (3.2 or 3.2.1 no matter) in CLI.

    c) Like anyone I am looking forward to try slitaz 3.

    d) To highlight the text, I use html balise (found on but be aware that only few ones work on vanilla!). The one I overuse is < pre > and < /pre > (Please note that I added an artificial space to avoid vanilla use it but allow you to see it).
    Interesting ones are < tt > and < /tt>, < i > and < /i >, < blockquote > and < /blockquote >etc...

    If anything else just ask.
    All the best.
  • davesurreydavesurrey February 2010
    Yes I think our messages "crossed" so now I understand better although still confused why my Abiword doesn't work.
    After the weekend I'll have to try a new install again using only CLI and doing it your way. Going away now.
    Thanks also for the link to Balise html. I'll have a try next time I need it.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social