This is the old SliTaz forum - Please use the main

  • ok i am confused.
    I customised my slitas on my system and i am very happy with it
    what command should I use to make a livecd of if, that would allow me to install it on another machine ?
    I read the tazlito wiki but it does not help me: what should i use ?
    I tried tazlito gen-distro but i get a number of errors :( and i am not sure this is the right command

    thanks for any hint
  • dnelubdnelub February 2011
    I have the same problem here
  • GokhlayehGokhlayeh February 2011
    Here's what I found on tazlito doc (/usr/share/doc/tazlito/tazlito.en.html)


    This command will write the current filesystem to a cpio archive (rootfs.gz) and then generate a bootable ISO image. Writeiso can be used in a HD install or in live mode and will also archive your current /home directory. This command lets you easily remaster and build your own LiveCD image, just boot, modify any files, and then:

    # tazlito writeiso [gzip|lzma|none]
    # tazlito writeiso gzip
    # tazlito writeiso gzip image-name

    Hope this help.
  • Trixar_zaTrixar_za February 2011
    I just tried tazlito writeiso lzma and it takes a while to do since my SliTaz with a clean home folder is about 1.6GB. But it works and I now have an LiveCD iso with my current setup - it rocks ;)
  • ms3811ms3811 March 2011
    I can't seem to ever get tazlito writeiso working. I tried it with lzma and gzip. In both cases, it randomly terminates with the error:

    Unable to mount the cdrom to copy  the Kernel and needed files. When Slitaz is running in RAM the kernel and bootloader files are kept on the cdrom. Please insert a LiveCD or unmount the current cdrom to let Tazlito handle the media.

    ENTER to continue....

    I have slitaz installed on the hard drive. I don't have a cdrom drive. I tried mounting the cooking-iso to /media/cdrom, that didn't help. Also, when I installed slitaz, I installed using the stable iso, then did a "tazpkg set-release cooking", then upgraded. How will the LiveCD help in this case, since even the cooking-iso has kernel .34 whereas my current install is running .37.

    Anyone has any ideas how I can provide it a LiveCD without a cd drive? Thanks.
  • Trixar_zaTrixar_za March 2011
    I get the same error... it expects the LiveCD in the drive and mounted @ /media/cdrom - which doesn't always happen. You could probably mount an iso to there which negates the need for a CD drive. As to how, I'm not sure...
  • ms3811ms3811 March 2011
    Actually, I did try that. I mounted the cooking iso using the mount -r loop command at /media/cdrom and then ran tazlito. Still gives the same error.

    Also, as I mentioned in my previous post, tazlito claims it needs the LiveCD to copy kernel and bootloader files. But my current install is running kernel version 2.6.37 whereas the latest kernel available in iso form is 2.6.34. So even assuming I did have the LiveCD in my CD drive (which is not happening for me, since I haven't used a machine with a cd drive in like 5 years), how will that help? tazlito couldn't possibly copy bootloader and kernel files from a LiveCD that uses an older version of the kernel to the rootfs.gz being created for an install running kernel version 2.6.37.

    Doesn't make any sense. I'm lost. It would be really nice to get this working, since I play around with my machines  a lot, requiring frequent reinstalls. They all share the same hardware for most part, except maybe the network adapters. It will save me a lot of grief by avoiding the whole 'setup' process between configuring xorg, setting up apps, customizing look and feel, what have you!
  • slicelslicel March 2011
    Slitaz will make an iso of your kernel but first you need to give it an iso of your kernel.  I am finding a number of kernel problems.

    It looks like tazlito might assume the same kernel and assume cd hardware when it should not.  If anyone has used tazlito writeiso successfully when the user's kernel was different from the live cd kernel, it would help to post it.

    Tazlito has improved, though.  Believe it or not, the slitaz v1 tazlito wanted you to connect to the internet to re-download uncustomized system files to make an iso of your customized, local hd system (imagine that on dialup) and then the process did not work for many people.

    I suggested on the old forum to have a simple command to burn an iso of the current, local system, which is what the new tazlito writeiso is trying to do.
  • claudineiclaudinei March 2011
    I guys,

    I've just tried 3 methods, gen-distro, gen-liveflavor and writeiso. Results:

    1) gen-distro 


    # tazlito clean-distro
    # tazlito list-flavors
    # tazlito get-flavor base

    Added "nano-2.0.9" to /home/slitaz/distro-packages.list and created the file /home/slitaz/distro/addfiles/rootfs/hostname. Then:

    # tazlito gen-distro

    It downloaded the necessary packages and generated an iso on /home/slitaz/distro.

    2) gen-liveflavor


    Install the packages you want. Then:

    # tazlito gen-liveflavor

    It downloaded the necessary packages and generated an iso on /home/slitaz/distro.

    3) writeiso 

    Not worked with SliTaz installed on hd. Maybe it just works in live mode, doesn't tried it.

    I personally prefer the gen-distro approach, it offers more ways of customization and control of the process. The gen-liveflavor is simplier, but doesn't keep /home files. The writeiso keep /home files, but as said, seems to work only on live mode.
  • slicelslicel March 2011
    Claudinei, what flavor and kernel did you use?

    Thank you
  • claudineiclaudinei March 2011
    SliTaz Stable 3.0. 

    The undigest cooking iso (  has the 2.6.37 kernel.
  • ms3811ms3811 March 2011
    @Trixar_za & @slicel, appreciate the responses. Not complaining, I realize a lot of work has gone into making things better. Just wasn't sure if I was missing something or if the problem lay elsewhere. Thanks for clarifying.

    @claudinei, I will give gen-distro a shot, thanks for looking into this.
  • slicelslicel March 2011
    Ms3811, I did not think you were complaining because I know that users who post problems are often helping slitaz as much as the reverse.

    It looks like tazlito writeiso is avoiding an internet connection to external files by using the cd for external files so tazlito is still not reading the current, local, customized system as the direct source for the new iso.
  • Trixar_zaTrixar_za March 2011
    *sighs* Ever use that software that can turn Windows XP into a LiveCD? It ALSO needed to read files off the install discs to work, which makes your statement kind of redundant especially if your expecting anything more for SliTaz than you'd expect from Windows...

    Anyway, back on topic: Funny enough using the writeiso function while booted from the LiveCD works for me too :/

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social