This is the old SliTaz forum - Please use the main

Network printing issue (smb / windows share)
  • xfleblonxfleblon February 2011

    Is someone has succeed (Slitaz stable 3.0) to configure a printer (HP) shared by Windows XP, with URI like the following ?
    My printer is correctly shared, and i can print over network with Puppy Linux, but it fails with Slitaz ;-(
    My printer server (windows XP) is reachable from slitaz (ping OK)

    Here are the steps :
     - Install package (smbclient, hplip and all dependencies)
     - > ln -sf /usr/bin/smbspool /usr/lib/cups/backend/smb  (it's not an intuitive step, but found in other forums)
     - Configure printer with Cups web Interface.
     - Choose "Windows share", HP driver (my PhotosmartB109a is well known in the list provided by HPLIP)

    I tried URI with many syntaxes. For example :
      smb://WORKGROUP/hostname/PhotoSmartB109a (with hostname declared in /etc/hosts)
     and many other combination.

    But each time, printing "test page" or "real document" fails : Printing error

    I don't know if it related, but when I try to configure it manually with smbclient ... i get the following loop error :
    > init_iconv: Conversion from UTF-16LE to IS0-8859-15 not supported
    > init_iconv: Attempting to replace with conversion from UTF-16LE to ASCII
    > init_iconv: Conversion from UTF8 to IS0-8859-15 not supported
    > init_iconv: Attempting to replace with conversion from ASCII to ASCII
    > ......
    The "init_iconv" issue seems to be known, but I don't understand in other forums the way to fix it ...

    Thanks for any idea
    I think, it's the last step to allow me to switch to Slitaz (I currently use Puppy Linux)

  • xfleblonxfleblon February 2011
    I tried some more ... and it work !

    First i follow steps described in "" and restarted cups daemon, but it was not sufficient.
    I also needed to :
    - install "samba-pam" and "pyneighborhood" packages (Appearance of CUPS web interface has changed after that)
    - add hostname of my windows server in /etc/hosts even if I use only IP address in smb URI
    - browse shares on my Windows PC, with pyneighborhood GUI which detects windows "WORKGROUP"

    After all these steps, all print tests work !

    But to much memory consumption  to burn new LiveCD with writeiso ... (ISO~150MB) RAM=768MB and home=usb !!!! I will need 1GB RAM to suceed !!! Arghhhhh !
    No HDD in my PC.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social