This is the old SliTaz forum - Please use the main

SliTaz and Windows Networking
  • kbrickedkbricked July 2010
    Hi all.

    SliTaz is a great mini OS with a huge punch; however I'm finding it difficult to do some basic things.

    I've installed smb related packages, as well as pyNeighborhood and I can't seem to add or mount a Windows share via the command line or through the pyNeighborhood GUI.

    Any ideas?
  • mojomojo July 2010
    Open terminal become root
    tazpkg get-install smbfs
    modprobe cifs
    mount //i.p. address.with.samba.share/ /local.mount.folder -o user=guest
    Add cifs to LOAD_MODULES of /etc/rcS.conf to autoload cifs module on boot

    pyNeighborhood flat out doesn't work. When it query's for the i.p. of a netbios name it receives from smbtree it uses "nmblookup -T netbiosname" which returns nothing because -T switch is broken. I remove and install the newest version and it still has the same issue.

    If you installed samba use smbtree,nmblookup netbiosname,findsmb,smbclient tools to get the IP of the shares you want to mount if necessary.
  • I have installed Slitaz 3.0 from the stable iso, and upgraded all the packages to the latest version (tazpkg recharge / tazpkg upgrade). I have installed smbfs and followed the instructions above. When I try the mount command I receive the following error:-

    Mounting the DFS root for domain not implemented yet
    mount error: cannot change directory into mount target

    Please can anyone help me get past this error.
  • mojomojo July 2010
    What command are you using to mount the samba share when you receive the error ?

    I get the error without -o user=guest
    ux@slitaz:~$ sudo mount // /tmp

    Mounting the DFS root for domain not implemented yet
    mount error: can not change directory into mount target ip=
    tux@slitaz:~$ sudo mount // /tmp -o user=guest

  • The command that I was using was:

    mount // /media/nas

    I have now tried using

    mount // /media/nas -o user=guest

    After approx. 5 minutes the command finishes with the following error:

    Mounting the DFS root for domain not implemented yet
    mount error: can not change directory into mount target ip=

    I have run modprobe cifs before I have tried any of the above.

    Have I missed something obvious.
  • mojomojo July 2010
    You are executing mount as root, you are sure the computer at address is broadcasting an open share called nas2
    You have made a mount directory called nas inside a directory called media at the root of the partition.
    Then you have not missed anything obvious.
    To diagnose farther you need smbtree to see if your computer receives broadcasting a share called nas2
    About 60 MB install, smbclient,samba-common,and a bunch of depends.
  • kbrickedkbricked November 2010
    Well golly gee, where's the time go?

    Mojo; many thanks for the help, however I too had no luck. Some Googleing produced a similar problem in Ubuntu.

    After some trial and error: [as root] {forgive the lack of forum wrapping}
    - ensure smbfs is installed:

    root@slitaz:/# tazpkg get-install smbfs
    root@litaz:/ # modprobe cifs

    - add cifs to LOAD_MODULES of /etc/rcS.conf to autoload cifs module on boot so as to avoid having to load cifs after reboot

    root@slitaz:/# mount.cifs // /local.mount.folder -o user,sync,domain=MYDOMAIN,user=USERNAME,password=PASSWORD

    {space after, local.mount.folder, as well as -o.}

    *replace MYDOMAIN, USERNAME, and PASSWORD with your domain, username and password...

    If guest access is allowed... I guess user=guest would work as well, with no need for a password? {rhetorical question}
  • vegarlvegarl February 2011
    Hey guys, I'm very new to linux, but I am really enjoying how linux (Slitaz especially) has revived some of my older machines. So I have gotten a network share to work with my wireless card, my question is how to make it permanent so that the next time I boot up my machine I can get to my files on the nas without bringing up the terminal and putting in: root@slitaz:/# mount.cifs // /local.mount.folder -o user,sync,domain=MYDOMAIN,user=USERNAME,password=PASSWORD over and over again.
    I see kbricked has said to "- add cifs to LOAD_MODULES of /etc/rcS.conf to autoload cifs module on boot so as to avoid having to load cifs after reboot"
    could you walk me through how I would do this?
  • ms3811ms3811 February 2011
    @vegarl, to add cifs to LOAD_MODULES, edit /etc/rcS.conf with your favorite text editor (I use leafpad), scroll down to the section LOAD_MODULES and add cifs to the list of modules within quotes. E.g.:

    LOAD_MODULES="snd_hda_intel tg3 drm intel-agp cifs"

    (The string within quotes might look different for you, simply add cifs at the end). This will accomplish the equivalent of # modprobe cifs at boot time.

    To execute the mount command upon login, you could try adding the mount.cifs command to  /home/yourusername/.config/openbox/ (/root/.config/openbox/ for root user).

    Good luck.
  • xfleblonxfleblon February 2011
    For me, it was much more easy (with Slitaz stable 3.0).
     1- Install package "smbfs"
     2- mkdir /mnt/nas
     3- (as root) mount.cifs // /mnt/nas (no option ....)
    => Wonderfull it works !!

    After that :
     3- mount (to show the active mount points with default options added by the system)
     4- Then copy (with few syntax modifications) the line to "/etc/fstab"
    Example : // /mnt/nas cifs rw,mand,relatime,\\unc=\datanas,username=root,password=,addr=,posixpaths,acl,rsize=16384,wsize=57344,_netdev 0 0
     5- tazlito ..... to burn new live CD
     6- Wonderfull ... next boot is OK with cifs mounted

    But .....  it doesn't work with new cooking version

  • mojomojo February 2011
    I have had no problem with cifs mounting of username/password protected shares on Windows 7 with cooking.
    There is a 4th step you left out of slitaz-3.0/cooking smbfs mount setup.
    # modprobe cifs
    Add cifs to LOAD_MODULES of /etc/rcS.conf to autoload cifs module on boot
    If you need more assistance:
    Post your command line syntax and the following output errors for a temporary mount
    Post mount  -a command and all the errors that follow when your fstab fails to mount.

  • vegarlvegarl February 2011
    Hey Guys

    I added cifs to LOAD_MODULES of /etc/rcS.conf like you have said, and also edited fstab, but it still wasn't connecting to my nas.

    I was thinking maybe it wasn't connecting because my wifi didn't have time to be fully active. So I used the sleep command, added the line sleep 5 (give the script 5 seconds of delay) before executing the mount.cifs // /local.mount.folder -o user,sync,domain=MYDOMAIN,user=USERNAME,password=PASSWORD in the rcS.conf file and it worked!

    my little outdated laptop is surfing the web like a boss! (ok... still slowly but it does the job... haha)

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social