This is the old SliTaz forum - Please use the main

After Upgrade to Cooking(to solve geeqie issue), My mouse can not move
  • florastephanieflorastephanie February 2011


    i am a newbie around here, 

    first allow me to say how astonishing Slitaz is, so lightweight on my Toshiba laptop, my wireless even has a stronger signal than when it was on Windows 

    but I had one problem:
    geeqie was quitting unexpectedly whenever trying to add a metadata to a file.checking its log files, it says that i'm using gtk+ 2.16, while geeqie is designed to work on gtk+2.2 and higher.

    my attempts to solve it:
    i downloaded the corresponding gtk+2.2 cooking package and tried to install it on my stable slitaz. at restart, grub showed me 2 login options (1 stable and 1 cooking),but the stable wouldn't load i went to xterm, and did a
    tazpkg install gtk 
    to force the system to revert the package to its older version, which it did.
    geeqie was -naturally- still as buggy as before my attempt.

    my another attempt now was to make the whole system cooking:
    # tazpkg set-release cooking
    then tazpkg upgrade (if i'm not wrong), but i am sure that it was some 1 hour procedure that resulted in a download of 120 MB of data in the purpose of updating the package files, and these were installed as they were downloaded.

    after restart, i find the mouse is in the middle of the screen, but i can't move it.
    still my Belkin wireless is working,
    i can assure that my keyboard is working (it responds to the F1 that locks/unlocks the screen)
    and to add up to it, my cd reader isn't reading cds any more, so i can't boot from any LiveCD
    nor is my system able to boot from a usb (it doesn't have it in the booting options)
    still, it has a floppy reader, but it's been a looong time since it has been used, and i'm not sure if it would work at all.

    I would appreciate any help on my issue,

    Note: I don't know what the shortcut to xterm is, so I can't be much helpful in the exact history of the commands i did, nor can i give more info about my system as long as I can't access it. 

    Many thanks in advance
    Kindest Regards

  • Trixar_zaTrixar_za February 2011
    I have good news and I have bad news for you.

    The bad news is that the use of the upgrade command probably broke your SliTaz beyond any easy kind of repair. The reason why this happened is because the packaging system has been changed, with many other parts that also got upgraded, added or modified in some way. Because of all of these factors, Cooking and Stable just aren't very compatible and a direct upgrade from the one to the other tends to break them.

    I do however have some good news. It may be possible to boot off a usb device even if your bios doesn't support by using something called SBM (Smart Boot Manager) which you can get here:
    The great thing about it is that you just put it on a 1.44 diskette and use it to boot other devices attached to your system like HDDs, CD/DVD Drives and USB devices.

    So give it a try. I'm sorry to say I have no experience with using SliTaz off a usb device, but hopefully somebody that has can give you some pointers in that regard. There is also a guide on it in the docs @ - Hopefully combining SBM and a liveusb version will solve your problem.

    Anyway, Good luck and hope to see back on SliTaz soon!
  • florastephanieflorastephanie February 2011

    thanks for your reply :),
    i will try to do your proposition in a moment, and will keep the thread updated about it :)

    Kindest Regards

  • florastephanieflorastephanie February 2011

    oh my! my floppy has failed me.....

    but i still have one tiny hope: the LAN,
    not through my wireless (its LED lights only turn on AFTER having booted to slitaz)
    but through the wired Ethernet.

    I have a DLINK DIR-300 router,
    but the problem is that it's unable to recquire a DHCP address,
    it says :
    MAC Address 00.00...........

    then after a few seconds it says:
    "no DHCP or proxy DHCP offers were received,
    exiting intel PXE..."
    then we're back to square zero...

    Note that i don't mind formatting the whole system (i don't have any valuable data on it yet, it's just the packages which i can redownload and install later...)

    Kindest Regards

  • OldGuyOldGuy February 2011
    I'm a bit puzzeled.
    Your CD-Drive as well as your Floppy-Drive failed you ?

    Can you as a first step make sure that your BIOS is setup correctly and the boot sequenze is something like:
    1. Floppy-Disk
    2. CD/DVD-Drive
    3. USB-Media (if available)
    4. Harddisk

    Insert a bootable media in each unit and start the laptop to see what's happening.

    If really nothing works, you couls try to setup a PXE server on a seperate machine.

  • florastephanieflorastephanie February 2011

    OldGuy, thanks for your reply :)

    actually, in a desperate attempt to make my cd-reader work, i wiped the lens of it with a brush (since it's a laptop, the lens is expelled with the cd lid)
    not too cautious, i know, i might have scratched it, but it did the trick.

    and for the PXE server info, thanks for the link, i'll bookmark it in case -god forbid- my cd reader fails me again

    so, @Trixar_za and @OldGuy ,
    thank you both for your help :)

    Kind Regards

  • florastephanieflorastephanie February 2011


    After my cd reader erroneously worked this time,I started by installing Lubuntu, since Digikam is what I wanted in the first place, but it can't be installed on slitaz.

    now my cd reader has stopped working (again!), but only on startup:
    when I'm in UBUNTU, it can easily read cds on it!

    so now I have this Lubuntu-which-is-not-light-enough-for-my-laptop operating system that i would very happily trade back to slitaz now.

    I tried to do the PXE method, but it seems to me (from the google cache of the link @OldGuy has given me) that it relies on booting first from CD, or floppy...
    Still, my cd-reader couldn't open the CD on boot, even with the burnt 700 KB slitaz-boot on it !!

    So I figured to make slitaz boot from iso within the hardisk through GRUB2 that came along with LUbuntu.


    February 13th 2011  

    EDIT: Post moved as a new thread since it's another topic. But one remaining problem from this topic is that my cd-reader can not read cds on boot

  • GokhlayehGokhlayeh February 2011
    About you're initial question: maybe the situation is not so problematic. Having no mouse/no keyboard is symptomatic of stable>cooking upgrade; even if problem pointed by Trixar_za **may** happens (until there, I havn't heard about someone who broke entirely his system doing such upgrade), there's no clue this was which happens to you. Problem you're describing can be easily explained: stable xorg use mouse/keyboard drivers, while cooking use evdev which is missing from you're system, while in cooking xorg disable mouse/keyboard drivers by default.

    To install evdev:
    Start SliTaz (cooking) in terminal mode
    At grub screen, edit the cooking entry (type 'e') and add to the first line:
    Confirm (type 'ENTER') and boot (type 'b').

    At terminal login prompt, log as root and install evdev driver using:
    $ tazpkg get-install xorg-xf86-input-evdev

    Then reboot:
    $ reboot

    Boot as usual and check if all looks fine for you :)

    PS: please spread the word if other people fall into the same problem ;)
  • mojomojo February 2011
    This grub2(installed to usbkey MBR) isoboots /boot/slitaz/slitaz-3.0.iso on same usbkey:

    menuentry "SliTaz-3.0.iso" {
    loopback loop /boot/slitaz/slitaz-3.0.iso
    linux16 (loop)/boot/bzImage
    initrd16 (loop)/boot/rootfs.gz autologin

  • florastephanieflorastephanie February 2011
    Thank you for your precious post!
    I wish I waited a few days for it! I thought back then that I damaged my slitaz!
    (unfortunately now, i wiped the system and installed Lubuntu instead, and I'm trying to find my way back to slitaz now!)
    but i will definitely spread the word if I encounter other people falling into it
  • florastephanieflorastephanie February 2011
    @mojo ,Thank you for your reply.
    Please correct me if I'm wrong, I understand that your method relies on plugging the usb on boot and allowing grub2 to run from it?
    If it's the case, then I don't think it would work:
    my laptop dates back to pre-2001 (toshiba Satellite 1800 )
    it has no bios entry to boot from USB,
    it can only see the usb from within the operating system.

    Anyway, I have posted a new thread concerning this issue (so that I don't dilute the initial thread)and allow me to repost your post on that new thread
    Kindest Regards
  • Trixar_zaTrixar_za February 2011
    Actually, there was several threads about SliTaz stable breaking when a direction upgrade is made through tazpkg to cooking. Mostly involving or other driver based devices/software breaking afterwards. So since this was the case, I assumed that it was also the cause of this problem. It may also be caused by the move to udev in cooking. Stable still wants to use HAL fully while cooking wants to use udev more which effectively breaks the newly upgraded SliTaz's hardware detection.

    Just thought I should mention that :P

    PS: I did convert over the debian package of geeqie, but it tends to break when loading directories with pictures in with an out of bounds error. I get the exact same error with Nitrogen. Then again, my SliTaz is heavily modified.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social