This is the old SliTaz forum - Please use the main

CPU Heating
  • math1337math1337 February 2011
    I have an AMD Athlon II p340 2.2 GHZ cpu, and it seems to heat up a lot when I run slitaz. I checked the cpu usage and it's close to 0 so there is no program taking up all of the cpu. The cpu fan constantly runs at full speed and when I reboot to windows after sunning slitaz, the temps are very high(~65), but decrease to a low idle temp(~50)
  • kultexkultex February 2011
    because in slitaz 3.0 there is no cpufrequtils - it will be possible in comming release 4.0 and note that you have to install all the utils by hand

    see here

    if you really want to save energy with an AMD CPU, you should have a look to cpupowerd - you have to reed the readme carefully, because you can destroy your CPU !!! and your CPU was released 2010 and the last version of CPUpowerd was 2009 - I never tried it with slitaz, but in Debian with AMD X2 and Athlon II Regor it works perfect - I use it for all my servers.

    Here is a german howto perhaps google will help to translate.
  • math1337math1337 February 2011
    I'm not looking to undervolt the CPU. It's fine in windows, and SUSE, but for some reason slitaz heats the cpu up to extreme temps.
  • Trixar_zaTrixar_za February 2011
    Could you try booting the live cd with the parameter acpi=off (at the Boot Baby, Boot screen) and seeing if the problem persists?
  • FOmenalFOmenal February 2011

    just my two cent,

    i have see cpufreq with lxpanel do not work, but with E17 all work perfect on slitaz 3.0 stable.

    maybe youcan test E17 to see if that change something.

  • kultexkultex February 2011
    open the console and get root - then type (you can copy and paste)

    tazpkg get-install linux-cpufreq
    tazpkg get-install linux-acpi,
    tazpkg get-install acpid
    tazpkg install cpufrequtils-008.tazpkg

    tazpkg install powertop-1.13.tazpkg
    /etc/init.d/hald stop
    /etc/init.d/dbus stop
    /etc/init.d/acpid start
    /etc/init.d/dbus start
    /etc/init.d/hald start
    modprobe powernow-k8
    cpufreq-set -c 0 -c 1 -g powersave

    and then powertop and see if the cpu is scaling

  • math1337math1337 February 2011
    I will try that as soon as I get a chance to. Also, my CPU is a k10, so will powernow-k8 work on it?
  • kultexkultex February 2011
    powernow-k8 is working with all AMD CPUs exept some Semprons, which do not scale

    I never used the normal cool and quiet - all the time cpupowerd, so I am no expert, but it should work like this

    maybe "cpufreq-set -c 0 -c 1 -g powersave" is not working, then try:

    cpufreq-set -c 0 -g powersave cpufreq-set -c 1 -g powersave

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social