This is the old SliTaz forum - Please use the main

HW trouble - WG511 - "p54pci not found"
  • OldGuyOldGuy January 2011
    Hi Folks,

    I just ran into a curious problem while playing around with an old WG511 (cardbus) wireless card.
    I verified that the p54pci is the module I would like to use and isl3889pci is the firmware it should/needs to load.
    The apropriate firmware is placed in /lib/firmware.

    If I now insert the card, no module is loaded.
    (It seems this is the dafault behaviour of Slitaz. Can it be changed to autoload modules?)

    If I then start 'tazhw detect-pci' I get the responce :
    "! Missing module: p54pci," <- The comma is no typo!!
    "* Loaded module: prism54"

    A 'depmod -a -m' doesn't change anything on this behaivior.

    If I 'disable' prism54, by renaming "prism54.ko.gz" to "prism54.ko.gz.disabled", and run "depmod -a -m" a 'tazhw detect-pci' will then correctly identify and load the p54pci module.

    Any idea why tazhw would miss the p54pci module while the prism54 module is present?
  • OldGuyOldGuy January 2011

    The comma got me on the right trail afterall.

    tazhw detects the required modules with > lspci -k | grep "modules" | cut -d ":" -f 2 | sed s/-/_/g < which unfortunatelly reports p54pci and prism54 as a possible module for this card.

     p54pci, prism54
    Indeed both modules report themself in /lib/.../modules.alias as the "choosen one" for this card. :-(
    alias pci:v00001260d00003890sv*sd*bc*sc*i* prism54
    alias pci:v00001260d00003890sv*sd*bc*sc*i* p54pci

    Cutting off the 'additional' options by adding '| sed s/,.*//' to the detection line in tazhw will fix the problem for this card, but I don't know what other problems would arise to other cards by doing so.

    Any better ideas?

  • mojomojo January 2011
    Did you try add blacklist.conf to /etc/modprobe.d  ?
    Every module you may need load on boot:
    /etc/rcS.conf LOAD_MODULES=

  • OldGuyOldGuy January 2011

    I just had a look at /etc/modprobe.conf, /etc/modprobe.d/ and blacklist.conf

    It seems that the 'blacklist' only is used by udev. Modprobe seems always to load the modul, regardless of any entry in any blacklist.

    I also had a quick peek into the Debian manpages:

    -b --use-blacklist
                     This option causes modprobe to apply the blacklist commands in the configuration files (if any) to module names as well.  It is usually used by udev(7).

    Unfortunally, modprobe in the busybox doesn't have this switch. :-(

    If I preload the modul with "LOAD_MODULES=" then it will be loaded, regardless if the card is inserted or not, and it doesn't prevent prism54 to beloaded by a later 'tazhw detect-pci'.

    It seems there are two different cards with different chipssets out there which report the same vendor and product id.
    Therefore I guess there is no 'clean' solution to this problem but to find out which one you have and to remove the other module. :-(

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social