This is the old SliTaz forum - Please use the main

Booting Problem after Each Fresh Installation of SliTaz 3.0
  • TheForsakenTheForsaken January 2011
    Hello everyone,

    The Title "Booting Problem after Each Fresh Installation of SliTaz 3.0" said it all.


    Everytime I install SliTaz on my PC (P4 @ 3.0GHz - 512MB RAM - 20GB IDE HDD), I got the same problem and I have no idea how to fix it.


    1) As you know, you can't install SliTaz unless you have created the needed partitions for the installation process.

    2) Everytime I start GParted, I found out that GParted detect my HDD as "/dev/hdb".

    3) The HDD which I'm using is a Primary Slave. That might be the reason why SliTaz is always detecting it as hdb but let me tell you that with other Linux Distributions and even with Windows, I don't have any problem at all. It's always "sda" with other Linux Distributions and Windows does not complain about the HDD being Slave at all.

    After Installation:

    4) Directing after the first reboot when the installation process is done, I got the GRUB Menu so I choose SliTaz which is the ONLY OS installed in my PC but then I got this error:

    root (hd1,0)
    Error 21: selected disk does not exist
    Press any key to contiune . . .

    5) In order to boot and login into SliTaz, I have to do this:

    a) From GRUB Menu

    b) Press "e"

    c) Highlight root (hd1,0)

    d) Press "e" again

    e) From GRUB edit> root (hd1,0)

    I have to change it to root (hd0,0)

    f) Then Press "b" to boot.

    6) I got Slim so I Press Enter after I see my login Username then Enter my Password.

    7) Once I login into SliTaz, I got to the Main Menu > System Tools > Control Box

    8 ) From the First Tab:

    Confg file: /boot/grub/menu.lst

    then change: root (hd1,0) >>> root (hd0,0)

    9) Save, Exit and Reboot.

    10) Problem Solved.

    Now, I know it's "solved' but ... it does not make sense to do this "everytime" I have to install SliTaz.

    There MUST be another fix for this issue.
    Is this a bug? or this is how SliTaz works?

    NOTE THAT: If I plug any USB Drive into my PC, GParted detect it as "/dev/sda".

    So, what's going on here?

    Thank you!

    Again, it happens only with SliTaz. I have no problem with other Distributions whenever I try to install any on the same PC.
  • TheForsakenTheForsaken January 2011
    Before I Fix it:

    # /boot/grub/menu.lst: GRUB boot loader configuration.

    # By default, boot the first entry.
    default 0

    # Boot automatically after 8 secs.
    timeout 8

    # Change the colors.
    color yellow/brown light-green/black

    # For booting SliTaz from : /dev/hdb1
    title SliTaz GNU/Linux (cooking) (Kernel vmlinuz-
    root (hd1,0)
    kernel /boot/vmlinuz- root=/dev/hdb1

    After I Fix it:

    # /boot/grub/menu.lst: GRUB boot loader configuration.

    # By default, boot the first entry.
    default 0

    # Boot automatically after 8 secs.
    timeout 8

    # Change the colors.
    color yellow/brown light-green/black

    # For booting SliTaz from : /dev/hdb1
    title SliTaz GNU/Linux (cooking) (Kernel vmlinuz-
    root (hd0,0)
    kernel /boot/vmlinuz- root=/dev/hdb1

  • Trixar_zaTrixar_za January 2011
    The hd system works different than the sd system. Basically hd detects IDE configurations while sd detects SCSI, External (like external HDD, CD-Writers, Flash disks, etc) and SATA configurations.

    The 'Slitaz bug' you're experiencing is actually a bug in earlier versions GRUB and if you bothered using say Ubuntu 8.10, you'd have the same problem. It happens when you try installing GRUB on anything other than the Primary Master.

    The thing I can't work out is why you set your HDD as primary slave in the first place.

    I also don't believe you about Windows 'working perfectly' with that kind of setup. I have two HDD in my computer and the last time I tried installing Windows on the Primary Master, it detected and installed it as the E drive, meaning the Primary Master was put dead last. Further more, if you used any other distro that uses the older GRUB, you'd have the exact same problem, so in fact this isn't just SliTaz.

    So you want the quick and easy solution to your problem? Just change your drive to Primary Master. That's the Quick, Easy and Simple solution.
  • TheForsakenTheForsaken January 2011
    To tell you the truth, the very first Linux System I have tried was Ubuntu 9.10 where GRUB2 was first introduced in Ubuntu.
    If that is a real bug, then come on, why developers are still using GRUB Legacy? why they can't just fix it? I'm just speaking my mind.

    "The thing I can't work out is why you set your HDD as primary slave in the first place."
    Well, I did not want to make my scenario harder but I have another Primary Master HDD and It's almost full with many other distrubtions I'm testing so I can't play around with that.
    I can instead play around with my old 20GB IDE HDD and do whatever I want to do without being worry of losing the HDD for "any" reason.

    Well, sorry but believe it or not, it's your call :)
    I have done that and I installed Windows on a Slave HDD. It was working and I even had it on a Dual-Booting System with Ubuntu.

    Windows will not complain if you ask me as long as it will be installed in "Primary Partition".
    I don't know where that said came from that Windows MUST be installed in Master HDD + Primary Partition? I agree about the partition but I did it and Windows was working just fine on a "SLAVE" HDD, period.

    I'm afraid that fix is not good enough. I still need to use the other HDD and I need it to be the Master while this one where SliTaz is installed is the Slave one.

    If really there is no other way to fix that, then ... oh well.

  • Trixar_zaTrixar_za January 2011
    It's one of two software compatibility issues SliTaz has. It's probably wiser to move over to grub 2, but that would requiring a complete rewrite of how SliTaz interacts with it. I bet if somebody took an afternoon to figure this out, we'd all be on Grub 2 by now. It's by no means perfect and in many ways it's still way behind Legacy, but it does have a couple of things over Legacy, such as that it doesn't suffer from this bug, it also supports Windows 7 and other many distros.

    The second major issue is the use of HAL over the new udev system other distros are now using. If you've used the current most cooking (undigested) you'd have noted that this however is slowly changing and more and more of the udev system is being integrated.

    Hopefully by SliTaz 4's release both these issues will be addressed, but until then we're kind of stuck fixing it ourselves :P
  • TheForsakenTheForsaken January 2011
    As for GRUB2, I have started this thread:

    Hoping someone could help me out but did not get the right answer so far.

    I still consider myself new to Linux in general and I'm totally new to SliTaz.

    You were right about the "hd" system. I just checked another Distribution and it did the same, it detected my HDD as hdb not hda.
    So, I assume the same scenario will happen over again in case I'll install another system with the same issue "hdb".

    I have no experience about HAL and the other new system. I might start reading though.

    I don't really mind fixing it myself but don't you agree with me that it does not make sense to keep changing (hd1,0) to (hd0,0) everytime we install SliTaz? :)
    Yes, I know it's because my HDD is Slave but I still think there's some way to fix this.

    Thank you :)
  • Trixar_zaTrixar_za January 2011
    Because it's a problem with the code of Legacy. It's making a counting error. It also gives this problem with some SATA drives if I remember the ubuntu forum post about it correctly. Happened to me back in the day when I started with Ubuntu. It was one quick to learn Linux after coming from Windows... and I failed badly :P

    HAL is what handles hardware and plug-&-play detection in SliTaz. It's pretty old and has been a stale project for about 1-2 years now since the udev extensions replaced most of it's functionality. This is why many distros made the switch to using udev completely compared to using HAL. Our file manager, pcmanfm, is heavily dependent on it, but the current rewrite of pcmanfm has been somewhat recoded to work better with udev.
  • TheForsakenTheForsaken January 2011
    Then guess I'm lucky when I had started with Ubuntu 9.10 :P
    Actually I used it for very short time in 2009 (less than a month). In 2010, I went back to Linux and I don't have any Windows on my two PCs. I completely removed them except XP on VirtualBox. Last time I had XP installed when I was writing my guides for Ubuntu (Dual-Booting Guide and another one).

    So, guess we both agreed that GRUB2 must be used instead of Legacy :D
    Well, hope that will be done in version 4.0 :)

    I'm sure we can do it in this version. If not, then why would the devs put that in the package manager anyway?

    Good to know this abotu HAL. Thanks :)

    I still have some other questions regarding SliTaz but that's for another time/thread.

    BACK to topic. Do you think there is no other fix for my issue?

    Edit: Just to be clear, I don't mind when SliTaz detect my HDD as hdb but what I'm saying is ... why I have to configure the booting options manually and edit mene.lst just to login to SliTaz?

  • Trixar_zaTrixar_za January 2011
    Not any that I know of except upgrading to a higher version of GRUB or without using your manual solution.

    The older version of GRUB has caused a lot of issues with SliTaz like many systems, kind of like HAL has. The advantages Legacy has over GRUB2 is that it's easier to configure, customise and works better with older hardware. Not that you'd have any trouble with hardware using GRUB2 on a PII system or better though.
  • TheForsakenTheForsaken January 2011
    I see, thank you :)

    Perhaps we need to wait for another opinion? :)

    With GRUB2, I had no issues whatsoever, at least for now.
  • TheForsakenTheForsaken January 2011
    I managed to install GRUB2 and replace GRUB Legacy:

    I'll try to create an iso for SliTaz and using it to install it. I'm not sure whether this will fix my booting problem which is discussed in this thread but anyhow I'll report back :)
  • foxsamfoxsam January 2011
    why not use root=UUIDxxxxxxxxxxxxxxxxxxxxx or whatever is the right syntax then it will find it no matter what? when i built my lfs system thats what i tried.
  • TheForsakenTheForsaken January 2011
    foxsam, I'm afraid I did not understand so could you please explain :)

    My problem appears after installation not before, of course. I don't mind from doing it manually "chance (hd1,0) >> (hd0,0)" but it just doesn't make sense to keep doing that. There must be something wrong. Perhaps it's a bug as discussed before and it can't be fixed as of now.

    Now, even with GRUB2, I couldn't make it work the way I want. However, I'll give it a try. I'll create an iso, burn it and try to see what difference that will make. Yes, I mean an iso for SliTaz with GRUB2 installed instead of GRUB.

  • TheForsakenTheForsaken January 2011

    When I plug-in any USB-Drive, SliTaz detect it as "/dev/sda" while SliTaz always detect my Hard Drive(s) as "/dev/hdX".

    So, am I missing something here?
    Why it does detect the USB-Drive as "sdX" while it's detecting my HDD(s) as "hdX" ???
  • TotoetsasoeurTotoetsasoeur January 2011
    You don't miss anything! The right and usual way is (Slitaz uses that one if I'm not wrong):
    hdx => IDE drive,
    sdx =>SCSI/SATA (and usb) drive.

    But some other distros use sdx for all of them: IDE, SCSI, SATA and usb.

    Not a big deal. ;-)

    And in case of laptop, all are sdx (Not 100% sure about this).
  • TheForsakenTheForsaken January 2011
    So it is just the right syntax of SliTaz and there is nothing wrong, right?

    I used to deal mostly with "sd" system rather than "hd" system. You know that for example Ubuntu 10.04 uses "/dev/sdX" for HDDs and USB as well. I was just want to make sure there's nothing wrong because I don't have much experience with systems which use "/dev/hdX" system.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social