This is the old SliTaz forum - Please use the main

How to install an ATI Rage card (not Radeon!)?
  • GuidoGuido November 2010
    I've been trying the last few days to get this ATI Rage Mobility M3 AGP 2x (in a Dell Latitude C600) to work (vesa works of course but I want to use a better driver). After a lot of trial and error and google research now I know that this card is not supported by the ati driver (I think this should be stated in the wiki, only radeon cards are supported, not the rage family!). In other distros it is possible to find packages to install a driver under the name "r128". But there isn't any package related in the slitaz repositories. I tried converting a .deb package (had to move the because it was installed in a different folder) but got the following error in the Xorg.0.log:

    (II) LoadModule: "r128"

    (II) Loading /usr/lib/X11/modules/drivers//
    (II) Module r128: vendor="X.Org Foundation"
    compiled for, module version = 6.8.0
    Module class: X.Org Video Driver
    ABI class: X.Org Video Driver, version 2.0
    (EE) module ABI major version (2) doesn't match the server's version (4)
    (II) UnloadModule: "r128"
    (II) Unloading /usr/lib/X11/modules/drivers//
    (EE) Failed to load module "r128" (module requirement mismatch, 0)

    I tried with a newer one (6.8.1) but this time it says that it is compiled for 1.7.7 and ABI major version (7). So I see that there is a mismatch with Xorg core server being used (1.5.2) and the one the driver is looking for. I guess I need to compile the driver from source, which is here:
    But, being a noob in linux, how do I do that? Can someone create a package?

    PD: glxinfo reports that direct rendering is working and glxgears gears gives me around 35 fps with the vesa driver.
    PD: I'm using stable.
  • mojomojo November 2010
    Warning No 3d but
    I use this with Rage IIC:

    Add mach64 to /etc/X11/xorg.conf
  • GuidoGuido November 2010
    Hi mojo,

    I tried with that driver already but the card is not recognized, this is the error from Xorg.0.log:

    (II) Loading /usr/lib/X11/modules/drivers//
    (II) Module mach64: vendor="X.Org Foundation"
    compiled for 1.5.2, module version = 6.8.0
    Module class: X.Org Video Driver
    ABI class: X.Org Video Driver, version 4.1

    (II) MACH64: Driver for ATI Mach64 chipsets
    (II) Primary Device is: PCI 01@00:00:0
    (EE) No devices detected.

    Fatal server error:
    no screens found

    So I guess this chip is not supported by the driver, as this is the same error I get trying to load the radeon driver. Do you know of any slitaz documentation to read on how to compile a driver? Thx!
  • mojomojo November 2010
    I follow this:
    Prepare your System: tazpkg get-install slitaz-toolchain
    Not sure if you need linux-source which is about 50 MB.
    You're not compiling the kernel or it's modules.
    Extract the r128 source tarball
    Follow the directions in README
    It usually starts with
    Followed by
    Followed by
    make install.

    ./configure is the hard part, this is where a script checks what's on your system to verify it can compile.If it can't find what it's looking for it errors out.You either have to install what it's looking for or if it is installed edit the configure script so it can find it. Once you get through configure it's usually a breeze.
  • ouioui November 2010
    Hi Guido

    I would recommand to you to try following SliTaz flavor:

    Using it, it is possible to adopt different tactics:

    FIRST TACTIC: you start with tinyX (old Xvesa) and probably a relatively bad screen resolution but you can manage the problem using Xwindow

    SECOND TACTIC: you decide don't to use X at all at the first start (this flavor offers an adequate choice but you must go at the end of all choice with the mouse, not with the key 'cursor down'!). After that, you have to login as root with the password 'root', actualize and start the transaction 'tazx'.
    install the driver 'nv', don't start Xwindow but repeat the transaction 'tazx' and now install the driver 'ati'.
    install xorg-xinit
    inspect /etc/X11/xorg.conf and try divers solutions:

    ati driver, vesa driver, nv driver or radeon driver (radeon is included in ati!)

    start Xwindow with the transaction 'xinit'

    you can also try to define your own preselected screen resolution in xorg.conf instead to let make it for you!

    the more easy way to start in such in very difficult situation is to install as 'frugal installation' because you can make a lot of tests in a few minutes instead to use the heavy usual restarts!

    good luck!

  • GuidoGuido November 2010
    Ok, thankx mojo and oui for your suggestions. I managed to compile the driver and now I have it working. Glxgears is now reporting around 520 fps, so it is working fine. However I have one problem now, when the computer starts it takes me directly to the console, I have to login and then startx. After that everything works normal. I've checked the Xorg.0.log and I see no errors.
    I can't read fast enough what happens after I type startx and can't find a log file related to that. Where could I find the log created after the command startx? Any ideas on how to solve this very last step?
  • mojomojo November 2010
    When your in console,login as root

    Does X start then:
    root@slitaz: nano /etc/rcS.conf

    scroll down to RUN_DAEMONS=
    slim should be there after dbus hald
    If slim won't start X then:
    Look at /var/log/slim.log
  • GuidoGuido November 2010
    Thanx again mojo, that solved the problem, slim wasn't in the rcS.conf. After placing it it is now working perfectly.

    It would be great if a dev could make a tazpkg with the r128 driver, that would help a lot with the installation for newbies, as the compiling process is very time consuming. After all slitaz is targeted to low end computers so I think this chips should be supported as well.
  • ouioui November 2010
    hi guido

    I am happy, that I don't have to use slim at all: I login in console mode and did make a link for startx
    $ ln -s /usr/bin/startx /usr/bin/go

    and can continue with the short command 'go' to start X!

    It is more fast as well at login as at logout time!

  • GokhlayehGokhlayeh November 2010
    @guido :

    I just add xorg-xf86-video-r128 in wok :

    It would be available on tank repository in few hours :
    And on classical repository at next mirror sync - between few hours and few days - :

    You need to use SliTaz cooking to test it. All Xorg and related packages are up-to-date and should works fine, 3D acceleration included. I think that cooking is actually stable enough to use it, even if it's never really safe from breakage.

    I havn't test it as I don't have the good hardware. If you test it, please report the result here, I will try to fix it if problems happens.
  • sanger440sanger440 January 2011

    I am trying to get 3d to work in Cooking using your xorg-xf86-video-r128.  I have a P2 laptop with the mach64 Rage video card.  I loaded all the stuff from the wiki too.  I put "radeon" in the xorg.conf file and X will not start.  Using "vesa" slim will work and I can login again.  glxinfo | grep shows Direct Rendering: yes. 

    Modprobe DRM and Modprobe radeon show no modules, but maybe they shouldn't in this Cooking kernel.

    What driver do I put in the place of "vesa" in xorg.conf?  Mach64?  Radeon?  r128?




  • mojomojo January 2011

  • sanger440sanger440 January 2011
    Well, turns I needed the newer kernel.  I did not do an upgrade-all because it previously broke something.  With the newer kernel, Modprobe drm and Modprobe r128 load the modules.  But with "r128" in the xorg.conf, still X will not start.  I am thinking I need more package upgrades.  I am going to try and upgrade all the xorg packages and give it another try.
  • sanger440sanger440 January 2011
    I ended up doing a full upgrade and everything seems ok (only been a few minutes)  Again X would not start with "r128" in xorg.conf.  Looking at the xorg.0.log file shows a whole host of Rage 128 cards trying to detect.  In the end it said "60.019] (EE) No devices detected."

    So apparently Gokhlayeh's xorg-xf86-video-r128 package does not recognize the old Mach64 ATI Rage card.

    Should I email him?  He did say he would like a report.

  • gdesilvagdesilva January 2011
    I have an ATI Rage card as well and had almost the same problems described above with Slitaz 3.0. Then I installed the latest cooking version (Nov 2010) which has the r128 package. Installed r128 and now everything is working OK.
  • sanger440sanger440 January 2011

    I have cooking version installed and all packages updated, but it the rt128 driver would not load.

    gdeslva, what does  glxinfo | grep render  show on your Machine? 

  • Trixar_zaTrixar_za January 2011
    Use the cooking version found here:

    The cooking provided on the website uses the older 2.6.34 kernel while all it's modules are compiled for 2.6.36. Hence instant breakage if you try to use the newer modules with the older kernel.
  • sanger440sanger440 January 2011

    After doing full upgrade to cooking, the 2.6.36 kernel is installed and is the one I boot into. The DRM and r128 modules load with modprobe.  I think the problem is I that this r128 driver does not support my ancient Mach64 chipset ATI Rage 2c (rev64) card.  It probably supports the ATI Rage Mobility M3 AGP 2x which Guido uses at the top of this thread and most of the other Rage 128 cars.  So I think I am going to have come up with another way to get the 3d mach64 driver installed and working.

    Any suggestions?

  • GokhlayehGokhlayeh January 2011
    Hi, I think that a specific driver is needed for you'e card; I will push it to the repo soon.
  • sanger440sanger440 January 2011
    Thank you for attention in this manner.  I have scoured the internet on this Mach64 install, and most of it is very outdated.  Below is the best info I could find:

  • gdesilvagdesilva January 2011

    I had to install mesa-demos to get glxinfo working and here is the output;

    direct rendering: Yes
    OpenGL renderer string: Software Rasterizer
        GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_fragment_program,

    Hope this helps.

    EDIT : BTW my card is ATI Rage 128 Pro Ultra TF which I note is slightly different to what you have.

  • GokhlayehGokhlayeh January 2011
    @gdesilva: OpenGL renderer string: Software Rasterizer; Software Rasterizer is a generic 3D render and doesn't use capabilities of you're own graphic card (if it had some 3D capabilities) = it's slow;
    Can you use glxinfo as root to see if it's give the same result ? I need to know if it's a permission or a dri problem. Thanks.
  • gdesilvagdesilva January 2011
    @Gokhlayeh, the result is the same.

    I hope I did not put you guys off the track...I am using a Dsub (analog) screen and I have the following error messages in my Xorg.0.log file.

    [   846.066] [drm] failed to load kernel module "r128"
    [   846.066] (EE) [drm] drmOpen failed.
    [   846.066] (EE) R128(0): [dri] DRIScreenInit failed.  Disabling DRI.

    Not sure what this means but apart from these error messages everything else looks OK.

    If you need any further info please let me know.
  • GokhlayehGokhlayeh January 2011
    Work in progress; I'm updating libdrm/mesa then pushing the package for mach64 driver on the mirror - as mesa update means xorg-server & video drivers recook. Also some packages split to make things slimmer (particulary for r128).

    @gdesilva: thank for the report, that's precisely the relevant part of the log :)
    This module should be located in /lib/modules/2.6.36-slitaz/kernel/drivers/gpu/drm/r128/ and is actually packed into linux-drm package; the downloadable cooking ISO use linux 2.6.34 - but r128 driver you download from mirror was compiled against the last packages. I guess it's why it doesn't find the module.
  • GokhlayehGokhlayeh January 2011
    Please don't upgrade you're system yet, it can break it: only a part of the update have been pushed to mirrors, I will finish this tomorrow as it's late here.
  • sanger440sanger440 January 2011


    Cooking comes with 2.6.34, but when you do a full update, the 2.6.36 Kernel becomes available.  Once I did the update and booted into the 2.6.36 Kernel, the r128 and the drm modules loaded without errors.  When I pointed the xorg to r128 driver, X would not start, and the log file showed that it that my video card (mach 64) was not detected.  But I think any Rage 128 supported cards would of been detected and loaded properly.

    Reading up on the mach64 chipset video card, it appears support for it dropped for it some time ago do to security concerns.  So now you have to build it separately, but that is beyond what I can figure out how to do. 


    So gdesilva, what Kernel are you booting into?  uname -r in xterm will tell you.




  • GokhlayehGokhlayeh January 2011
    @sanger440: the comment about kernel update targeted gdesliva' case. I pushed the receipt for mach64 driver few hours ago:; it will be available soon on the mirror.
  • GokhlayehGokhlayeh January 2011
    New linux/libdrm/mesa/r128 & mach64 are available on the mirror

    Edit : tazx config-xorg should setup driver
  • sanger440sanger440 January 2011
    I downloaded both of your packages an installed them.  I then changed to "mach64" in the xorg.conf.d file.  Booted right into X but glxinfo still showed direct rendering: Yes
    OpenGL renderer string: Software Rasterizer

    Looking at the xorg log file, everything looks pretty good, the Mach64 driver loaded and it detected the correct video card, etc but there was this message:

    [   884.112] [drm] failed to load kernel module "mach64"
    [   884.112] (EE) [drm] drmOpen failed.
    [   884.113] (EE) MACH64(0): [dri] DRIScreenInit Failed
    [   884.114] (II) MACH64(0): Largest offscreen areas (with overlaps):
    [   884.114] (II) MACH64(0):     1024 x 1279 rectangle at 0,768
    [   884.114] (II) MACH64(0):     768 x 1280 rectangle at 0,768
    [   884.114] (II) MACH64(0): Using XFree86 Acceleration Architecture (XAA)
    [   884.115]     Screen to screen bit blits
    [   884.115]     Solid filled rectangles
    [   884.115]     8x8 mono pattern filled rectangles
    [   884.115]     Indirect CPU to Screen color expansion
    [   884.115]     Solid Lines
    [   884.115]     Setting up tile and stipple cache:
    [   884.115]         32 128x128 slots
    [   884.115]         10 256x256 slots
    [   884.116] (==) MACH64(0): Backing store disabled
    [   884.117] (==) MACH64(0): Silken mouse enabled
    [   884.120] (==) MACH64(0): DPMS enabled
    [   884.120] (II) MACH64(0): Direct rendering disabled

    I have the moduel "drm" set to load at startup. 
    When I type modprobe mach64 no module found.

    Thanks for all your efforts.
  • gdesilvagdesilva January 2011
    @sanger440 - my boot image is 2.6.34-slitaz
  • mojomojo January 2011
    We need mach64 included in linux-drm.tazpkg
  • GokhlayehGokhlayeh January 2011
    In fact there's no (or no more ?) module mach64 into linux kernel...
  • sanger440sanger440 January 2011
    @Gokhlayeh: So I take it neither of the two new packages install a module for mach64? 
    I am guessing that is the hard part because support ended for this card so long ago.

    @Gdesliva:  If you are using cooking, then you must not have done the "upgrade all" since that would of given you the 2.6.36 kernel, and the r128 drivers/modules would of probably worked for your video card.  However, sometimes "upgrade all" breaks other stuff, so you might want not want to do that. 

  • gdesilvagdesilva January 2011
    @sanger440 - Thanks for the warning. I am not doing any fancy graphics so the current set up with the r128 driver is good enough for me. I will wait for the next cooking iso release just as a precaution.
  • GokhlayehGokhlayeh January 2011
    @sanger440: Nope, no module is packaged. A module is a part of the kernel, generally compiled during kernel compilation and packed in a linux-* package. When you compile the kernel, you have to choose for various option if you want to include the functionality into the kernel, if you want to build it as module - in this case it can be loaded automatically or manually at runtime; or if you don't want to compile it. There's a lot of functionality available with linux, but no drm_mach64:

    I don't know what can be the alternatives, but the Xorg driver I packaged is something else : it allow you to use you're graphic card better, but without 3D acceleration (as it needs the drm module). In example, you should be able to change for a better screen resolution using xrandr or lxrandr.
  • sanger440sanger440 January 2011

    @Gokhlayeh:  Thank you for all your efforts.  Your Xorg package for the mach64 worked flawlessly.  I was hoping for 3d acceration to help my poor old P2 laptop to stream youtube and other video's better. Looking through all the forums I could google, it appears the mach64 module was pulled out 3-4 years back.  For a while, there was some success compiling a module from older binary snapshots but I have not seen any that will work with the newer 2.6.30's Kernel.  I tried a couple just for grins and they errored out while trying to compile, but I really do not know what I am doing either LOL!

    But Slitaz boots fast, is great for browsing, email, openoffice, etc,  and is much faster than winxp or win2000 ever was.  The wireless works exceptional.

    Thanks again.

    Update: By chance I found a tarball that compiled and installed without errors.  This is what glxinfo shows:

    direct rendering: yes

    Opengl rendering string: Mesa Dri Mach64 (Rage Pro) 20051019 AGP 2x x86/mmx

    I found the tarball here:

    It does not seem unstable so for, we'll see.





  • GokhlayehGokhlayeh February 2011
    Cool, thanks for info. I will add it to SliTaz wok.
  • sanger440sanger440 February 2011

    I have another IBM P2 laptop with the ancient ATI Rage 2 card.  With the latest cooking installed and updated, the archlinux file linked above would not compile on the latest cooking 2.6.37 Kernel.  But later the Arch linux link was updated to work with the 2.6.37 Kernel and it compiled and intalled.  This ATI Rage card was really old and did not have much ram.  I had to configure it as 16 bit (which the Arch Linux link recommends) before it would work properly.  Even then, the performance was much less than I hoped, but it is what it is.



  • GokhlayehGokhlayeh February 2011


    We currently rebuild all the repository, so this will not be available before few days.
    Converted packages are generally known to be slower than thoses compiled for SliTaz, so maybe you can expect better performances with this one.

    Once the package become available for you, please give me news about how it works :)

    See you,

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social