This is the old SliTaz forum - Please use the main

HP device manger not starting
  • gdesilvagdesilva November 2010
    I installed hplip and other dependencies and now I get the HP Device Manager option under utilities. However, the program does not start when I select this option. Any ideas why this is so?

  • mojomojo November 2010
    According to the receipt for hplip.tazpkg
    # remove .desktop file as we compiled without pyqt3 support
    rm -rf $fs/usr/share/applications/*

    pyqt3 support which is not compiled in must be required to start hplip from the menu so the .desktop file was removed.
    Open terminal,login as root:
    root@slitaz: hp-setup

    If it doesn't start post the error messages.
  • gdesilvagdesilva November 2010
    Hi mojo, "rm -rf $fs/usr/share/applications/*" was a disaster as it screwed up all my desktop icons! Should have thought about it before using '*' but didn't. Anyway reinstalled OS and removed the hplip.desktop and tried hp-setup but got the following;

    Using connection type: usb
    error: No device selected/specified or that supports this functionality

    Then I ran 'hp-probe -bnet' command and it detected my printer without any problems.

    I then tried 'hp-setup 'printers ip address' without any success. The result was a message saying that the device uri was invalid.

    Tried hp-setup with the uri returned from the hp-probe command still without success.

    Any further ideas?

    EDIT: Ok had some sort of success using hp-setup -bnet ip_address commad. This in fact guided me through the installation of the printer and it all looked good till I printed a test page and I got a 'segmentation fault' error message. I read else where that someone had a similar problem and had to get ahavi daemon installed. There is no package called ahavi in the repos so how do I install ahavi daemon?

  • mojomojo November 2010
    Very very sorry, we got our signals crossed :(
    I never intended you to run that command. It's in the receipt that is executed to compile and package hplip.

    Now I can see how it happened and will never quote a command like that again.

    It looks as if the hplip package is offered only for it's drivers and that the gui setup is non functioning.

    This guide should get your printer working.

    Good luck
  • gdesilvagdesilva November 2010
    No worries...I am just checking Slitaz out and reinstallation is a breeze I must say.

    Just to add a comment to your doco - if one needs to configure a network printer one would need to type 'hp-setup -bnet' otherwise it defaults to configuration of usb connected printers.

    I still get the segmentation fault when doing a test page print.
  • mojomojo November 2010
    Open your web browser to this address:
    Printers, top right to verify that your printer is installed.
    Click your Printer's name (blue link)/Maintenance menu/print test page
    If printer is not in Printer list leave hplip installed for it's drivers/filters,
    Try to use this interface to add your printer instead of hplip.
    See the quickstart directions:
    http://localhost:631/help/overview.html -> Where Do I Begin ?
  • gdesilvagdesilva November 2010
    Hi, I did use the cups printer interface as well and the result is the same.
  • gdesilvagdesilva December 2010
    Workaround for this problem was to use socket interface in defining the printer using cups. I haven't pursued the hplip configuration issue.
This discussion has been closed.
← All Discussions

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social