This is the old SliTaz forum - Please use the main

Support for Moschip 7830 usb-ethernet module [solved]
  • gdesilvagdesilva November 2010
    Does any one know whether Slitaz supports USB to Ethernet modules based on Moschip 7830? If so, where can I find the kernel module for this?

  • mojomojo November 2010
    Search the google:
    tux@slitaz:~$ zcat /proc/config.gz | grep CONFIG_USB_NET_MCS7830
    # CONFIG_USB_NET_MCS7830 is not set

    Not compiled into the kernel or available as a module on slitaz-3.0 stable .
  • gdesilvagdesilva November 2010
    Is there a lot involved in compiling the module? The linux driver source code is available from Moschip. I have had a cursory look at tazwok pages but would appreciate your thoughts on this as I do not want to waste too much time on this. Thanks.
  • TotoetsasoeurTotoetsasoeur November 2010
    Nobody likes wasting his time. In my opinion, solving a problem AND sharing obtained results really worth it. :-)

    Anyway you should have a look at the following, especially the step-by-step method I wrote at the end of the post. It is not related to your device but the method to use should be similar:

  • gdesilvagdesilva November 2010
    Hi Stephane

    I had a cursory look at the link you sent - does not look too bad. However, the laptop I am using has a very small disk - just 16GB and it would help if you can tell me how much space is going to be used up by downloading linux-source?
  • TotoetsasoeurTotoetsasoeur November 2010
    16GB is enough as far as I know.

    For reminder:
    - once compilation and installation processes are over, you can get rid of linux-source previously downloaded.
    - Try to download the source and you will answer to your question better than I did.

  • gdesilvagdesilva December 2010
    Hi Stephane,

    I tried to load slitaz on my desktop to dual boot with Ubuntu so that I can download the source and build the module. Unfortunately, although grub sees the Slitaz partition the display goes blank so that idea failed.

    However, I booted using LiveCD and since I have enough RAM on this machine downloaded source and followed your instructions. And the good news is that despite a warning message during the make it all seem to work fine. In fact, I am using the USB Ethernet port to do this post.

    Your instructions were great and very clear. Many thanks to you.

    Not sure how I can share this module since I did not use Tazwok. If you can tell me how to make it available that will be great. Thanks again.
  • TotoetsasoeurTotoetsasoeur December 2010
    Well done! I'm glad you found the info useful. :-)

    I think the best would be that you post here all steps you went through. Based on something like I did.

    Moreover, you could send your module to mailing list. Hopefully one dev guy will manage or tell you how to make it available.

    Happy Slitaz.

    PS: do not forget, once you've post your step by step procedure, to edit subject title and add [SOLVED]
  • gdesilvagdesilva December 2010
    For the benefit of those who will come across the same problem, the solution is as follows. This solution was already mentioned elsewhere by totoestsasoeur - see

    There were some minor issues when following the steps outlined above which you may want to take note of . Apart from these issues, I had no problem activating the USB Ethernet module.

    Step 3 - I had to use "make CONFIG_USB_NET_MCS7830=m M=drivers/net/usb" command. I noted that the mcs7830.c file was located in drivers/net/usb directory and not in drivers/usb/net directory.

    Step 5 - install firmware did not result in any errors but when I did a ls command it was not able to find any firmware file for mcs7830.

    Also, you would need to make the this device's ethernet port the default one so that you will have the network connection at bootup.

    Thanks for Stephane for outlining the process.

This discussion has been closed.
← All Discussions

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social