This is the old SliTaz forum - Please use the main

[SOLVED] wifi card and Cardbus not detected
  • gdesilvagdesilva November 2010
    I installed slitaz on an old Portege 2010 and I am pretty impressed with the performance. However, I cannot get the OS to detect the mini PCI wifi card (I think OEM by Agere) and the Cardbus attached DVD drive. I have gone through the doco extensively but nothing seems to activate the these cards.

    Any thoughts or suggestions?

  • kultexkultex November 2010
    here is somthing for your wifi:

    and for the cardus DVD can you give the output of lspci
  • gdesilvagdesilva November 2010
    Here is the output of lspci....

    00:00.0 Host bridge: ALi Corporation M1644/M1644T Northbridge+Trident (rev 01)
    00:01.0 PCI bridge: ALi Corporation PCI to AGP Controller
    00:04.0 IDE interface: ALi Corporation M5229 IDE (rev c3)
    00:06.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link Controller Audio Device (rev 01)
    00:07.0 ISA bridge: ALi Corporation M1533/M1535/M1543 PCI to ISA Bridge [Aladdin IV/V/V+]
    00:08.0 Bridge: ALi Corporation M7101 Power Management Controller [PMU]
    00:0a.0 Ethernet controller: Intel Corporation 82557/8/9/0/1 Ethernet Pro 100 (rev 0d)
    00:0c.0 USB Controller: NEC Corporation USB (rev 41)
    00:0c.1 USB Controller: NEC Corporation USB (rev 41)
    00:0c.2 USB Controller: NEC Corporation USB 2.0 (rev 02)
    00:10.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Controller (rev 01)
    00:11.0 CardBus bridge: Toshiba America Info Systems ToPIC100 PCI to Cardbus Bridge with ZV Support (rev 32)
    00:12.0 System peripheral: Toshiba America Info Systems SD TypA Controller (rev 03)
    01:00.0 VGA compatible controller: Trident Microsystems CyberBlade XPAi1 (rev 82)

    As you can see the wifi card does not even appear here although the LED indicates that it is active and was working when I had XP installed.
  • kultexkultex November 2010
    sorry the wifi link was absolut nonsense - just to quick, before I had to go out. And I am sorry, I cannot find any info about the wifi chip and linux in the net. Did you get it running with any other Linux distribution?
    Same for your DVD Drive - whats the exact name?
    and the output of lsmod
  • kultexkultex November 2010
    Here I found one linux document, that reports, that wifi works fine, but not which module
  • kultexkultex November 2010
    perhaps it has the same hardware as a portege 2000 (only different CPU)

    so the wifi modul could be orinoco - try modprobe orinoco

    could be also the same as Portege 4000

    at least lspci points on that

    "WiFi - Lucent ORiNOCO - eth1
    Use the wvlan_cs (or orinoco_cs) driver.

    There is an `on' / `off' switch at the `front', RHS, near the `Portege' sticker to the right of the mouse buttons.
    PCMCIA/CardBus - TI PCI1410 + Toshiba ToPIC95
    It has a single internal slot `Texas Instruments PCI410 PC card Cardbus Controller (rev 01)' to drive the internal WiFi card, and a Toshiba `ToPIC95 PCI to Cardbus Bridge with ZV Support (rev 32)' "

    so the wifi is attached over cardbus so first the cardbusdriver has to be loded bevor the orinoco
  • gdesilvagdesilva November 2010
    see below
  • gdesilvagdesilva November 2010
    sever is playing up...hence the multiple posts..sorry.
  • gdesilvagdesilva November 2010
    Hi kultex, many thanks for all the information you have come up with. Unfortunately, just now my LAN port has died! It was a bit flaky to start with but now I cannot activate the LAN port at all. I have already ordered a usb LAN module so that should not be an issue. Yes, the on/off switch for wifi has always been in the 'on' position.

    One more thing can I load the cardbus driver?

    Thanks once again.
  • kultexkultex November 2010
    The ToPIC95 PCI is supported by the module "yenta socket"
    which module is supporting Texas Instruments PCI410 PC, I cannot find in the moment - perhaps somebody else could help - no time in the moment
  • mojomojo November 2010
    Verify output from lsmod shows yenta socket is loaded.
    Make sure you have pcmciautils.tazpkg installed.
    Use pccardctl with commands listed here:
    To get DVD drive interface and wireless chipset hardware and socket id's
    Google the hardware ids with linux, ubuntu, etc. to determine the correct modules to load.
    modprobe -l | grep -i
    to see if you have the module.
    If not:
    Do a file search on module names here:
    to find which package to install that has the module.
    Add the modules to /etc/rcS.conf LOAD_MODULES=
    In Xterm
     wodim -inq
    to see if DVD drive is recognized.
    ifconfig -a
    to see if wireless card is recognized.
  • gdesilvagdesilva November 2010
    Many thanks to kultex and mojo.

    I managed to fix the problem with wifi - all it required was to load the orinoco_cs module. I don't have a clue what the firmware should be but I left it at b43-firmware and lo and behold the wifi card came into existence. Prior to posting this I tried the orinoco and orinoco_pci (not the orinoco_cs) modules but unfortunately did not try orinoco_cs!

    I still have no idea how to access the pcmcia connected dvd drive and if you have any bright ideas please let me know.

    Thanks a lot guys.

  • gdesilvagdesilva December 2010
    Just for the benefit of those who may come across the same problem, the solution to recognising the DVD drive was to load the ide-cs module (modprobe ide-cs). Once this was done, my dvd drive was recognised accessible via /dev/hde as per the boot log. I did have to put my user id in the group 'disk' and 'cdrom' otherwise the mount command would fail (or do chmod 666 on these device files)

    Thanks to kultex and mojo for advice and comments.
This discussion has been closed.
← All Discussions

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social