This is the old SliTaz forum - Please use the main

Wireless Connection
  • ValeourValeour March 2011
    Okay, I'm new to linux altogether, I've managed to pick up a few things, but not alot. I decided to use Slitaz because it seemed perfect for an old laptop I have.

    I've managed to figure most things out myself or through this forum and other places, but I cannot for the life of me get my wireless dongle to connect to any AP.

    It's a NetGear dongle, I have no idea what model/make, etc. I got ndiswrapper and install the drivers, but it still doesn't turn on unless I force it with

    sudo depmod -a
    sudo ndiswrapper -m
    sudo modprobe ndiswrapper
    Then my actual problem arises. I can see all the routers and things, but whenever I try to connect, it just does nothing, except scan for APs again.
    I also changed the internet method from eth0 or lo to wlan0, I get a signal strength bar, but if I connect to my router, the signel strength is 0, and just says disconnected. However, if I access an open access point from nearby, I'll get signal strength, but the status is still disconnect and I cannot connect at all.

    This is becoming a slight pain, so any help will do. And yes, I've tried upgrading the drivers, kernals, etc.
  • mojomojo March 2011
    Ndiswrapper is broken on slitaz-3.0 ,the network adapter associates to the wireless router but never achieves network connectivity.
    Ndiswrapper is pre-installed and works on slitaz 2.0
    I'm having boot problems with cooking so haven't tested ndiswrapper on it. 

    Post the complete output from:
    With that info I can check if there is a linux driver on slitaz-3.0 for the chipset in your usb adapter. 
  • ValeourValeour March 2011
    Thanks for the reply, much appreciated.

    And, apparently, lsusb isn't a recognized command, and I can't seem to find a package for it.

    What do I need?
  • babaorumbabaorum March 2011
    It is in "usbutils" package.
    You can have a more detailed output w/ "usb-devices" command provided with the same package. ;-]
  • ValeourValeour March 2011
    Unfortunately the only ethernet cable I have is in the back of my PC, so I'll either have to download the package tomorrow or sometime on the weekend, thanks anyway, I'll get back ASAP.
  • ValeourValeour March 2011
    Okay, managed to download and get lsusb;

    Bus 001 Device 002: ID 1385:5f01 Netgear, Inc WPN111 (no firmware)

    (judging by no firmware, I guess that's bad?)
  • mojomojo March 2011
    Searching google for "1385:5f01 linux " returns no results for a  linux driver.
    Ndiswrapper is the only way to use this adapter with linux.
    I suggest:
    Menu/System Tools/Wireless Networks Connections/Drivers tab/Install Windows driver button
    Browse to windows driver .inf file Load the driver

    Some WPN11 info @ ndiswrapper wiki:

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership


SliTaz Social