This is the old SliTaz forum - Please use the main

.config file of the kernel shipped with Slitaz 3.0
  • OldGuyOldGuy February 2011

     does anyone know where I could find 'the' original .config file used for the kernel shipped with Slitaz 3.0?

    All attempts to recompile the current kernel end up in different sizes. :-(

    According to my experience it should be the same size, hence I guess that some options differ between the .config I have and the original.

    Any help appreciated!!

  • mojomojo February 2011
    This is how to print to file kernel config on running slitaz.
    zcat /proc/config.gz > my.kernel.config

    See where tazwok cooks the stable kernel:
    Either clone wok-stable or click browse link at
    Go to linux folder
    View receipt and stuff folder which has patch's, kernel configs. etc..
  • OldGuyOldGuy February 2011
    Ok, I guess I'm again chasing the wind. :-(

    If I have a look in wok-stable, it seems that those are patches and I would think there are all included in the current download of linux-source.
    Nevertheless, looking trough them I found that the modification described in wok-stable changeset 5182:efca0feeb58e are, while the modifications described in wok-stable changeset 5202:db226c2b7ebb are not patched into the linux-source when installed with 'tazpkg get-install linux-source'.

    How can I find out which patches are included in the kernel currently distributed with the core flavor?


  • mojomojo February 2011
    linux-source receipt has WANTED="linux"
    WANTED package linux is cooked (patched/compiled)first as it is the source of the files for the package linux-source .
    Packages that have a WANTED have local url , no download address since they get there files from pre-cooked WANTED package and their own stuff folder
    Kernel patches go to linux and migrate to linux-source because patched linux is the source of linux-source
    The patches for kernel in slitaz-3.0.iso are in the wok-stable/linux/stuff folder
    Both changesets are applied to linux-header- in the above folder.
    You will have to look at the receipts and cook both packages to determine why the one changeset is missing in linux-source.

    Info about receipt variables:
    Custom Kernel Guide:

  • OldGuyOldGuy February 2011
    Maybe I' missing something.
    What I did so far is to setup a fresh Slitaz 3.0 core installation on a dedicated HDD.
    Thereafter I followed the Custom Kernel Guide.

    # tazpkg get-install slitaz-toolchain
    # tazpkg get-install ncurses-dev
    # tazpkg get-install perl
    # tazpkg get-install linux-source     <- it seems at this point the sources are patched
    # /usr/bin/get-linux-source              <- There is no 'get-linux-source' script or command !!!

    # cd /usr/src/linux
    # make oldconfig && make prepare
    # make

    now I shut have the same bzImage file under arch/x86/boot/ as is shipped with the slitaz-3.0.iso, or is there anything wrong with this approach?

    I found the 'linux-header-' file included in the linux-soure- which is used to patch the sources and should, to my understanding, contain the changeset 5202 but doesn't.

    Does this mean the 'linux-source-' downloaded during the process is not the most current?
  • slicelslicel March 2011
    I cannot answer your question but I can add that I experienced mismatches too.

    I posted a year ago that a diagnostic tool reported a kernel mismatch between slitaz 3 stable xvesa and a slitaz modem driver.

    I tried linux "make" instructions but received an error that slitaz did not have the expected linux-headers directory.

    Linux changed its versioning system since 2.6.11.

    I did not see any slitaz kernel version history on the website anywhere.

    I also did not see ram or hd system requirements for compiling.

    Tazwok extraversion might not be the same as kernel extraversion.

    I asked where tazwok gets its versioning information but did not receive an answer except that it was "magic."

  • slicelslicel March 2011
    Jozee told me in October 2009 only to install linux-source while the guide lists more packages as necessary but the guide might be wrong too because granda also needed slitaz-dev-pkgs, a package that is not mentioned in the guide at all.

    Following directions is easy.  Finding correct slitaz directions is difficult.

    Maybe this information can help in some way with your problem.
  • Trixar_zaTrixar_za March 2011
    October 2009 was still SliTaz 2 and that cooking version. Many things were added to SliTaz 3 including several meta-packages like slitaz-dev-pkgs.

    Now try compiling that same package on Debian, Ubuntu or even Puppy. Note the same errors? But unlike SliTaz they don't have the slitaz-dev-pkgs meta-package to install all the requirements.

    In fact, Jozee compiled those modem drivers for you in the end even with the bad and irrelevant information you were giving him. And like when I tried to help you, you felt that it was your right to bite our heads off.

    I tried to be nice to you, but that didn't work. I tried to ignore you, but that didn't work. Now I'm going to just tell you directly: If you don't like SliTaz then use something else. Otherwise let us improve SliTaz without your badly thought-out, off-topic, public asinine "suggestions" and criticisms. This is NOT our jobs and it doesn't provide income to us. That means your "Customer is always right" mentality doesn't belong here and won't win you friends with ANY community driven project.

    If you want to fit in here then HELP OUT. Suggestions isn't helping out. Pointing out irrelevant things which is off topic in somebody elses post isn't helping out. Biting people's heads off or lamenting about stuff trying to win people over your way of thinking - isn't helping out. It's being a hinderence.

    Helping out means creating packages or providing concise and helpful solutions to people. You want to see how I did it? - and just to show you a few. If you get to be that helpful, then I'll respect you. Not before.
  • OldGuyOldGuy March 2011
    Unfortunately, this discussion doesn't get me anywhere either.

    Trixar_za, do you know who did 'cook' the 3.0 kernel or how?
  • Trixar_zaTrixar_za March 2011
    It probably was pankso that cooked the SliTaz 3 kernel or somebody else who has access to the build server. I know Pascal Bellard has access and he also applied several patches to our busybox. Either way, pankso is probably the the one to ask.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social