This is the old SliTaz forum - Please use the main

Installation - newbie.
  • wagoneer89wagoneer89 February 2011
    Hi gang,

    I can get around Ubuntu on this modern laptop but I've never spent any time under the hood in Linux, this is my initiation.

    I'm intalling Slitaz (3.0) lomem (I believe) on an IBM Thinkpad 600 (not a 600e). Slitaz is WONDERFUL off of the Live CD, I'm very excited to try it. My goal is to make this machine a dedicated Internet radio, but I will take what I can get... if it just works as a stand alone word processor, that's OK too! This machine is 133 mhz and 97728 KB. 4 gig of HD storage. I have been trying to get it up and running with anything that is small enough to run it, and not from MS, for a couple of years! This is the closest I've gotten so far although I did get a load of Redhat 6 up until I destroyed the video... but that was an OS contemporaneous to the machine, I want something current.

    I've got the HD partitioned via GParted to 3.?G and a 1.25G swap. The 3.?G is hda1 and is where, I expect, Slitaz should be loaded. I ran Spinrite on the disc before setting up the drive and it is essentially flawless, but Spinrite did tell me that "SmartDrive" had been turned off... and Spinrite claimed to have turned SmartDrive back on.

    Everything seems to go as it should until:
    "Starting udev daemon...   [ Failed ] (I've read on this site that this is normal)
    Then a few lines further down:
    "Mounting filesystems in fstab...
    /etc/init.d/rcS: line 255: can't create /var/log/dmesg.log: nonexistent directory
    /etc/init.d/rcS: line 255: can't create /var/log/boot.log: nonesistent directory
    script: can't open '/var/log/boot.log/: No such file or directory

    SliTaz GNU/Linux Kernel tty1

    (none) login:"  (Quotes added)

    I am then able to login as root.

    I've tried the manual install in the documentation but my linux terminal skills are still VERY green. While the Live CD will load and this means that the CD somehow works... I can't see it when I use the command "dmesg" (I don't think). I do see:

    "EXT3-fs: mounted filesystem with writeback data mode.
    VFS: Mounted root (ext3 filesystem) readonly on device 3:1.
    Freeing unused kernel memory: 328k freed
    EXT3 FS on hda1, internal journal
    root@(none):~# " (Quotes added)

    As I have no output working I have copied this from the screen and tried to be accurate... I doubt there are any issues with the syntax, if you see syntax errors expect that they were produced by being copied rather than by flawed software.

    I hope I am not imposing too heavily being so green, any direction would be appreciated...

    Thank you.
    Bill  Minden, NV
  • mojomojo February 2011
    Your logged in to linux,determine your graphics with lspci, install the if available,make a xorg.conf(X -configure, mv /root/ /etc/X11/xorg.conf ),start X with slim or startx command. If there is no graphics driver make an xorg.conf (X -configure, mv /root/ /etc/X11/xorg.conf )and configure the vesa driver.
    See Configuring X :
  • wagoneer89wagoneer89 February 2011
    "root@(none):~# lspci
    lspci: error while loading shared libraries: cannot open shared object file: No such file or directory
    root@(none_:~#"  (Quotes added)

    I'm figuring that "lspci" means list the PCI connections. Not sure this thing isn't OLDER than PCI.  I'll surf the net and see if I can determine what the video card is. Video is natively supported from the Live CD. I figured that the driver must be in there. Am I missing something? The resolution is loading at 800 x 600 and should be 1024 x 768, but it works, I figured I could sort that out after loading it onto the hard drive.

    Thanks for the post... I'll be trying to find the video card specs on Google. I appreciate your time!

  • wagoneer89wagoneer89 February 2011
    Looks like I have a NeoMagic MagicGraph 128XD 2.0MB video card (if another owner on the "" site is correct. It seems that the interface is PCI. The 600 is seemingly rare... I don't find much info on them even on the Lenovo site. The 600e, not so much.

  • wagoneer89wagoneer89 February 2011
    /etc/init.d/rcS: line 255: can't create /var/log/dmesg.log: nonexistent directory
    /etc/init.d/rcS: line 255: can't create /var/log/boot.log: nonesistent directory
    script: can't open '/var/log/boot.log/: No such file or directory

    I created the directory '/var/log/boot.log/' and the boot process continued on to a later fail. I still have no graphical display, but the computer did load up to the point where I got a character based graphic penquin and a note on documentation.

    The last of the note says "Type  'startx' to start a X window session." It did not work... but we're closer.

  • wagoneer89wagoneer89 February 2011
    lspci now returns:

    "lspci: error while loading shared libraries: cannot open shared object file: No such file or directory" (quotes added)

    I don't know where this file is supposed to reside, or where I get if from, so more research is needed. Anyone with a solution?

  • wagoneer89wagoneer89 February 2011
    After Reboot:

    Starting all daemons specified in  /etc/rcS.conf...
    /etc/init.d/dbus: line 18: can't create /var/lib/dbus/machine-id: nonexistent directory

    Starting message bus daemon: DBUS... /usr/bin/dbus-daemon: error while loading shared libraries; /usr/lib/ file too short                                 [ Failed ]

    Starting Hardware Abstraction Layer: HAL... /etc/init.d/hald: line 53: /usr/sbin/hald: not found   [ Failed ]

    Starting slim login manager: Slim...                      [ OK ]

    Welcome to your box.
    SliTaz goot time: 7s

    SliTaz GNU/Linux Kernel tty1

    thikpad login: root

    {Documentation in /usr/share/doc. Use 'less -EM' to read files,
    become root with 'su' and edit using 'nano'.
    Type 'startx' to start a X window session.}

    root@thinkpad:~# startx

    (After "startx" nothing happens except for the new line with the prompt)

    Soooo, off to find out the secrets of HAL and DBUS...


  • ms3811ms3811 February 2011
    Just to backtrack a bit, I'm hoping you installed Slitaz from the LiveCD using Start-->System Tools-->Slitaz Installer?

    Seems like your installation didn't really go through successfully. The problems you are describing don't appear to be related to hardware drivers as such, but rather a corrupt installation. Just a guess.

    You might want to consider a reinstall. Reboot from the LiveCD, delete all partitions using GParted, recreate your partitions (note the partition identifiers in GParted for use during install), format using ext3 and install (the install should format using ext3 anyway).

    During startup, as you correctly deduced, the Udev error can be safely ignored, despite the error, Udev works fine. However the rest of the errors shouldn't be occurring.
  • Trixar_zaTrixar_za February 2011
    I'm inclined to agree with ms3811. It looks like a corrupt or bad install. The file system is also very important because SliTaz works with ext3 and tends to break on any other file system. Also make sure you use the SliTaz Installer to install it.

    You also don't need that much swap space. Linux uses very little Swap, so using double the size of your RAM tends to work well. The most it ever used was like 60MB back on Ubuntu and I have like 400MB of swap.
  • wagoneer89wagoneer89 February 2011
    Thanks ms3811 and Trixar, bad install, kinda what I was thinking.

    I have repartitioned and reinstalled a few times now so I'm not inclined to try it again. I did use the Installer just as you suggest. The install died the same way each time. Perhaps I need to recheck the ISO burn... I'll check into that before I reinstall. I know I'm missing directories and I assume there was supposed to be data in those directories that didn't get installed. I'm sure checking the directories on the CD and replicating them on the HD would fix the problem (with some tinkering) but I can't seem to see the CD from the operating system yet. Since I did get the install to continue a little further last night I may be able to see the CD now, I'll check that too.

    I have about 100Mg of memory and I set the swap partition at 1.25Gig... Oooops! I see I missed the decimal calculation there! OK... you win! Time to reinstall.

    Anyone who reads this thread this morning... I'm trying the lomem install because I've had SOOO much trouble with this limited machine. I'm thinking that more people have undoubtedly downloaded the regular variety and it might be easier to load IF my machine will run it. Can the regular SliTaz run in just under 100Mb of RAM on a 4 Gig disc?

    Thanks for the ideas guys... really appreciated.

  • wagoneer89wagoneer89 February 2011
    Small question: What should "dmesg" show me if I have a CD to communicate with?

  • wagoneer89wagoneer89 February 2011
    Found the CD operative in the LiveCD desktop GUI, I am also able to see the HD. Not sure yet whether I will be able to transfer the appropriate folders and files.
  • wagoneer89wagoneer89 February 2011
    Running "dmesg" on the Live CD returns many iteration of this text:
    ATAPI device hdc:
       Error: Illegal request -- (Sense key=0x05)
       Illegal mode for this track or incompatible medium -- (asc=0x64, ascq=0x00)
       The failed "Read 10" packet command was:
       "28 00 00 00 4a 00 00 00 02 00 00 00 00 00 00 00 "
    end_request: I/O error , dev hdc, sector 75776
    hdc: command error: status=0x51 { DriveReady SeekComplete Error }
    hdc: command error: error=0x51 {Illegal LengthIndication LastFailedSense=0x05 }
    hdc: possibly failed opcode: 0xa0
    ATAPI device hdc:
       Error: Illegal request -- (Sense key=0x05)
       Illegal mode for this track or incompatible medium -- (asc-0x64, ascq=0x00)
       The failed "Read 10: packet command was:
       "28 00 00 00 4a 00 00 00 02 00 00 00 00 00 00 00 "
    end_request: I/O error, dev hdc, sector 75776
    mtrr: base(0xe0000000) is not aligned on a size(0x1f0000) boundary
    ISO 9660 Extensions: RRIP_1991A
    kjournald starting. Commit interval 5 seconds
    EXT3 FS on hda2, internal journal
    EXT3-fs: mounted filesystem with writback data mode.

    I'm going to burn this ISO to another brand of disc and see if that helps the situation. The discs I am using are Memorex and they are black... perhaps this machine can't handle this odd disc type.

  • wagoneer89wagoneer89 February 2011


    Repartitioned, reformatted, burned a new ISO on a clean SILVER CD, installation finished in a half hour with NO errors.  OUTSTANDING!!!

    THANK YOU!!!!
  • Trixar_zaTrixar_za February 2011
    Yeah, I would have said that dmesg was showing a issue reading from the CD.

    I also guess you could install the base SliTaz copy, if you booted it with the the screen=text parameter at the Boot Baby, Boot screen on the LiveCD. Then you could just login as root and the installer from terminal with slitaz-installer. I've done it this way once on as system with 96MB of RAM :P

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social