This is the old SliTaz forum - Please use the main

Printer setup problems
  • johnrockingjohnrocking January 2011

    I am trying to setup my Epson C44ux printer via usb lead on Slitaz 3.0 stable but just can't do it. I am very new to Linux but have previously used cups on the same laptop using Puppy linux and it was no problem at all and set up easily. However I just cant set it up in Slitaz, even having a job to get into the setup window as my root password seems hit and miss. I have looked at the guide in the Slitaz documentation but get lost. Can anyone point me to an 'idiots guide' to Slitaz printer setup or spell it out for me please.

    Many thanks in anticipation

  • erniaernia January 2011
  • johnrockingjohnrocking January 2011
    Thanks Ernia. This may well be my problem and I will try to work through it but as a complete newcomer to Linux,  I don't understand all of it. Does it have to be so difficult. I appreciate the comments and help but please keep it simple
  • kultexkultex January 2011
    no - it does not be that complicated, if you take another distribution like Ubuntu Pclinuos, Mint and so on - these distributions have 500 - 700 MBs and are very "userfriendly".
    Slitaz just has 35 MBs and I would say is the most userfriendly tiny OS - but still there are parts, which are not only one click and where you have to deal with the basics of linux. Thats the price for getting a very stable, ultrafast OS and if you complain - yes there are other distros, where it is just one click
  • erniaernia January 2011
    if this is your problem you just need to reboot and you can login in cups as root, is it simple enough? ;-)
  • johnrockingjohnrocking January 2011

    I can see I have touched a nerve here.
    I am not criticizing Slitaz. On the contrary it is excellent in most
    respects. I was drawn to lightweight distros as I have an old
    Panasonic CF-27 laptop with a 300Mhz cpu and 197mb of RAM. I have
    tried them all including the 'larger' lightweights (Puppy, Xubuntu
    etc) and the two best for me were Antix and Slitaz out of which I
    prefer Slitaz by far. Considering its tiny size it is remarkable and
    supports all my hardware out the box. However I need to print.
    Getting past the CUPS log in I can now do and when I go to add
    printer it searches for but finds nothing. What do I need to do now please.

  • johnrockingjohnrocking January 2011
    My printer is via a usb connection. I tried to add it as LPD/LPR using socket but this after adding the details of the printer returns a
    Bad device-uri "socket//

  • kultexkultex January 2011
    I just copy from here:

    Install the printer drivers with the following packages:

    1. hplip : for HP printers

    2. gutenprint : for Canon, Epson,
      Lexmark, Sony, Olympus

    3. foomatic-db, foomatic-db-engine,
      foomatic-db-nonfree and foomatic-filters : several free software printer

    4. ufr2: for Canon printers (extra

    5. splix: for Samsung

    6. cups-pdf: for “printing” to PDF files
    if you have a USB Printer - follow the Usb Part of the howto

  • johnrockingjohnrocking January 2011
    I have followed the instructions and made changes as per the documentation to the cupsd.conf file, installed the usb support. Now when I go to hardware detection and drivers add printer I get this.
     1 Vendor 04b8 seiko Epson Corp
    Product 0005 LUA-TX Ethernet ; 0005 Type 6 keyboard
    Is your printer shown (Y) start cups (Y) add printer but in the browser interface my printer is not shown and I am completely stuck. Where do I go from here. Can someone please help
  • kultexkultex January 2011
    did you install gutenprint?
  • johnrockingjohnrocking January 2011
    Yes Gutenprint installed
  • kultexkultex January 2011
    I have no idea, what you are doing, but to add a new printer in cups you go in the interface to administration, then choose add a new printer, then choose the URI - which should be "usb:/dev/usb/lp1" for the usb printer and then you can select the driver
  • kultexkultex January 2011
    Perhaps an idea - try to setup the printer in Anitx and see if it works and how it works and then return tu slitaz
  • johnrockingjohnrocking January 2011
    Antix is the same as Slitaz. I cant set the printer up. Puppy 5.1.1. is a breeze and the printer is easy to setup. Puppy uses cups 1.4.3.  Could I use the later cups in Slitaz.
  • kultexkultex January 2011
    the difference between puppy and the other distros is, that puppy is a rootdistro - you are always root, which is a security problem in my opinion but you have no permission problems - did you do all the permission stuff?
    And where are you hanging - is it not printing? can you install the printer?
  • johnrockingjohnrocking January 2011

    I cannot install the printer. I get as
    far as the localhost:631 screen. There is a 'looking for printers
    logo revolving searching but it finds nothing. My printer is not shown (it is
    shown in Puppy at this point) The options I have are

    Local printers
    SCSI or HAL.

    Discovered network printers (Nothing shown)

    or Other
    network printers

    LPD/LPR or host priner

    Internet Printing http

    Internet Printing ipp

    AppSocket HP jet direct

    Backend error handler.

    If I choose LPD/LPR put the address as
    /dev/bus/usb/001/002 I can continue and setect the Epson C44UX from
    the subsequent pages but I then get the error File device URI's have
    been disabled ! To enable see the file directive in

  • kultexkultex January 2011
    give me the output of "lsusb"

  • johnrockingjohnrocking January 2011
    Hello Kultex
    The lsusb output
    Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 002: ID 04b8:0005 Seiko Epson Corp. Stylus D88+
  • kultexkultex January 2011
    The problem is, that I use a network printer and I just tested today my new canon IP2700, which works as networkprinter and I could not get it working as usb printer.

    I have tested USB once with a HP Printer this worked, but I think, that this worked, because hplip installs udev rules. Only changing the permisson of /dev/bus/usb/001/002 to 666 does not get the printer to be recogniced by cups. I think the howto does not solve the problem for all printers.

    Is somebody out there, who has mor experience with a usb printer
  • johnrockingjohnrocking January 2011

    Can anyone help with this issue please. Kultex (Many thanks) has tried but I am really stuck now. I am trying to set up my printer with a usb connection. I desparately need  it for some work I have to do. HELP!

  • kultexkultex January 2011
    there is some advantage -

    you have to load the module usblp as root in the terminal

    modprobe usblp

    now cups recognices the printer and you can setup the printer - but still I cannot print - still getting the error

    E [12/Jan/2011:10:40:19 +0000] [Job 1] Unable to open USB port device file: Permission denied

    even if the permissions are correct

    root@slitaz:/home/tux# ls -l /dev/bus/usb/001/004
    crw-rw-rw-    1 root     lp        189,   3 Jan 12 10:55 /dev/bus/usb/001/004

    but this is in cooking and perhaps it just works in stable, because cups just behaves strange in cooking - I will try it later on in stable

  • mojomojo January 2011
    Computer connected to internet and printer.
    Printer powered on.
    menu/System Tools/Hardware detection and drivers
    Check Auto-install all optional packages
    Hardware Setup/click Printer
    Confirm installation of ALL Depends and Suggested Packages !
  • kultexkultex January 2011
    @mojo - that does not help - I have done that all the Printer works fine as networkprinter with openwrt

    if not loading the module usblp

    root@slitaz:/home/tux/Images# /usr/lib/cups/backend/usb
    root@slitaz:/home/tux/Images# lpinfo -v
    network socket
    direct hp
    network http
    network ipp
    network lpd
    direct scsi

    the printer is not recogniced by cups - it does not help if I create udev rouls or not

    loading usblp - which is the old way and some distris tell, it must be backlisted to get a usb printer to work gives

    root@slitaz:/home/tux/Images# modprobe usblp
    root@slitaz:/home/tux/Images# /usr/lib/cups/backend/usb
    direct usb://Canon/iP2700%20series "Canon iP2700 series" "Canon iP2700 series USB #1" "MFG:Canon;CMD:BJL,BJRaster3,BSCCe,IVEC,IVECPLI;SOJ:TXT01;MDL:iP2700 series;CLS:PRINTER;DES:Canon iP2700 series;VER:1.030;STA:10;FSI:00;HRI:EU;MSI:AOFF,BOFF,DAT,E3;PDR:4;"
    root@slitaz:/home/tux/Images# lpinfo -v
    network socket
    direct hp
    network http
    network ipp
    network lpd
    direct scsi
    direct cnijusb:/dev/usblp0

    here I can install the printer - evrything is fine - no errors until I print the testpage - here comes, no permission just this, no more errors even in debug mode

  • kultexkultex January 2011
    I just see something now - perhaps thats the error - the uri of the device is cnijusb:/dev/usblp0 (autodetect), but perhaps I can cange that to usb://Canon/iP2700%20series "Canon iP2700to get it working

    but no time now
  • kultexkultex January 2011
    I can change, but it does not print

    just the difference to slackware, where it prints without problems

    root@fluxflux: /home/gast # /usr/lib/cups/backend/usb
    DEBUG: list_devices_libusb
    DEBUG: usb_find_busses=4
    DEBUG: usb_find_devices=6
    direct usb://Canon/iP2700%20series "Canon iP2700 series" "Canon iP2700 series" "MFG:Canon;CMD:BJL,BJRaster3,BSCCe,IVEC,IVECPLI;SOJ:TXT01;MDL:iP2700 series;CLS:PRINTER;DES:Canon iP2700 series;VER:1.030;STA:10;FSI:00;HRI:EU;MSI:AOFF,BOFF,DAT,E3;PDR:4;" ""
    <code>root@fluxflux: /home/gast # lpinfo -v
    direct cnijusb:/dev/usb/lp0
    network http
    network ipp
    network lpd
    direct parallel:/dev/lp0
    direct scsi
    network socket
    direct hp
    direct usb://Canon/iP2700%20series
    network beh
    network smb
    direct hpfax</code>

    so the difference is, that lpinfo detects also

    direct usb://Canon/iP2700%20series   this is also used as URI for setting up the printer

    I cannot find any differences in  permission in any files

    the only thing are some different udev rules - and the udev roules in slackware 13.0 are now no longer in /etc/udev  they are in /lib/udev

    the printer part in 50-udev-default roules

    # printer
    KERNEL=="parport[0-9]*",    GROUP="lp"
    SUBSYSTEM=="printer",        KERNEL=="lp*", GROUP="lp"
    SUBSYSTEM=="ppdev",        GROUP="lp"
    SUBSYSTEM=="usb",        KERNEL=="lp*", SYMLINK+="usb%k", GROUP="lp"
    KERNEL=="lp[0-9]*",        GROUP="lp"
    KERNEL=="irlpt[0-9]*",        GROUP="lp"
    # hplip and cups 1.4+ use raw USB devices, so permissions should be similar to
    # the ones from the old usblp kernel module
    SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ENV{ID_USB_INTERFACES}=="", IMPORT{program}="usb_id --export %p"
    SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ENV{ID_USB_INTERFACES}==":0701*:", GROUP="lp", MODE="0664"

    and 70-printer.rules

    <pre># Low-level USB device add trigger
    ACTION=="add", SUBSYSTEM=="usb", ATTR{bInterfaceClass}=="07", ATTR{bInterfaceSubClass}=="01", RUN+="udev-configure-printer add %p"
    # usblp device add trigger (needed when usblp is already loaded)
    ACTION=="add", KERNEL=="lp*", RUN+="udev-configure-printer add %p"

    # Low-level USB device remove trigger
    ACTION=="remove", SUBSYSTEM=="usb", ENV{ID_USB_INTERFACES}=="*:0701*:*", RUN+="udev-configure-printer remove %p"

    PS not even
    is working any more
  • johnrockingjohnrocking January 2011
    Despite the best efforts of a few more experienced members than me I am still unable to set my epson printer up. It is attached via usb. Can anyone help please.  I really need to get this working as the need to print is now urgent.   H E L P PLEASE
    Many thanks
  • TotoetsasoeurTotoetsasoeur January 2011
    I must say that trying to understand what you did, in what order, what does work, what doesn't, ... is a real pain.

    I think you should start over again and follow, step by step, this guide (especially  chapter: Installing an USB Brother HL 2030 Printer):

    If you encounter a problem, report it and lets solve it. It does not make any sense going further if a specific issue is not solved.

    Maybe I am wrong, but I do not see any reason why you could not use this printer under Slitaz.

    Slitaz community is really cool. To get precise and useful help:
    - try to explain what you did,
    - report used command,
    - and report the message returned by the system as well.

    I am sure you'll do it.


  • johnrockingjohnrocking January 2011
    I agree that this is just going on and on and is becoming a pain to read it all but initially I think I just posted the correct information. I have an Epson printer connected by a usb cable to my laptop. I have carefully followed the guide you refer to but my printer is not recognised in cups so it is not there to select. I have previously set the printer up on this laptop in puppy linux so it 'can' be done but I have wireless problems with puppy so Slitaz is preferable for me. I am at a loss as to what to do next.
  • TotoetsasoeurTotoetsasoeur January 2011
    When you're saying: "my printer is not recognised in cups", are you able to select the previously .ppd downloaded file through cups web interface?
  • kultexkultex January 2011
    @totoetsasoer perhaps you mean my posts, that are a pain -

    the USB part of the printer howto is not working !!! - mybe there is just something missing - but I tryed it in stable and cooking - no chance to get my Canon IP2700 - which works without a problem as network printer - to work on USB

    so I added the output of /usr/lib/cups/backend/usb and lpinfo -v, which shows whats going on in cups
  • TotoetsasoeurTotoetsasoeur January 2011
    You may be right. Unfortunately, I use a printer connected to parallel port. But I remember helping nounours with his usb printer (
    Then nounours was the guy who wrote this part of howto, but I could not check it obviously.

    Maybe should I get an usb printer to figure out what is going wrong...
  • kultexkultex January 2011
    that would be great - because I really gave up - I had no more ideas

    the best would be a canon printer - canon provides propriate drivers, that do not install any udev rules...
  • kultexkultex January 2011
    and it would be cool, to test with a mulitfunctional Canon Printer - like MP280

    they are cheap, quite good printing results, very good in standby power consumption, can be refilled (nochips in it) and canon provides working linux drivers for scanner and printer (they have to be tweaked)
  • slicelslicel February 2011
    First post's first sentence-

    "I am trying to setup my Epson C44ux printer via usb lead on Slitaz 3.0 stable but just can't do it. "

    Closest match I know-

    These packages plus their depends worked for an epson c40ux local usb printer on slitaz 3 stable xvesa as explained a year ago.

    aspell-en (or your language if not english)

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social