This is the old SliTaz forum - Please use the main

Compiling TrueCrypt 7
  • ms3811ms3811 September 2010
    Truecrypt 6.3 sourcecode is no longer available for download at I tried compiling 7 using the instructions posted by @Payoon at:


    Bunch of issues. 7 seems to have more dependencies, it requires xorg-libSM-dev and xorg-libICE-dev to be installed (which in turn required to be installed using the --forced option, not sure why kept throwing some errors). Now "make WXSTATIC=1" throws errors with Assembling Aes_hw_cpu.asm and fails with an "expression syntax error".

    At this point, can't seem to go any further (I'm not really an expert in compiling stuff). Giving up, unless anyone is interested in walking me through this (hint, hint).
  • Trixar_zaTrixar_za September 2010
    First off, you can get the 6.3 version here:

    The tutorial you followed was for SliTaz 2.0 based on the date. This probably won't work exactly the same for SliTaz 3. For example, wxWidgets and wxWidgets-dev are both in the repository, so you don't have to compile them. So I guess you can skip the whole section on compiling wxWidgets then. Going on that tutorial, you need to install the following packages: slitaz-toolchain, fuse-dev, gtk+-dev, pkg-config, dmsetup, wxWidgets-dev and xorg-libXxf86vm-dev

    Then download, tar zxf it, ./configure --prefix=/usr and then try compiling the bugger again (make then make install).
  • ms3811ms3811 September 2010
    @Trixar_za, thanks for looking into this.

    /pastversions at only seems to have the binaries -- don't I need the source code? I couldn't find a link to download the source (or am I seriously retarded?).

    I will download and install wxWidgets-dev and xorg-libXxf86vm-dev (I have the rest installed already) and try compiling again. I am assuming this will work with 7?
  • ms3811ms3811 September 2010
    I downloaded the two packages and installed them. But I can't find configure. Using the source code of truecrypt 7, but there is no configure in it.

    Sorry, I really don't know much about compiling.
  • JackNapierJackNapier September 2010
    When you download the -dev version of something, can you uninstall the non-dev version?

    Do you need the dev packages just for installation or do they need to be kept?
  • ms3811ms3811 September 2010
    @JackNapier, the dev packages are only for compiling. They can be removed once the binary is created. If I can ever create them that is ;).
  • JackNapierJackNapier September 2010
    So, "slitaz-toolchain, fuse-dev, gtk+-dev, pkg-config, dmsetup, wxWidgets-dev and xorg-libXxf86vm-dev" can all be removed after TrueCrypt is installed?
  • Trixar_zaTrixar_za September 2010
    There is actually another package required for the asm files called nasm which you have to install. I downloaded the source code and tried to compile it. Here are the steps I took:
    1. Downloaded the linux source code from and downloaded the file to my Downloads folder.
    2. I go to terminal, type cd Downloads and untar the file with tar zxf TrueCrypt\ 7.0a\ Source.tar.gz
    3. I made sure I installed all the dependacies - including nasm
    4. I typed mkdir temp and cd temp into it
    5. I downloaded the files I needed from :
    6. su to root and cp *.h /usr/include
    7. cd .. to get out of the temp folder and then cd truecrypt-7.0a-source to get into the truecrypt source code folder and then type make PREFIX=/usr (still as root)
    8. Got the same error you did... so I checked nasm's version - it was the older one. Grudgingly downloaded and installed it with tazpkg install nasm-2.08.01.tazpkg
    9. I went back to the truecrypt-7.0a-source folder and tried make PREFIX=/usr again and compiling worked this time - well past the one part...
    10. Getting compile errors about wxWidgets... checked cooking packages and stable packages. It's both 2.8.10 - so I gave up after this step.

    Anyway, as you can see, your issue was being caused by an older nasm copy - installing the cooking version fixed that, but now it's throwing wxWidgets errors I'm unsure about. Maybe somebody else has some clues on how to solve this one.
  • Trixar_zaTrixar_za September 2010
    You can remove slitaz-toolchain, fuse-dev, gtk+-dev, wxWidgets-dev, nasm and xorg-libXxf86vm-dev after compiling yes. The rest will be needed again by TrueCrypt. I haven't figured out how compile it though. I'm getting wxWidgets errors now.
  • ms3811ms3811 September 2010
    @Trixar_za, thanks for trying.
  • avamkavamk October 2010
    Anyone got it to work??
  • avamkavamk October 2010
    Anyone got it to work??
  • ms3811ms3811 October 2010
    not that I know of. if someone did, please let us know how you got past the wxWidgets errors.
  • sebastian2011sebastian2011 December 2010
    Hello people.  I've been working this for the past several hours.  I'm building a Linux from scratch system and so I'm being a stickler to building everything from source.

    The answer is actually very simple.  You have to use the wxWidgets GTK package found here:

    I just compiled Truecrypt7.0a with the wxGTK-2.8.10.tar.bz2 found at the link provided, and it was a breeze.  Good luck, and I hope some of you who were trying to do this some months ago  see this post.

  • ChristopheChristophe December 2010
    Can you provide a tazpkg package ?
    I am interested n getting that, though i do not know how to do the compile myself....


  • sebastian2011sebastian2011 December 2010
    Hello Christophe,

    To be honest, I know absolutely nothing about Slitaz.  I only found this forum, and particularly this thread when I was searching the web for a solution to getting Truecrypt7 to compile.

    Perhaps one of he other members here can help you.  If not, you could learn how to compile programs in GNU/Linux.  Also, if you are not hell-bent on installing everything from source, Truecrypt provides an executable binary at their site which should work on just about any distro, so long as you have the dependencies installed and the correct kernel modules enabled.  Again, perhaps others who know more about your distribution can help you get that squared away.

    Good luck!
  • ChristopheChristophe January 2011
    ok thanks.
    there had been a lot of discuttion arout this
    so hopefully someone will pick it up
  • avamkavamk January 2011
    Will TrueCrypt ever become an included package with SliTaz? Hopefully in 4.0?

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social