This is the old SliTaz forum - Please use the main

some questions about WICD
  • kultexkultex August 2010
    I tried to install wicd, but opening from the menu nothing happens and from the shell I get the following errors

    tux@slitaz:~$ wicd-client -n
    Traceback (most recent call last):
    File "/usr/lib/wicd/", line 50, in
    import wicd.gui as gui
    File "/usr/lib/python2.5/site-packages/wicd/", line 2005, in
    File "/usr/lib/python2.5/site-packages/wicd/", line 177, in setup_dbus
    proxy_obj = bus.get_object("org.wicd.daemon", '/org/wicd/daemon')
    File "/usr/lib/python2.5/site-packages/dbus/", line 244, in get_object
    File "/usr/lib/python2.5/site-packages/dbus/", line 241, in __init__
    self._named_service = conn.activate_name_owner(bus_name)
    File "/usr/lib/python2.5/site-packages/dbus/", line 183, in activate_name_owner
    File "/usr/lib/python2.5/site-packages/dbus/", line 281, in start_service_by_name
    'su', (bus_name, flags)))
    File "/usr/lib/python2.5/site-packages/dbus/", line 622, in call_blocking
    message, timeout)
    dbus.exceptions.DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name org.wicd.daemon was not provided by any .service files

    the changes form jozee are here ( - so perhaps somebody has any ideas, what could be the problem?
  • mojomojo August 2010
    Client/daemon program-> has the wicd daemon started ?
    ps -A | grep wicd
    Comments from:
    /etc/init.d/wicd: Start, stop and restart deamon on SliTaz, at boot
    time or with the command line.
    To start daemon at boot time, just put the right name in the $RUN_DAEMONS variable of /etc/rcS.conf and configure options with /etc/daemons.conf.
  • kultexkultex August 2010
    thank you mojo - I did not start the daemon
  • kultexkultex August 2010
    I reopend it and changed the title, because I just installed SliTaz for a not linux-expierienced friend and I can not give her the laptop without proper wicd integration. The wiki of wicd is still empty and I have not much time in the moment, so some questions - perhaps somebody did this already:

    1) wicd is interfering with the network config of SliTaz - is it enough to just remove the
    3) to start the demon is clear, but where to start the client? in openbox autostart?
    2) what has to be done to integrate it into the lxpanel?
  • seawolfseawolf August 2010
    1) Could you just set the "DHCP" "STATIC" and "WIFI" variables to "no" in /etc/network.conf so it ignores them and lets Wicd take care of it? (I actually have the wifi on in there to connect at start-up before log-in, and Wicd just reports it connected as usual.)

    2) You can put the following in "AutoStarted Applications" (~/.config/openbox/
    # wicd Network Configuration
    wicd-client &

    3) It's own tray icon will sit in the panel; clicking it brings up wireless connetions, config etc.

    I'm using Wicd in SliTaz with no problems. HIH.
  • kultexkultex August 2010
    thx seawolf,

    your wifi configuration is interesting - and it does not interfere, when I want to connect to some other wpa wifi node (the home wifi connection of my friend is also wpa)?
  • kultexkultex August 2010
    just if somebody is interrested:

    I removed in /etc/rcS.conf in the section RUN_SCRIPTS
    and added in the section RUN_DAEMONS wicd

    then the change of as seawolf suggested

    and last removed the network-plugin in .config/lxpanel/default/panels/panel

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social