This is the old SliTaz forum - Please use the main

dpkg -i *.deb error
  • justineurojustineuro April 2010
    tried using:
    dpkg -i *.deb
    got the error:
    dpkg: can't open '/var/lib/dpkg/status': No such file or directory
    i'd appreciate any help in this regard.
  • seawolfseawolf April 2010
    I'm unfamiliar with dpkg but you could try to create a blank file with :
    mkdir /var/lib/dpkg -p && touch /var/lib/dpkg/status

    It depend on the file contents, though; in which case you will need to copy it from another machine that has a working dpkg installation, or find example on the internet.

    Have you tried converting the DEB packages to TazPkg format?
    tazpkg convert *.deb

  • justineurojustineuro April 2010
    hi seawolf,
    thanks. 'tazpkg convert *.deb' worked but the consequent installation of the corresponding .tazpkg failed (the ones that i've tried) because of missing required files. thanks for looking into this.
  • blcondeblconde April 2010

    I have the same issue here, "dpkg: can't open '/var/lib/dpkg/status': No such file or directory". I've tried several workarounds and none worked. Is the Slitaz dpkg support working correctly? Have someone had success installing a .deb package?

  • blcondeblconde April 2010
    Sorry about the duplicate post. By the way, how do I delete a post?

  • would someone know if tazpkg in slitaz 2.0 can be updated to include the "convert" option? i see this as an option in slitaz 3.0 but it doesn't appear in 2.0.
  • mojomojo May 2010
    Download tazpkg-3.4.tazpkg from slitaz-3.0 repository.
    Extract the contents
    tazpkg extract tazpkg-3.4.tazpkg

    Go into the extracted folder tazpkg-3.4/fs/usr/bin to find tazpkg
    Give tazpkg a new name like tazpkg.convert
    Move it into /usr/bin or another location in
    echo $PATH

    Call it up with it's new name from terminal when you want to convert.
    root@slitaz: tazpkg.convert convert package name
  • hi mojo,
    i tried this but 'tazpkg.convert' was looking for the file /etc/slitaz/tazpkg.conf. apparently, 'tazpkg extract tazpkg-3.4.tazpkg' doesn't create this file in /etc/slitaz.
    i then tried directly installing tazpkg-3.4.tazpkg in slitaz 2.0 and it installed this time (if my memory serves me right, this didn't use to install as it is a slitaz 3.0 package; maybe this is an updated version---i didn't take careful note of the version that i previously tried to install). also, tazpkg.conf was also created in /etc/slitaz/tazpkg.conf after installing tazpkg-3.4.tazpkg. i eventually had two ways of calling 'tazpkg convert', either as itself or as 'tazpkg.convert'.
    it's probably better to install tazpkg-3.4.tazpkg as it is now installable in slitaz 2.0 (i'm not sure if this became installable after i extracted tazpkg-3.4.tazpkg and followed the steps you indicated).
    much thanks for your expertise!
  • slicelslicel May 2010
    I rescued some user contributions from the old forum that included a deb convert script to make a *.sh shell file with permissions set to execute.
  • mojomojo May 2010
    Somewhere during the process my directions failed you.
    I'm glad you straightened yourself out ;)
  • hi mojo and slicel,
    it was a blessing in disguise as i unintentionally discovered that that tazpkg-3.4 is installable in slitaz 2.0. thanks for the additional info.
This discussion has been closed.
← All Discussions

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social