This is the old SliTaz forum - Please use the main

Can't set system's time
  • mek8630mek8630 September 2010
    Well for some reason when I try to sync the system's time online it won't. I think it's because it's set to the wrong time-zone. Well when I try to change the time-zone it won't do that either. I am not sure how to do it or what I am doing wrong IF I am doing anything wrong. I know that I get error codes when trying to launch certain programs saying that something is wrong with my locales, I can't remember if it says they aren't configured correctly or what, but I don't know how to configure my locales.
  • marquiticomarquitico September 2010
    Actually, the computer should sync no matter which timezone it's set to, right or not. Do you do it from the SliTaz Control Box? I believe the Control Box issues this command:

    rdate -s

    I have noticed that the rdate timeserver has been out of service a lot since the end of August, so it may not be your fault. You can try to do it by opening a terminal as root, and then doing:

    rdate -s

    It should sync with no confirmation, at first. Wait a few seconds, and try again. Continue synching until you receive this message at least twice in a row:

    rdate: current time matches remote time

    Then do:

    hwclock --systohc

    As an alternative, you can download the ntp package and use that instead. Search for ntpd and ntpdate instructions online; there are many. There are also many more ntp servers than rdate servers (so I believe), so the ntp protocol is easier to use.

    Your other applications complaining about your locales is a different conversation, however...
  • Trixar_zaTrixar_za September 2010
    If you're using SliTaz 3, first install glibc-locale then look in the /usr/share/zoneinfo folder - you see those files and the files in the folders? You add them to Menu--->System Tools--->Control Box--->Time--->Timezone. If it's in the main /usr/share/zoneinfo/ folder, then just add it as CET or UTC, but if it's in one of the other folders like Africa, then you add it like Africa/Windhoek.

    It's a pain I know, but this is the easiest way to solve this problem.
  • mek8630mek8630 September 2010
    marquitico, I tried your way and I received the "rdate: current time matches remote time" message twice in a row and then tried the next part and nothing happened. When I type in hwclock --systohc it just keeps giving me the command line back again.

    Trixar_za, I see everything you are talking about the files and the files that are in the folders, but I don't know where you are saying to put them. If I bring up the control box and click on the "time" tab, and then what? Or am I not in the right place? I installed that glibc-locale, now I am just not clear on what you are saying to do with them files?
  • mojomojo September 2010
    marquitico's first command sets system time to UTC from timeserver.
    The second command sets hardware clock from system time.
    Now your hardware clock is set to UTC.
    Determine the hour difference between UTC which is what you see in the clock in the lower right hand corner of lxpanel and the local time where you live.
    The /etc/TZ file controls the hour offset difference between local time which you want displayed on system and hardware clock which is set to UTC.
    root@slitaz: nano /etc/TZ

    Add the following and save.
    If your local time is behind UTC:
    UTC + number of hours behind
    If your local time is ahead of UTC:
    UTC - number of hours ahead
    Logout and in,the system clock should display your local time.
    Example: I live in New York, when it is 12:00 PM local time it is 4:00 PM UTC
    My /etc/TZ:
    From now on when you sync hardware clock from system clock designate UTC or time will be set wrong.
    root@slitaz: hwclock -w -u

    This is the command given when you click the Hardware time: Set from system button in controlbox
  • mek8630mek8630 September 2010
    Thank you for the replies, Marquitico and mojo with your combined replies I was able to get it to work. I actually have done what you said mojo but without doing what Marquitico said first it didn't work. But thank you all for your help.
This discussion has been closed.
← All Discussions

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social