This is the old SliTaz forum - Please use the main

[SOLVED] A difficult case for xorg
  • jpegjpeg April 2010
    I have tried the live CD on an oldish computer and I just get vertical colored lines. Pretty.
    The xvesa flavor works fine. at 800x600. I haven't tried to get a better resolution than that.

    If I install and try xrandr it says:
    > Screen 0: minimum 640 x 480, current 640 x 480, maximum 640 x 480
    > default connected 640x480+0+0 0mm x 0mm
    > 640x480 0.0*

    Nevertheless a look inside the Xorg log file shows
    > (II) VESA(0): Supported VESA Video Modes:
    > (II) VESA(0): 720x400@70Hz
    > (II) VESA(0): 640x480@60Hz
    > (II) VESA(0): 640x480@75Hz
    > (II) VESA(0): 800x600@60Hz
    > (II) VESA(0): 800x600@75Hz
    > (II) VESA(0): 1024x768@60Hz
    > (II) VESA(0): 1024x768@75Hz
    I suppose those are the modes the driver can do, not necessarily ones that the monitor can do as well, because right after that comes the EDID info and a pile of Modelines, one of which is
    > (II) VESA(0): Modeline "1024x768"x85.0 94.39 1024 1088 1200 1376 768 769 772 807 -hsync +vsync (68.6 kHz)
    After that it says
    > (II) VESA(0): Searching for matching VESA mode(s):
    the best of which is
    > Mode: 105 (1024x768)
    but that seems to be only 8 bit color depth
    Then it says
    > (II) VESA(0): Monitor0: Using hsync range of 30.00-69.00 kHz
    > (II) VESA(0): Monitor0: Using vrefresh range of 48.00-120.00 Hz
    > (II) VESA(0): Not using mode "1024 768" (no mode of this name)
    > (II) VESA(0): Not using built-in mode "640x400" (no mode of this name)
    > (--) VESA(0): Virtual size is 640x480 (pitch 640)
    > (**) VESA(0): Built-in mode "640x480"

    and some colored vertical lines appear.
    Strangely enough the /etc/X11/xorg.conf file has *no* Modes lines and adding them doesn't help.

    I then tried tazx and installed the intel drivers since lspci says:
    > 00:02.0 VGA compatible controller: Intel Corporation 82815 Chipset Graphics Controller (CGC) (rev 02)
    The following packages got installed:
    > linux-agp, linux-drm, mesa-dri, mesa-dri, xorg-libXv, xorg-libXvMC, xorg-xf86-video-intel

    The result: X won't even start!
    > (EE) GARTInit: Unable to open /dev/agpgart (No such device)
    > (EE) intel(0): AGP GART support is not available. Make sure your kernel has
    > agpgart support or that the agpgart kernel module is loaded.
    > UnloadModule: a pile of modules
    > (EE) Screen(s) found, but none have a usable configuration.

    A few checks:
    cat /proc/modules
    > agpgart 25980 0 - Live 0xe073b000
    ls -l /dev/agpgart
    > crw-r--r-- 1 root root 10, 175 Mar 28 17:49 /dev/agpgart
    The logfile has the same EDID info in it and the same Modelines
    The xorg.conf file uses the intel driver, and it still doesn't have and Modes specified in it, and adding them still doesn't help.
    Adding write permissions for everyone on /dev/agpgart doesn't help.
  • marquiticomarquitico April 2010
    I had the same trouble as you, after installing pretty much the same packages. The clue was:

    (EE) intel(0): AGP GART support is not available.
    The solution that works for me is: after all the packages are installed, I must activate AGP GART support as a kernel module at the command line by hand as root, issuing this command:

    modprobe intel_agp
    This loads not only the intel_agp module, but all the modules that it depends upon as well. I verify this by issuing the command:

    and looking for "intel_agp" and any other "agp"-related entries in the resulting output. Then I can start X. I believe this is supplied by the linux-agp package that comes as one of the Intel driver's dependencies.

    I also find that my setup doesn't use ModeLines properly no matter what they are, so I just leave them out of xorg.conf. Be certain that the HorizSync and VertRefresh values are correct for your hardware, and then you can add two things.

    First, I add to the Monitor section a DisplaySize line, right after HorizSync and VertRefresh. For a 1024x768 display at 96x96 dpi, you may use:

    DisplaySize 270 203
    This option can be tweaked to your preference. I actually use:

    DisplaySize 260 195
    This gives me 1024x768 at 100x100 dpi, because my eyes are poor and I enjoy slightly larger text. (While browsing the Internet, however, some webpages don't display exactly right at this resolution, but I can live with it.)

    Second, to be certain that X doesn't override this, I add to the Device section (where the Intel driver is specified) this line:

    Option "DDC" "false"
    You may need to experiment a little to find what suits your setup best. One last note: on my system, if I put the DisplaySize in Monitor but forget the Option line in Device, the worst that happens is X takes its best guess, and I get something ugly but usable until I fix it and restart X. But the reverse is not true. If I put in the Option without a DisplaySize, X breaks. X also breaks if I carelessly put these lines in the wrong sections, so check carefully.

    HTH! Regards.
  • jpegjpeg April 2010
    Solved! (at least partially)

    modprobe intel_agp

    was exactly what was needed. Thankyou marquitico for your quick reply, and thankyou Rupp for the /etc/rcS.conf hint. to make things permanent.

    However the problem with Xorg vesa driver is still unsolved. A pity for all those who just try the liveCD.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social