This is the old SliTaz forum - Please use the main

problems with tazusb on slitaz3
  • moralesramonmoralesramon April 2010
    first; sorry by my english
    i installed slitaz 3 on a flash usb and it booted nice the first time
    then i installed some packages with tazpkg (text mode) and created a new rootfs with tazusb writefs lzma
    but i can't boot with the new rootfs , the screen shows me
    [(c016080c)] ? alloc_vmap_area+0x168/0x197
    [(c0114df4)] bad_area_nosemaphore+0xd/0x10
    [(c011500a)] do_page_fault+0xe1/0x1de
    [(c0114f29)] ? do_page_fault+0x0/0x1de
    [(c0423b4d)] error_code+0x6d/0x74
    [(c05v9342)] ? unlzma+x0xcfa/0xe8e
    [(c0101546)] ? fill_buffer+0x0/0xa9 ....
    [(c01038e7)] kernel_thread_helper+0x7/0x ......

    what can i do
  • blcondeblconde April 2010
    How did you created the new rootfs, did you run again the Taz USB tool again or did end the session and checked the box "Saving file system using compression"? The second one is the best way.

  • moralesramonmoralesramon April 2010
    i created the new rootfs using tazusb writefs lzma in a terminal
    slitaz 3.0 doesn't shows me the box "Saving file......"
    i think the problem is in the new rootfs generated because if i use the old rootfs (the original) the system boots very well
  • slicelslicel April 2010
    Sometimes, different lzma commands use different default compression settings.

    If you are running a tazusb installation, when you click logout, there should be a check box to write the fs at logout.
  • moralesramonmoralesramon April 2010
    well, i made the usb installation in a windows box with tazusb.exe utility
    it did work well for me with slitaz2.0 usb installation
  • moralesramonmoralesramon April 2010
    thanks slicel for your help
    i can't resolve this yet
    have you made a tazusb installation in slitaz3.0 cd live
    i can't do it , tazusb gen-uso2usb or gen-liveusb shows me errors

  • slicelslicel April 2010
    I booted a slitaz 3 xvesa live cd, used gparted to make one ext3 partition on a usb key, used the tazusb gui tool to create a tazusb key (you can leave the first box blank for the default cd and select the usb key's partition in the second box), booted the tazusb key, installed conky, used the logout prompt to write the fs in lzma at logout, and rebooted the tazusb with conky installed.

    You can try that method instead of the windows exe.
  • moralesramonmoralesramon April 2010
    thanks a lot slicel, i will try tomorrow
  • moralesramonmoralesramon April 2010

    there is something wrong with my machine
    tazusb is not working for me because slitaz can't mount my cdrom
    /proc/sys/dev/cdrom shows empty properties on its info file (drive name) .....
    i am new in linux and i don't know why
    i will try in another machine

  • slicelslicel April 2010
    I do not remember ever having to mount the cd drive manually for tazusb.

    Once the usb is formatted to ext3, either the tazusb gui tool with the first box blank or the xterm command should work (sdb1 is an example, use your specific usb identification)-
    # tazusb gen-liveusb /dev/sdb1

    Open the mount box and try to mount the cd if it is not mounted or unmount if it is mounted.

    If you are running the live cd from the machine that has the initially downloaded slitaz iso on hd, you could mount that partition and then use the gui tool's first box to point to the iso on hd (mounted drives are in /media).

    You could divide the usb into two partitions, copy or download the iso to a 50mb partition (might be named sdb2), and then have the gui tool create a tazusb from sdb2 to sdb1 on the usb key.

  • moralesramonmoralesramon April 2010
    yes , the problem was generated by my machine
    i used the slitaz 3.0 live cd in another machine and tazusbbox worked fine
    i installed slitaz on my usb flash
    now i will boot with my usb and i am going to update my system
  • moralesramonmoralesramon April 2010
    first: save file system using compression box at logout does not work
    "can't execvp /usr/bin/tazusb no such file or directory"
    but tazusb writefs works fine in a terminal
    second: if i use lzma compression, the machine can't boot again (the original problem)
    but gzip compression or not compression works fine
    thanks slicel , i appreaciate your help
    i am not going to use lzma compression until someone fixes this problem
  • slicelslicel April 2010
    It sounds like the tazusb.exe is ok and my slitaz-3.0-xvesa.iso is ok so the problem is with the flavor you tried.

    Thank you for reporting results.
  • stopstockstopstock September 2010
    i created the new rootfs using tazusb writefs lzma in a terminal.
    and why my system booting so long?

    its about 6minutes.

    i'm new in linux too.
  • slicelslicel March 2011
    Some people reported that writing lzma was broken but writing gzip worked.
  • ChristopheChristophe March 2011
    i had issues even if not compressed at all....
    In fact I gave up for now to have it run from memory.
  • Yes, I had the same issue several times with ,,tazusb writetazusb writefsfs lzma" - I could not boot the new rootfs.gz that I got. Using ,,tazusb writefs gzip" it worked without any problem. The boot process was longer, but the file system was much bigger after having had installed a lot of memory-eating software.


  • Trixar_zaTrixar_za March 2011
    I was told on IRC (and from personally experiencing it) that lzma has it's limits and can take forever if your file system is over 150MB or so. Generally switching to gzip at this point compresses faster and decompresses faster too. Still a pain if it tries to load everything into RAM though,
  • ChristopheChristophe March 2011
    I am not sure i see the value of compressing a fs if this is to reduce it from 600 MB to 200MB from current USB sticks... but had pbs event when not compressing, after adding openoffice; it would not boot anymore whether compressed or not...

    Question, it seems there is something that I missed though
    What it the "tazusb gui" ? and where/how do I open it ?


  • slicelslicel March 2011
    There is a tazusb tool in the menu and a gui box at logout.
  • ChristopheChristophe March 2011
    I have never seen the gui box at logout....

    So far i have used the tazusb to generate a rootfs that I boot from using grub4dos

    I am gessing you do differently. What should i do ?

  • slicelslicel March 2011
    I meant the box that looks like the normal logout box with added choices for writefs that every tazusb installation should show (when logged into a tazusb installation that you created already).

    I used the terminal commands described in this thread.

    I only did initial installations on ext3 from live cd and never tried heavy customizations.
  • lmartlmart March 2011
    Christophe: I boot slitaz-3.0-xvesa frugal from grub4dos and, like you, use tazusb to generate a rootfs. Running into problems.  Create the new rootfs using tazusb under xterm (tazusb writefs gzip), then replace the existing rootfs with the new rootfs.  During boot, SliTaz presents a logon error, then presents the signon screen. Slitaz will not allow logon as Tux, only root. Ideas on what is happening and what will correct the situation? Many thanks.

    PS: If you boot SliTaz from a usb stick, when you exit, there is a dialog box (Slicel's tazusb gui tool) that allows you to create a new rootfs using lzma or gzip. It's pretty cool. If we could have the same thing for frugal installs, it would be a valued addition to a great distro!!!
  • ChristopheChristophe March 2011
    you need to have an ext partition as /home on the usb and then it should work.

  • seadx6seadx6 March 2011
    In my Dell desktop my ext3 partition is sda2 but on my Dell inspiron 1420 the sda2 is my hard drive ¿how can I solve it editing my slitaz syslinux.cfg?
  • ChristopheChristophe March 2011
    i think i did something that had solved that somehow by calling the partition "home" and then passing the argument home=home at boot time.on the command line
  • lmartlmart March 2011
    Christophe:  Have 2 instances of SliTaz; #1, hdd frugal and, #2 on usb for remote use.  No problems w/ usb.  As mentioned, like the option to create a new rootfs on usb.  Additionally, like the maintenance of rootfs files under usb SliTaz.  My problem is with frugal SliTaz.

    Here's the situation w/ hdd frugal.  xterm - tazpkg upgrade.  xterm - tazusb writefs gzip.  rename rootfs.gz to #.rootfs.gz.  move rootfs.gz from / to /sda1/boot/.  [fyi, usb slitaz does this automatically] On boot, get FAILED TO EXECUTE LOGIN COMMAND.  Can only login as root.  Any thoughts on resolving?

  • mojomojo March 2011
    tazusb functions the same whether the frugal install is to a flash drive or hard drive.
    rootfs.gz should always be in /boot
     tazusb writefs gz resulting in /rootfs.gz means the install is broken
    I would do a clean install and start over.
    Verify a writefs results in /boot/rootfs.gz , /boot/previous.gz ,and
    login tux works correctly before you start installing software.
  • lmartlmart April 2011

    since your post, tried multiple times to resolve problem with no success on hdd, the process you outline works perfectly on usb

    system:  hdd (f32, 20G), boots to grub4dos, extracted iso and copied exactly to hdd | tux login works correctly
    upgrade all packages with tazpkg upgrade and create new rootfs.gz with tazusb writefs gzip
    new rootfs.gz in / not /boot; no previoius.gz
    manually replace rootfs.gz and upon next boot, get the dreaded error message

    As suggested in my earlier post/reply to Christophe, exiting SliTaz on usb is elegant.  You can select to create a new rootfs or not, it takes care of the housekeeping (previous.gz) and, it works!  Based on the volume of posts on this topic along, providing this same functionality for frugal installs would be a welcomed addition to a great distro!!!


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social