This is the old SliTaz forum - Please use the main

How to keep installed software?
  • sanekssaneks March 2010
    thanks alot for creating a new Slitaz! I really liked the distro from the start and it now feels a lot better than 2.0.

    But how do I keep installed software?

    I try home=usb while booting, so I keep some settings:

    - background
    - new menu entries
    - root-passwords are kept (not in wifi manager)
    - I created config files for wbar/conky/... in /home

    but mplayer, conky, wbar, gimp, abiword etc.. are not kept!

    I am not sure if home=usb uses the ssd drive of my eee rather than the actual thumbdrive: I found my crunchbang installation filled up with a 260MB big slitaz folder when playing with "tazusb writefs"

    My theory: /home is kept on usb, but not the root-filesystem with the new programs.

    So how can I make the root filesystem save changes back to my live-usb? It is formatted FAT,cause Unetbootin does not work here on my Linux. I want to make changes and save back to the stick. That's all, but I find it a tricky task. Or do I have to make a "real" install to the USB key or my harddisk/ssd to have installs that stay?

    Thanks for help!
  • snowpinesnowpine March 2010
    Unetbootin is not part of SliTaz. Use TazUSB instead if you want the full SliTaz experience. :)
  • pauljurczakpauljurczak March 2010
    I just started playing with SliTaz and here is my prescription for persistent modifications of liveUSB:
    1. Boot from liveCD.
    2. Create liveUSB with “tazusb format” (ext3) and “tazusb gen-liveusb”. Don’t use UNetbootin.
    3. Boot from liveUSB.
    4. Make modifications.
    5. Run “tazusb writefs lzma” and soft reboot.
    6. Go to 4.
  • sanekssaneks March 2010
    just tried exactly this, but formated with gparted and did "writefs none". booting takes longer now and I can notlogin other than root. ("no autologin") - and as root I see no desktop files anymore and no wallpaper works.. but software and wifi settings are intact this time.

    will keep on working on it. thanks for your suggestions.
  • snowpinesnowpine March 2010
    "just tried exactly this"

    Not if you used gparted. :) Follow Paul's instructions exactly, or the detailed TazUSB documentation linked to in post #2.
  • sanekssaneks March 2010
    thanks snowpine and all the others. I repeated all of Paul's steps, but first it came out like I described in my last post above (only root user). But after *really powering off* the eee and *not booting with localization* it seems to work like it should. wifi autoconnects, conky is still installed.. also after reboot. and I am being asked if I want to change changes before Shutdown, so I don't have to sit waiting for it, great.

    I think I thought to much.. like copying the rootfs.gz into the folder where it was before before hutting down, then entering my local upon boot is unecessary, and I guess it caused some different type of image being booted (???)

    still a slitaz starter, but now I think I am over the worst hurds, yeah :D

    Thanks to all!!

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social