This is the old SliTaz forum - Please use the main

[Solved] Weird flakey Alsaplayer problem
  • marquiticomarquitico March 2010
    At first I thought I simply had no sound at all, until I discovered that flash animations with sound in the browser played perfectly well. On investigating I see that Slitaz finds my card just fine (Riptide). Alsamixer behaves normally. Alsaplayer loads mp3s and wav files fine, and acts like it plays them, but no sound comes from my speakers, although flash in Firefox continues to play sounds just fine.

    I tried reinstalling the linux-sound package; no change. Then I read on here something about the audio group and permissions, and I fooled around with /etc/group, and this happens to me:

    At bootup the /etc/group file has this line:


    I changed it to this:


    And suddenly Alsaplayer has sound!! But this is the only chance I get. If I log out and log right back on, the sound is gone. And no amount of switching back and forth in /etc/group will bring it back. The only way to get it back is to reboot and start all over again (have not tried persistent changes).

    Any ideas?
  • Bump. Disappointed to report same problem in 3.0. A Riptide problem, maybe? Any thoughts appreciated. Flash with sound continues to work.
  • slicelslicel May 2010
    Hello. It makes sense that you bumped your unresolved and unresponded-to problem but I was told that bumping violated forum ethics, although I could not find any documentation of such a rule.

    I read that riptide needs oss instead of alsa, or it needs firmware, or it needs a compiled driver, or it might never work.

    One person said that it would work only with one item at a time, so you could try to disable sound in your browser and everything else except the program that you want to produce sound.

    Here is a link to some riptide drivers (not sure if they apply to yours)-

    However, slitaz might have a bug in compiling.

  • Thank you for your response!

    I know from my desktop installation (Slackware-based) that Riptide actually has needed ALSA in the past, and that OSS didn't work, although I'm uncertain about OSS's latest revision (v. 4.1). Somewhere in the 2.6 Linux kernel, Riptide support ceased being an external driver and became a kernel module. My older Linux installations on the 2.4 kernel were completely mute until this happened.

    SliTaz's linux-sound package, being based on a recent kernel, has all the kernel modules necessary, and lsmod after boot-up shows them all loaded, the same as with my Desktop installation.

    Since there's no OSS tazpkg, has anyone successfully installed OSS on SliTaz manually? Any tips/pointers?

    I'm fascinated by the idea of disabling sound in the browser, as you suggested. How is that done?
  • slicelslicel May 2010
    Sound in flash with the new kernel might mean that oss is not needed but I mentioned it because it was listed on other websites.

    Login as root to try everything in addition to trying to add other users to group.

    Opera has some easy sound settings-

    You probably can google for disabling sound in other browsers.

    You also could uninstall every browser and flash (or install an experiemental fresh install somewhere).
  • kultexkultex May 2010
    first did you try to play the files with another player e.g. audacious, mpg123, mplayer, vlc....

    see on the end of this thread - there is amixer - there are switches, you do not see in alsamixer

    slackware is quite good in recognizing the sound correctly, try any slackware live cd like fluxflux -
    and find out, what amixer numids are swiched on or try to google for amixer and your soundcard......

  • OK. Tried slicel's idea of a root login, but no luck. kultex may have the right idea (thank you). mpg123 plays just fine. So maybe I was hasty in naming this thread...perhaps I have a problem with Alsaplayer itself?

    When I have a little more time, I will check the amixer settings on my full install, which is based on Slackware (but is also on the same hardware), also kultex's idea, thank you.
  • kultexkultex May 2010
    your amixer settings are correct, when mpg123 plays fine. Does Alsaplayer recognice your card?

    type: aplayer -l

    $ aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: I82801BAICH2 [Intel 82801BA-ICH2], device 0: Intel ICH [Intel 82801BA-ICH2]
    Subdevices: 1/1
    Subdevice #0: subdevice #0


    $ aplay -d hw=I82801BAICH2 test.mp3

    and alsaplayer has the same syntax

    $ alsaplayer -d hw=I82801BAICH2 test.mp3

    the config file of alsaplayer should be here (I am not on SliTaz): ~/.alsaplayer/config
  • OK, kultex is onto something. audacious plays just fine. Really well, actually. So I was wrong: the problem I have is with alsaplayer itself.

    And in other news, why don't I have aplay anyplace? I seem to have everything else...
  • OK, now I'm convinced. aplay also works. So the actual culprit is alsaplayer, hence the change to the thread title.

    Question about syntax: what do I put in as my card? aplay -l produces:

    **** List of PLAYBACK Hardware Devices ****
    card 0: Riptide [Riptide], device 0: RIPTIDE [RIPTIDE]
    Subdevices: 3/3
    Subdevice #0: subdevice #0
    Subdevice #1: subdevice #1
    Subdevice #2: subdevice #2

    But if I do:

    alsaplayer -d hw=Riptide Blah.wav

    I get

    Unknown PCM hw=Riptide
    snd_pcm_open: No such file or directory (hw=Riptide)
    Failed to initialize plugin!
    Failed to register plugin: /usr/lib/alsaplayer/output/

    If I do this (I got this from the ALSA website. hw:0,0 is supposed to be the default):

    alsaplayer -o alsa -d hw:0,0 Blah.wav

    it no longer complains about not initializing the plugin, etc., but there's no sound, so I'm back where I started.

    This is actually not critical, since so many other multimedia players work, but I guess this means that alsaplayer is not foolproof across many different sound setups.
  • OK, the quick and dirty solution:

    alsaplayer -d hw=default

    I then edit alsaplayer.desktop in /usr/share/applications so that the Exec line looks the same, and then launching from the menu also works.

    Extra info for those interested. Running from the command line produces these comments:

    ALSA lib pcm.c:2211:(snd_pcm_open_noupdate) Unknown PCM hw=default
    snd_pcm_open: No such file or directory (hw=default)
    Failed to initialize plugin!
    Failed to register plugin: /usr/lib/alsaplayer/output/
    Falied to load output plugin "alsa". Trying defaults.

    Then it repeats some of this once more, but the player it spawns plays just fine. As noted above, if I actually specify the correct device (hw=Riptide) it fails. Weird. But I have my solution.
  • kultexkultex May 2010
    I never used alsaplayer and there is not much doku about alsaplayer config, but something like this in the config should work:

    audio_dev = default
    audio_output_type = alsa
    audio_output_mode = -d

    Edit: this is old alsaplayer style - the new one is:


    if this does not work, can you ask Dominique Michel you will find the adress under contact on - he is the admin of Alsaplayer - the problem is, that alsaplayer is quite dead ....
  • No luck, I'm afraid. The

    is already in the config file, so that's not it.

    I didn't realize that the alsaplayer project is not maintained anymore. Too bad. Michel doesn't answer me, so I guess that's it. But my solution works, even if it's a bit weird, so I'm not complaining.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social