This is the old SliTaz forum - Please use the main

Play FLV File (VLC and MPlayer)
  • maxxmaxx March 2010
    I have used Search box on this forum to find a player of FLV file, but it seems no one has discussed about it. I have a problem when play FLV file which I download from YouTube using VLC. It needs some codec which can play the sound "mp4a", but VLC can't find it on the default installation of tazpkg file.

    Have you got an idea how to play FLV file using VLC or Mplayer?

    Need help and regards,

  • seawolfseawolf March 2010
    It is a Flash video file, with MP4 audio. Your best bet would probably be to use an online converter, similar to if no-one can offer a program to play them directly.
    I'm unfarmiliar with VLC so can't offer a codec to play them directly.
  • erniaernia March 2010
    in archlinux mplayer plays flv
  • mojomojo March 2010
    slitaz-2.0 + mplayer-1.0rc2 plays flv,mp4,avi(divx),svcd,vcd,dvd
    quicktime,wma,wmv,mp3,flac,ogg,mp3,and many more.

    Add to


    Menu/Multimedia/Mplayer Multimediaplayer

    browse to file,playlist,url

    make open with mplayer file association in pcmanfm for multimedia file types

    or from xterm without gui

    mplayer /path/to/multimedia/file

  • maxxmaxx March 2010
    Ok guys, I'll try it at home... thanks bro mojo for the config. Actually VLC plays FLV smoothly on Ylmf (karmic based), and I am really sure that all linux is able to play it using VLC. I'll report my progress as soon as I arrived at home and try it...

  • maxxmaxx March 2010
    well, i have just play around and do what suggested, but still the VLC failed to play the sound "mp4a". Is there anymore idea guys? Could this because any dependency error?
  • moulefritemoulefrite March 2010
    Xine with it's xine-lib is ok with flv and many stuff (except for some .wmv)

    you can find some good skins for as like u can see here

  • maxxmaxx March 2010
    I didn't check whether the xine was able to play FLV correctly... I'll try it tonight. VLC play some FLV file, but can't on others with audio "mp4a". I have tried installing "faad2", but it still doesn't work. If there's no way to play all of FLV file with VLC, I plan to install it from the source code.
  • noteithernoteither March 2010
    i have tried downloading flv files and the played on slitaz 3 rc
  • maxxmaxx March 2010
    how do play the flv files? are you using VLC too?
  • ffplay plays flv-files - I tried it. It uses ffmpeg. But maybe you can also use gstreamer (gst-...) to get the needed codecs to play flv-files with vlc...
  • maxxmaxx March 2010
    any suggestion of how to install these packages?
    what first and what next to install? I mean on the dependency which should suit the installation process.
  • RuppRupp March 2010
    Nearly everything plays .flv these days. I wonder what could be the problem?

  • RuppRupp March 2010
    Nearly everything plays .flv these days. I wonder what could be the problem?

  • RuppRupp March 2010
    multipost sorry
  • RuppRupp March 2010
    multipost sorry
  • RuppRupp March 2010
    multipost sorry
  • maxxmaxx March 2010
    I have trial installing "faad2" which said to be able to play mp4a file, but it was no luck. I think the problem remains here, VLC cannot play mp4a audio because it's missiong some dependency for mp4a (aac audio).

    Any idea to install VLC manually Rupp? I'm getting used to VLC than other multimedia players. I have a note on the Ubuntu VLC installation, may be it could help us for VLC on SlitTaz:

    VLC 1.0.2

    The following packages were automatically installed and are no longer required:
    user-setup localechooser-data
    Use 'apt-get autoremove' to remove them.
    The following extra packages will be installed:
    libdvbpsi5 libebml0 libiso9660-5 liblua5.1-0 libmatroska0 libqtcore4 libqtgui4
    libsdl-image1.2 libtar libvcdinfo0 libvlc2 libvlccore2 vlc-data vlc-nox vlc-plugin-pulse
    Suggested packages:
    qt4-qtconfig mozilla-plugin-vlc videolan-doc
    The following NEW packages will be installed:
    libdvbpsi5 libebml0 libiso9660-5 liblua5.1-0 libmatroska0 libqtcore4 libqtgui4
    libsdl-image1.2 libtar libvcdinfo0 libvlc2 libvlccore2 vlc vlc-data vlc-nox vlc-plugin-pulse
    0 upgraded, 16 newly installed, 0 to remove and 80 not upgraded.

    Selecting previously deselected package libdvbpsi5.
    (Reading database ... 103865 files and directories currently installed.)
    Unpacking libdvbpsi5 (from .../libdvbpsi5_0.1.6-1_i386.deb) ...
    Selecting previously deselected package libebml0.
    Unpacking libebml0 (from .../libebml0_0.7.7-3.1_i386.deb) ...
    Selecting previously deselected package libiso9660-5.
    Unpacking libiso9660-5 (from .../libiso9660-5_0.78.2+dfsg1-3_i386.deb) ...
    Selecting previously deselected package liblua5.1-0.
    Unpacking liblua5.1-0 (from .../liblua5.1-0_5.1.4-3_i386.deb) ...
    Selecting previously deselected package libmatroska0.
    Unpacking libmatroska0 (from .../libmatroska0_0.8.1-1.1_i386.deb) ...
    Selecting previously deselected package libqtcore4.
    Unpacking libqtcore4 (from .../libqtcore4_4.5.3really4.5.2-0ubuntu1_i386.deb) ...
    Selecting previously deselected package libqtgui4.
    Unpacking libqtgui4 (from .../libqtgui4_4.5.3really4.5.2-0ubuntu1_i386.deb) ...
    Selecting previously deselected package libsdl-image1.2.
    Unpacking libsdl-image1.2 (from .../libsdl-image1.2_1.2.7-1_i386.deb) ...
    Selecting previously deselected package libtar.
    Unpacking libtar (from .../libtar_1.2.11-6_i386.deb) ...
    Selecting previously deselected package libvcdinfo0.
    Unpacking libvcdinfo0 (from .../libvcdinfo0_0.7.23-4ubuntu1_i386.deb) ...
    Selecting previously deselected package vlc-data.
    Unpacking vlc-data (from .../vlc-data_1.0.2-1ubuntu2_all.deb) ...
    Selecting previously deselected package libvlccore2.
    Unpacking libvlccore2 (from .../libvlccore2_1.0.2-1ubuntu2_i386.deb) ...
    Selecting previously deselected package libvlc2.
    Unpacking libvlc2 (from .../libvlc2_1.0.2-1ubuntu2_i386.deb) ...
    Selecting previously deselected package vlc-nox.
    Unpacking vlc-nox (from .../vlc-nox_1.0.2-1ubuntu2_i386.deb) ...
    Selecting previously deselected package vlc.
    Unpacking vlc (from .../vlc_1.0.2-1ubuntu2_i386.deb) ...
    Selecting previously deselected package vlc-plugin-pulse.
    Unpacking vlc-plugin-pulse (from .../vlc-plugin-pulse_1.0.2-1ubuntu2_i386.deb) ...

    Sorry it's a long note.. hehehe... :D
  • ffplay can be installed via package manager or "tazpkg get-install ffplay" on slitaz-cooking.
    I don't know much about gstreamer but I know that on Ubuntu it is used to get the needed codecs installed. I think you can use the several ubuntu-wiki to learn how to configure gstreamer...
    But ffplay does not need gstreamer it uses ffmpeg.

    With VLC and mplayer I had the same problem, they didn't play the flv-file. Using the terminal for starting the video with mplayer, I found out that I had to install xorg-...-libxv and it needs a libgif... I don't know which package this refers to...
    So I tried ffplay and it works...
  • maxxmaxx March 2010
    I'll try it brother Killerkaninchen... and I'll post the result soon here. Many thanks for you.
  • maxxmaxx March 2010
    still have no luck to play some FLV file using VLC...
    the "mp4a" warning still be the problem.
  • What about ffplay?
  • maxxmaxx March 2010
    I tried ffplay too, but the audio (mp4a) can not be played. I'm going to install SliTaz 3.0 soon. I wish I can play all the FLV files without problem then. By the way, thanks for your help.. I'll report back my progress here later.
  • maxxmaxx March 2010
    I have installed SliTaz v.3.0 last night. Installed mplayer-svn, still cann't play FLV file (video can not be shown) and the message says it needs to be compile with "faad" enable.

    So, I think the problem is here with mplayer on SliTaz, the mplayer-svn tazpkg should be compiled with "faad" enabled. I wish it could be fixed sooner. I can not compile by myself by now. And also with VLC, it should be compiled with "faad" enabled too.

  • RuppRupp March 2010
    Again I don't know what the problem is. FLV works right away for me with no problem at all.

    Try this faad:

    download it then use:
    tazpkg convert

    then install it.

    Hopefully that will work for you.

  • maxxmaxx March 2010
    Thanks Rupp, I'll try it tonight.
  • maxxmaxx March 2010
    still no luck... I think I will have to compile it from source or use tazpkg convert for all of dependency files needed.

    I'll give it a try this weekend and report back here later.
  • jozeejozee March 2010
    Hi all,

    Few suggestions:
    1) Burnbox can convert your flv files to mpg format. For 3.0, we didn't find time to make this conversion as a separate GUIbox. There is small trick you can use now. Burnbox saves the converted audio/video to /tmp/burn-cd. Just copy that.

    2) Atleast Mplayer plays flv on my computers. I just tested: gmplayer, gnome-mplayer and smplayer. They all play flv. VLC used to play earlier but now it doesn't. So, we need to fix this. Can someone add this bug to the issue tracker on lab.

    My suggestion is just download SMplayer. I hope this helps.
  • maxxmaxx April 2010
    Here's what Terminal says when I run VLC from Terminal:
    [00000358] main decoder error: no suitable decoder module for fourcc `mp4a'.
    VLC probably does not support this sound or video format.

    And here's what I have got from Googling around for the trouble on playing FLV:
    ./configure option: --enable-faad

    VLC is compiled by default without faad enabled. I wish SliTaz VLC package would be compiled by faad enabled.

    Thanks for any helps...
  • maxxmaxx April 2010
    I am trying to convert vlc-1.0.1-i486-2alien.tgz (Slackware binary) but it takes too long to finished (have not finished untill now, about half hour running)

    I use this command:
    tazpkg convert vlc-1.0.1-i486-2alien.tgz

    and the Terminal says:
    LZMA 4.57 Copyright (c) 1999-2007 Igor Pavlov 2007-12-06
    Decoder error

    How long does it takes to convert a package on a normal time? This file is about 20.1 MB.
  • maxxmaxx April 2010
    ffplay does play FLV video with mp4a audio now.. thanks to Killerkaninchen..

    but, how do we integrate this ffplay to the GUI version of for example SMplayer or Mplayer and VLC. any idea guys?

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social