This is the old SliTaz forum - Please use the main

SOLVED (?) cooking 20100221 pcmanfm ntfs hal
  • erniaernia March 2010
    I'm not able to mount a ntfs partition double clicking it in pcmanfm.
    I can mount it in mountbox and with ntfs-3g but not in pcmanfm.
    This was working in 2.0 and works for ext2 and vfat.
    The error message i got is:
    Error org.freedesktop.Hal.Device.Volume.UnknownFailure
    Error org.freedesktop.Hal.Device.Volume.UnknownFailure
    Directory doesn't exist!

    Errors appears in a message box and i press ok between messages.
    It seems something related to hal, i sure don't have the skills to debug it.
    Any advice?
  • erniaernia March 2010
    I got the very same error message with reiserfs partitions.
    the message disappear after installing linux-reiserfs, so probably the error it's not due to hal but to something related to the filesystem driver pcmanfm is using.
  • erniaernia March 2010
    I've solved with a dirty hack knowing nothing about hal:
    i've just copied the /usr/share/hal/fdi/policy/10osvendor/25-ntfs-config-write-policy.fdi in /usr/share/hal/fdi/policy/10osvendor/ and restarted hal
    Now it mounts ntfs read-write
    Maybe someone more qualified then me could check wath's going on?
  • jozeejozee March 2010
  • qman_txunqman_txun February 2011
    Hi ernia,
    Where did you get the 25-ntfs-config-write-policy.fdi file? Looks that I'm starting to like Slitaz but if I can't mount my NTFS partition then I can't do much thing, the problem is that I have other people that behind me and they need easy computer mounting. On the PCMan it doesn't show up the NTFS partition nor an Ext3, USB memory are so easy to mount. Here is my Fstab file:

    # /etc/fstab: Information about static filesystems.


    proc            /proc        proc    defaults          0       0

    sysfs           /sys         sysfs   defaults          0       0

    devpts          /dev/pts     devpts  defaults          0       0

    tmpfs           /dev/shm     tmpfs   defaults          0       0

    #/dev/hda3       /home        ext3    defaults          0       2

    #/dev/hdb1       /mnt/data    ext3    defaults          0       2

    /dev/cdrom      /media/cdrom iso9660 user,ro,noauto       0       0

    /dev/hda1 swap swap default 0 0

    my NTFS partition is on /dev/hda3

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social