This is the old SliTaz forum - Please use the main

New: SliTaz Snow LiveCD flavors: slitaz-dillo.iso
  • kultexkultex December 2009
    first congratulations - I am verry happy!!! it looks so cool without the ugly fxpanel and the new wellpaper - the iso is booting via USB-Stick on my Fujitso Futro A210 with Geode LX800, which has 89RAM available. I just could install it to the CF card.

    Then I wanted to install just firefox, because this 8W running Computer is going to be my surf PC. But after installation it did not start, because of missing depencies - so the depencies for firefox should be needs also alsa-uitils

    the only thing, I do not like - but its just a matter of taste: I would prefere Midnight Commander with built in mcedit instead of nano and this strange clex
  • kultexkultex December 2009
    some more thoughts after one day of experimenting:

    1) Hv3: dillo is now quite useless - there are not much websites, you can open in a readable way - two years ago, this was different.
    There is another lightweight browser called Hv3 - - ok developement stopped also about two years ago, but at least javascript and frames are working - - perhaps it is possible to replace dillo with Hv3.

    At the moment Hv3 is not opening, because it is missing Perhaps somebody can make a running package for slitaz-dillo.iso of HV3 to test.

    2) Midori: firefox is not anymore a good choice for a machine with so little rams - even with swap its extreamly slow now - but I recommand midori - installs without any problems with tazpkg - installed (normal hdinstall) on CFcard, it works like a charme even without swap (I think the same it should be on a lowram.iso). Midori made a very huge progress since I tested it last year. Midori in the repos is a little bit outdated (Version 2.0) - the new is 2.2 so perhaps it is possible to get an update?

    and last but not least, I think hal is useless on such a system, so I removed it

  • seawolfseawolf December 2009
    Does anyone know if it is possible to compile Firefox without sound capabilities, or other such dependency-ridding options? A firefox-nosound package or something similar could then be created.

    Maybe. Just a thought.
  • CaseyCasey December 2009
    Midori is indeed a viable alternative to firefox and certainly lighter. I wholeheartedly agree that dillo should not be considered a workable browser in today's web ecosystem - too many apps rely on JS for styling/functionality and dillo suffers there - heck, even the standard Google search page is not rendered properly in dillo.
  • kultexkultex January 2010
    ok - checking the office.iso of Snow flavors, I recogniced, that there is another browser - netsurf. But when I install it on the dillo.iso, it does not open - is it possible to
    !! correct netsurf!!
    , so I can open it on my A210 - because I cannot boot and install the office.iso - it seems, that there are missing depencies.

    I tried also on tinycore linux Hv3, Midori and Arora on my little machine and Arora was that one using the minimum of ram - even it is qt based. So it would be nice to have Arora also in the repositories.

    Arora depencies (7 in total with less than 13,5MB)
    qt/4.5/base 5.8mb
    qt/4.5/script 0,8mb
    qt/4,5/sql 0,3mb
    qt/4,5/webkit 6,1mb

    Midori depencies (about 20 - two of them have already 17MB)
    webkit 9,1mb
    icu 7,9mb
    And it seams, that Arora supports flash10, what Midori does not - or at least I did not get it working

  • jozeejozee January 2010
    @kultex: flash10 works with midori 0.2.0 (version I have). Midori reads mozila plugins in /usr/lib/mozilla/plugins (if I remember correctly). Maybe you create this dir and reinstall get-flash-plugin. See this fix: . Hope it works.
  • CaseyCasey January 2010
    important to note that any GTK dependencies listed for midori will most likely already have been included, while QT will not. I know, for example, on my Arch OpenBox setup, midori is a small 6mb addition with dependencies, while arora weighted in at over 18mb because of the QT related stuff (which none of my other installed apps require).
  • kultexkultex January 2010
    @jozee there was a symlink which was called /usr/lib/mozilla/plugin which pointed to /usr/share/flash/ - I deleted this and created it correctly /usr/lib/mozilla/plugin/ - but Midori 0.2.0 does not open a flash website. I think, I do not have to reinstall.

    But it can be, that this is also a problem of missing depencies - like with netsurf - but I dont think so, because I can open a flash website with firefox - but it takes ages - I will check this as soon as possible.....

    @Casey I am not talking about a normal system - I am talking about these little things: , which have all 128MB (89 left to work) - they start slowly coming to ebay (I could get one A210 for 50€) - latest, when the first tegra thinclients are available, they will be thrown out of the companies - and they have quite a lot of them......

    As I already told - it takes 8W and they are perfect for being always one for everybody, checking mails search something......also softmaker office works quite fine on it - without any depencies.
    Its also a perfect machine for Museums, showing videos or presentations, because it supports 1600x1200 without any problems.

    And on slitaz-dillo.iso Midori is installing a hell of apps - whereas Arora should not do this - I checked this on tinycore linux - Arora is the smallest and the quickest flash-browser!!!
    (Technosaurus on puppy was testing this too:, but they also did not take it, because of qt)

    So just for all this reasons, it would be nice to have Arora in the repositories....

    Edit: I already found the first Kirkwood ThinClient (same CPU as in the Shevaa Plug:
  • jozeejozee January 2010
    @kultex : Please reinstall flash. It should work. Its a known problem that when we update firefox version, flash for midori browser may stop working unless we rerun the get-flash-plugin script. It needs to recreate links latest nss and nspr libs. We need to improve firefox receipt to handle this.
  • kultexkultex January 2010
    @jozee I did as you told - nothing changed, I had to do the symlink again - perhaps it was working, because I found this:
  • kultexkultex January 2010
    I also tried from the

    export MOZ_PLUGIN_PATH="/usr/lib/mozilla/plugins:/opt/mozilla/lib/plugins"
    did not help
  • jozeejozee January 2010
    Hi Kultex: I just tested youtube video on midori. It works. As you are not able to get it to work, there must be some bug somewhere. I will try to debug it and fix for Slitaz 3.0.
  • kultexkultex January 2010
    hi jozee - did you update Midori? - its now 2.2 - there is missing depency: libnotify

    but flash is still not working - it must be in the flash skript - perhaps an idea: the flashscript from tinycore works perfect with midori, it could be worth to have a look on this?
  • slicelslicel January 2010
    I recommended a dillo (or even links) flavor as a rudimentary browser that was in repos at the time (old forum) for people installing from floppies or with <16mb ram or on dialup (want to refuse scripts). However, dillo could be replaced if something new is better for that flavor to serve old/slow systems. Hv3?<br />
    I understood that firefox has market share and many plugins but firefox could be replaced on the standard slitaz if something new is better (secure, does flash) for the full/standard slitaz. Arora? I suggested it for repos on the old forum.

    Midori is smaller than firefox with ability for mozilla plugins but Opera seemed faster to me.

    It is important for the browser not to add many mb in depends, as casey mentioned.

    I mentioned on the old forum that a flv player smaller/better than adobe would be good for slitaz.

    How does privacy and security for browsing and banking compare in all these browsers?

    Thank you.
  • erniaernia February 2010
    i got flashplugin working in midori only if firefox is installed. the reason is that some libs ( are installed only with firefox in /usr/lib/firefox/... and symlinked in /usr/lib/. so if you don't install firefox you can't use
    I got it working copyng these libs in /usr/lib/, uninstalling firefox and symlinking /usr/share/flash/ in /usr/lib/mozilla/plugins/ (or in ~/.mozilla/plugins/ if you prefer).
    wouldn't it be better to put these library in /usr/lib/ as a dependency of get-flash-plugin and leave get-flash-plugin indipendent from firefox?
  • jozeejozee February 2010
    yes you are right. I have been thinking of splitting firefox into libnss/libnspr for sometime (precisely for this reason). Will do this soon.
  • erniaernia February 2010
    thanks a lot, you are very kind

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social