This is the old SliTaz forum - Please use the main

Unable to mount a music cdrom
  • NikusNikus December 2009
    I installed Slitaz 2.0 stable on my computer and I have a DVD drive.
    I used this DVD drive to boot on a cd-rw to setutp slitaz, so the DVD drive works.
    When I insert the cd-rw with slitaz, the cdrom is mounted and works well.
    But when I insert a music cdrom, nothing appends. So I tried "mount /dev/hdd /media/cdrom" wih the root permissions and I had this error message : mount: mounting /dev/hdd on /media/cdrom failed: Input/Output Error (Erreur d'entrée/sortie)
    Someone has the same issue or a solution?
  • kultexkultex December 2009
    you should do the same with the group audio with the group cdrom - I hope that works
  • NikusNikus December 2009
    Thanks to reply me. I already thought of that but there is no group named cdrom in the file /etc/group.
    And as I can read my cd-rw I think this is not a permissions issue.
  • NikusNikus December 2009
    I tried to add a new group named cdrom, I added the user to this group and I changed the group owner of /dev/cdrom, /dev/dvd, /dev/hdd and /media/cdrom; but without success.
    I tried this command "mount /dev/cdrom /media/cdrom -t iso9660" and the system replies me "Invalid argument". Do Slitaz support iso9660 file type ?
  • kultexkultex December 2009
    soory, I did not see slitaz 2.0 - I use just cooking - but as an idea, did you already try slitaz mount box?
  • cavalier911cavalier911 December 2009
    Since you don't say why you need to mount an audio cd here is what I use on slitaz with audio cd.

    I rip the wav files and convert to ogg or mp3 with Menu/Multimedia/Asunder CD Ripper.

    I have a sata dvd burner and use Audacious which has a digital audio cd output plugin to play audio cd's.I had to change permissions on the drive before a regular user could play.

    I have an older computer with an atapi ide dvd drive with the analog audio cable between the drive and soundcard. I use orpheus to control the drive.

    Both programs retrieve song names from freedb and add them to the playlist.

    There is a cdfs kernel module for mounting audio cd , vcd, etc...

    I tried it on ubuntu, it's not in slitaz repositories.

    I could mount an audiocd and see the wav files,when I tried to copy or play the files as root the computer locked up.
  • ApteryxApteryx July 2010
    Hello! I had the same problem: I had to change the permission on the file /dev/hdc in order to be able to play the audio CD using AlsaPlayer (Slitaz 3.0)
    (as root): chmod 666 /dev/hdc

    Now I can play them fine with my regular user login!
  • gdesilvagdesilva November 2010
    Had the same problem and just changed file permissions on /dev/sr0 as per Apteryx and that enabled Alsaplayer to play CDs. Thanks Apteryx
  • revenazrevenaz November 2010
    @Apterix : excellent same problem, same solution
  • revenazrevenaz November 2010
    Now I am trying to play a film with VLC
    when I insert the film in my Ubuntu computer I have a windows opening showing the content of the DVD.
    I clic right on the film and menu "open with VLC"
    Nothing like it in Slitaz
  • revenazrevenaz November 2010
    can we use gnome-terminal in Slitaz ?
  • Trixar_zaTrixar_za November 2010
    Not without installing half of the gnome dependencies... Seriously, you need like 100MB of GNOME's files just to use it. Rather use something like LXTerminal or Sakura.
  • ronfleurronfleur March 2011
    Thanks Apteryx! the chmod 666 works fine !

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social