This is the old SliTaz forum - Please use the main

Slitaz-cooking 2.6.37 and aircrack-ng 1.1 problem
  • BuranBuran March 2011
    Has somebody tried to install "ath9k" patch (fixed channel mon0: -1) for aircrack-ng 1.1? I have tried as here:
    I have install "bash", "make" and all nessecary components, unpack and apply "compat-wireless-2.6.37-4.tar.bz2" and "mac80211.compat08082009.wl_frag+ack_v1.patch" and "channel-negative-one-maxim.patch". Maybe I took wrong module? But with "compat-wireless-2011-03-19.tar.bz2", "make" not work - Error 2. Can somebody help me? Slitaz is my first linux-based OS.
    P.S. Sorry for my English.
  • BuranBuran March 2011
    Problem solved for Slitaz-cooking 2.6.37 2011-03-01
    Install "make", "bash", "linux-module-headers", "gcc", "perl" and all depending.
    Download compat-wireless 2.6.37 stable releases , mac80211 patch and  mon:-1 patch.
    Unpack compat-wireless, copy both patches to unpack directory and run:
    $ patch -p1 < mac80211.compat08082009.wl_frag+ack_v1.patch
    $ patch -p1 < channel-negative-one-maxim.patch

    You can also select driver. For example: $./scripts/driver-select ath

    $ make
    $ sudo make install

    Then reboot.
    That's all. Have a nice day! :)

This discussion has been closed.
← All Discussions

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership


SliTaz Social