This is the old SliTaz forum - Please use the main

tazlito problem with kernel modules paths
  • dominik_tdominik_t March 2011
    I'm creating an ISO image with a set of own packages. Packages are deployed without a problem, only problem that I have is that while I'm running a new ISO image I can see that paths to kernel driver/modules are wrong.
    When I run 'modprobe -l' I can see that for example path to 'eth0' driver looks like this:
    "/home/tux/slitaz/build/hpce2/rootfs//lib/modules/" and this path doesn't exist on LiveCD.
    Path "/home/tux/slitaz/" is the place where I run "tazlito" on my main Slitaz installation and after that there is a location of rootfs. The proper location for kernel modules should be "/lib/modules/......". I don't know why tazlito combines information about kernel modules paths in this way ?
    I'm using commands "tazlito clean-distro" and then "tazlito gen-distro /path/to/file/with/packages" with the Slitaz 3.0.

    Thank you for any help!

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership


SliTaz Social