This is the old SliTaz forum - Please use the main

Can't download packages!!! (Could be solved)
  • Spyro543Spyro543 March 2011
    Tried with both Midori and Google Chrome, and every time I click the box icon beside any package name, it reports with the same error: URL cannot be found. What now? I have 2 computers, one that runs SliTaz and one that runs Windows 7. The 7 computer is the only one that can access the internet, so I'm using that one to download TAZPKG files, then put them on my portable hard drive, then install then om the SliTaz computer. But I can't do that if I can't even download packages..... :'(
  • Trixar_zaTrixar_za March 2011 - search the name and click the link that pops up. It will download them for you.
  • Spyro543Spyro543 March 2011
    Ahh never mind, I just search for them in the and then get them at
  • Spyro543Spyro543 March 2011
    Now I need help installing the files I downloaded. I go on my SLiTaz computer and double click on my OpenOffice package. It asks me what program to use. Ok, so I go into the package manager and there's nothing there to help me. What can I do to install these files?
  • marquiticomarquitico March 2011
    As an example, I will use the package xorg-xdpyinfo-1.2.0.tazpkg. Go to the subdirectory where you downloaded your package. Issue this command as root in a terminal:
    tazpkg install xorg-xdpyinfo-1.2.0.tazpkg
  • Spyro543Spyro543 March 2011
    Ah I'll try that - WAIT what? So I just need a window open that has my packages in it then type that string in?

    Oh it didn't work. Where can I type in the root password, it wants a root password.
  • Spyro543Spyro543 March 2011
    How can I do this without a command prompt? Is it possible?
  • Trixar_zaTrixar_za March 2011
    No, it's not possible in SliTaz 3 (Although, you can in Cooking and the up and coming SliTaz 4...)

    You also set the root password when you installed SliTaz. On the LiveCD it's defaults to 'root' (without the ''), but when you install it you have the choice to change it.

    But here's the basic guide:
    1. Copy the files to "My Documents" (from the desktop link) or your home folder.
    2. Start xterm - it looks like a black screen with a white border with a white >_ in it. You can also find it under "Start" --> Utilities.
    3. Type su and press return/enter
    4. Type in the root password you set (if you didn't set it, it should be the word root) and press return/enter
    5. Now type tazpkg install filename.tazpkg to install the package named filename.tazpkg

    You see this is one of the problems with not being online with SliTaz. There is very little you can do in the way of easy without being online at first. For example, if you wanted to install something like xchat, you'll need to download ALL the packages that xchat will need too. This can get VERY drawn out with some packages. Some packages like all the get-* packages like for Chrome and Opera will just fail because they have to download stuff from the internet during install.

    If you could explain what kind of connection you've got, then maybe then we can get you online on SliTaz too and cut out all this hassle for you and make it an one command or one click affair.
  • Spyro543Spyro543 March 2011
    Well, the only internet we have is WiFi and my Windows 7 is a netbook and the SliTaz computer is a desktop computer with no wireless connectivity.
  • Spyro543Spyro543 March 2011
    And my username is Aaron, so when I double click on the Desktop icon My Documents, it just opens a folder called Aaron. Is that where I drop my files? (I'll test it now.)

    Ok, It said it installed. Where can I open OpenOffice?
  • Trixar_zaTrixar_za March 2011
    OpenOffice is one of those apps like Chrome that requires you to be online to download it.
    This being the list of them (excluding drivers): Dropbox, eclipse, flash-plugin, foxit reader, google chrome, google earth, java, opera, openoffice, rar, realplayer, sjphone, skype, texlive, unace, upx, virtualbox, wakoopa, wink, xlite and xnviewmp.

    Alternatively we can try getting your wifi working, but because of the innate problem of SliTaz 3 not on having firmware (dsl and wifi) packages, this might be tricky. One solution is to get get the drivers from debian and just convert the package over with tazpkg convert package.deb. This is yet another annoying thing about SliTaz 3 because they don't stock firmware, which is yet again fixed in SliTaz 4 (or so I hear).
  • Spyro543Spyro543 March 2011
    Like an external Wi-Fi device that plugs into a USB? If that's the case, I can get on the internet with my SliTaz computer if it works. But it would have to be Plug and Play becuase I'm pretty sure SliTaz won't wanna work with an installation disc. This one runs SliTaz only, no Windows.
  • slicelslicel March 2011
    I suggested on the old forum for the tazpkg gui to install new packages with depends from any target, to install from the packages dvd or usb iso.  I know you can set the gui to another target but I do not know if it auto-installs depends from the packages dvd.

    That would not help with ooo but you could use my other slitaz idea for that.  You could boot the live cd on the windows machine, install what you want, run tazlito writeiso to save a new iso, and install the new iso on the other computer.

    Writeiso has a bug with burning hd to iso but burning a live cd session to iso might work for you.

    Even if the writeiso did not work, you could save the tazpkg cache with all the depends and I think also the ooo binaries.  Some people had problems with ooo because of the the way slitaz get packages work.
  • Spyro543Spyro543 March 2011
    Oh, on the SliTaz computer, I changed so many settings I don't wanna have to change them again.

    I'll just get an extrenal WiFi antenna thingy to take care of my packages through the packages manager.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership


SliTaz Social