This is the old SliTaz forum - Please use the main

Support Wifi USB Adapter Edimax 7811 Chipset RT8192CU
  • pierolpierol March 2011
    Hi All, i'm here to explain a problem that i've not completely solved. I'm non able to make function the wifi adpter on the discussion subject. On my first attempt i try to compile the linux-wireless package in the wok repository. In fact in the receipt of the wok i've seen that the support for the chipset 8192 is included. The problem is that i'm not yet an expert of cooking woks. I've followed the guide in the slitaz documentation, i've added  these packages in my slitaz distribution (cooking version):


    when i try to cook the linux-wireless the process try to compile the linux package it depends to. But the process stop with this error

    /home/slitaz/wok/linux/receipt: line 24:24: report: command not found

    i understand that the package cointaing the report command is not istalled in the system but i'm not able to understand which package i must install. Making a ' tazpkg search-pkgname report' more the twenty packages come out.
    My second attempt has been to compile the driver downloading the source from the realtek website. Modifing the source i finally i got the .ko kernel module after a insmod and a depmod -a my wifi adpter started to function but tring to install it definetely in the system (certainly in the wrong way) the interface eth0 dissapered. So i think the the right way is to complire the linux-wireless package in the wok.

    Thank in advance for your replies

    Piero from Italy

  • on4aaon4aa March 2011
    Last week, I tried to bring alive that very same adapter, but rather by loading the ndiswrapper module into the kernel and using the Windows XP driver. I did not succeed, but I suspect this failure rather to be due to the fact that the adapter does not seem to support USB 1.0. So you may still want to try out that route.

    At the end of the day, I swapped the 8192 for a Fritz!WLAN that did work with its Windows XP driver and ndiswrapper.

    PS: I also know that the Edimax 7811 neither will be automatically installed by Linux Mint 10, a Ubuntu derivative. I did not try any further. This is what often happens with "too new" hardware and poor manufacturer support for Linux (i.e. no .deb package).
  • pierolpierol March 2011
    But do you have in the module list of the wireless network slitaz GUI the possibility to load the 8192 driver module ? How do you install it ? Anyway downloading the driver from realtek and compile it in in slitaz, after patching the osdep_service.c file, it works for me after loading manually the module. 
  • pierolpierol March 2011
    If you want i can give you the module i compile on slitaz cooking version with kernel 2.6.37
  • on4aaon4aa March 2011

    Hi pierol,

    Please, refer to the following URL for a detailed discussion about using ndiswrapper with SliTaz:

  • pierolpierol March 2011
    Hi on4aa,
    Thank you very much for your help and support. Now with my patched driver downloaded from realtek it seems all work well. The solution with the ndiswrapper is very smart in case new problems come out i will certainly try it.

    Do you have any idea which is the package i must install for command 'report' just to countinue my attempt to compile the linux-wireless package from the wok repository ?

    I attached the driver if you want have a try for your your USB adapter. The zip extension is a fake, otherwise i couldn't upload it. The driver has been compiled for kernel 2.6.37.

    Thank you again

    Attachments 0B
  • on4aaon4aa March 2011
    Sorry, I cannot help you out with compiling under Slitaz. I have nt yet done that. Perhaps you should start a new discussion topic about it.

    Also thanks for posting the driver.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership


SliTaz Social