This is the old SliTaz forum - Please use the main

Unicode support for perl-curses, mc, smbfs
  • setkasetka March 2011
    Hi. I want to use perl curses application on top of Slitaz. There is a "perl-curses" package in repo, but it's compiled with "", not "" (wide-character support version). I tried to recompile package with installed "ncursesw-dev" by:
    CURSES_LIBTYPE=ncursesw CURSES_LDFLAGS="-lcursesw" CURSES_CFLAGS="-I/usr/include/" tazwok cook perl-curses
    and then it works well, perl is linked with "" and my app works. I think it shold be solved in dstribution packages (compile with widechars by default, or as separate package).

    Also it seems that midnight commander is compiled without unicode support (there is a problem for example with text files view and edit on UTF-8 console or via ssh). And similar for smbfs (mount.cifs) which do not accept "charset" option. It's very good that Slitaz have UTF-8 support on locales level, but this application level options are also important for me.
  • slicelslicel March 2011
    Thank you for the report and suggestions.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership


SliTaz Social