This is the old SliTaz forum - Please use the main

Qemu segmentation fault error
  • ms3811ms3811 March 2011
    Has anyone managed to get qemu working? I am running cooking with .37 kernel. I downloaded and installed qemu, but I can't seem to get it working. No matter what I do, it keeps throwing a segmentation fault. Even if I run it with no parameters, just # qemu, it throws a segmentation fault.

    I need to get windows xp running for a few apps that are windows only, and I really don't want to setup a dual boot. Ideally, I should be able to fire up a vm session, do what I need to then turn it off.

    Any pointers on what could be wrong with qemu would be very much appreciated. Thanks.
  • slicelslicel March 2011
    Qemu worked on slitaz 3 stable xvesa host to run puppy as guest but would not run slitaz as guest.

  • ms3811ms3811 March 2011
    I managed to get around the segfault error by compiling the 0.14 release. Then I couldn't get any display, so some googling resulted in missing libsdl dev during compile, so installed that and I am about to recompile. Not very comfortable with compiling, but anyway let's see how this goes. Thanks for the help.
  • funkturmfunkturm March 2011
    Hello all,

    I use the cooking on eee1101HA, another mini ITX and a Toshiba notebook. On all systems qemu crashes with <Segmentation fault> too.
     The line on "/var/log/messages" was
    "Mar 18 22:36:20 (none) kernel: qemu[16031]: segfault at bfaae580 ip 08178901 sp bfaa76d0 error 6 in qemu[8048000+26d000]"

    As attachment I send a <strace> logfile. The parameter of strace where "strace -tf -s 70 -o strace.log"

    Anyone an idea what the problem is?
    I tried to compile an own qemu 0.14.0 version - same problem!

    Best regards
    strace.log 96K

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership


SliTaz Social