This is the old SliTaz forum - Please use the main

Manual ('By Hand') Installation [SOLVED]
  • hangfivehangfive February 2011

    hi ..iam on a debianetch (oldthinkpad)

    and i tried to install slitaz cookin by hand described in the documentation

    but it ended in:

    h5n1:/home/h5# mkdir /mnt/target
    h5n1:/home/h5# mount /dev/sda2 /mnt/target
    h5n1:/home/h5# mount -o loop /home/h5/slitaz-slitaz-3.0.iso slitaz-cooking.iso  
    h5n1:/home/h5# mount -o loop /home/h5/slitaz-cooking.iso /media/cdrom
    h5n1:/home/h5# mkdir /mnt/target/boot
    h5n1:/home/h5# cp -a /media/cdrom/boot/vmlinuz-* /mnt/target/boot
    h5n1:/home/h5# cp /media/cdrom/boot/rootfs.gz /mnt/target
    h5n1:/home/h5# cd /mnt/target
    h5n1:/mnt/target# ls
    boot rootfs.gz

    h5n1:/mnt/target# lzma d rootfs.gz -so | cpio -id
    lzma: invalid option -- s
    cpio: premature end of archive

    can sb help me?


    the OLD-original lzma source knows the option "--s" ...

    # so I got it from here

    # backup /usr/bin/lzma

    #extract lmza.gz to /usr/bin/

    bamm!everythin works fine ;-)

  • hangfivehangfive February 2011
    ah ok maybe it helps to use an older lzma version
  • hangfivehangfive February 2011


  • TotoetsasoeurTotoetsasoeur February 2011
    Congratulations. Please write down what you've done finally. It may help others.

    Moreover, it would be nice of you if you could edit topic title and add [SOLVED].

    Thanks for your feedback.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social