This is the old SliTaz forum - Please use the main

Trying to get Wireless PCMCIA card to work on dinasaur laptop install of SliTaz
  • SoteriologistSoteriologist November 2009
    Here's my setup:
    Compaq Armada 1700 laptop

    I'm trying to get a Linksys WPC54GS ver2 working on WPA2 only network.

    I'm not really sure where to start.

    I've read about getting the windows driver from here:
    and then downloading and using ndiswrapper from here:

    And I've downloaded both but am not sure what do do with them.

    I'm not even sure if my PCMCIA adapters are installed and working. I mean: I pop in my wireless card and it lights up fine, but when I read about scanning the PCMCIA ports using "cardctl ident" It doesn't show anything as being listed.

    So I guess where I need to start is this:
    Can someone first help me with checking and making sure that my PCMCIA device is working and if not, help me get it working?

    And then:
    Can someone help me figuring out how to get my Linksys WPC54GS ver2 working on WPA2 only network?

    Thank you to anyone and everyone for any assistance given.
  • SoteriologistSoteriologist December 2009
    when I run "tazhw detect-pci" I get:
    Module in use: yenta_socket
    Module in use: yenta_socket
    Module in use: ac
    Module in use: battery

    and when I run "lspci | grep Wireless" I get:
    01:00.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev02)

    Sor the yenta_socket's are my cardbus/pcmcia slots. So I guess their installed right/working? But should it list my card that I have in them when I run "tazhw detect-pci" ???
  • darkaudaxdarkaudax December 2009

    I can't say I definitely know to get it working. However, I do know some pieces.

    First, make sure "yenta_socket" is loaded in memory via "lsmod". If not, then "modprobe yenta_socket" and lsmod again. PCMCIA cards require this module to work properly.

    Broadcom cards need firmware. See this regarding how to install it:

    Slitaz comes with the b43 driver module which supports Broadcom. I have no idea if the driver also supports pcmcia. Simply modprobe b43 and give it a try. Remember that yenta_socket and the firmware must already be installed and working prior to loading b43.

    Good luck.

  • cavalier911cavalier911 December 2009
    With a working internet connection open xterm,su,password is root.
    Get modules: tazpkg get-install linux-wireless
    Open wireless configuration: netbox
    Click the "Wireless Manager" button in the lower left corner
    Click the "Drivers" tab
    Try b43 or b43 legacy from "Module:" dropdown menu
    Pick matching selection from "Firmware:" dropdown menu
    Click the "Install" button to the right of "Firmware:"
    After the script is finished downloading the windows driver and extracting the firmware, click the "List files" button to the right to view the firmware
    Click the "Load" button to the right of "Module:" now that the firmware is installed
    Click "Lsmode" to verify the Module has loaded
    Click the "Networks" tab and see your wireless ap listed
    Click your wireless ap and be prompted for username and password or
    Go to "Configuration" tab for username,password, and additional options
    "Favorites" tab,"Add Network" to autoconnect if you don't want to be prompted for credentials
    Add the module to /etc/rcS.conf to LOAD_MODULES=
    Recompress your filesystem on shutdown with a frugal install and a persistant home to save.
  • SoteriologistSoteriologist December 2009
    @darkaudax: When I run "lsmod" and "modprobe yenta_socket" then "lsmod" again this is the output I see:
    tux@slitaz:~$ lsmod
    Module Size Used by Tainted: P
    ndiswrapper 153748 0
    battery 10884 0
    ac 4996 0
    yenta_socket 21260 1
    rsrc_nonstatic 10112 1 yenta_socket
    pcmcia_core 29204 2 yenta_socket,rsrc_nonstatic
    ohci_hcd 18820 0
    nls_utf8 2560 0
    vfat 9984 1
    fat 39200 1 vfat
    tux@slitaz:~$ modprobe yenta_socket
    tux@slitaz:~$ lsmod
    Module Size Used by Tainted: P
    ndiswrapper 153748 0
    battery 10884 0
    ac 4996 0
    yenta_socket 21260 1
    rsrc_nonstatic 10112 1 yenta_socket
    pcmcia_core 29204 2 yenta_socket,rsrc_nonstatic
    ohci_hcd 18820 0
    nls_utf8 2560 0
    vfat 9984 1
    fat 39200 1 vfat

    In the wireless manager I see "Install Windows driver". If I click on that I notice it talks about ndiswrapper. So I've pointed it to my usb thumb drive that I put the Windows driver on and tell it to "install" and then "load" and it says in the "Tazndisbox" window:
    For "Driver" it has listed "lsbcmnds"
    and for "Info" it has listed "driver installed : device (14E4:4318) present"

    When I "Exit" out of that and go back to the "Wireless Manager" window / "Driver" tab something pops up saying "snanning wireless interface: wlan0". but when I go to the "Networks" tab it still just shows "any * off (auto-connect)" listed and that's it. Back on the "Drivers" tab under "Firmware" I don't see any of the broadcom firmware listed, neither "bc43-firmware" or "bc43xx-firmware".

    I downloaded on another computer and put onto my usb drive "linux-wireless-". And I understand how to "extract" it but how do I install it from my thumbdrive?

  • SoteriologistSoteriologist December 2009
    @cavalier911: There's no other way I can get a working internet connection other than through this card.
  • cavalier911cavalier911 December 2009
    Do you have a wireless accesspoint within range that you know works? Sounds like you installed the windows driver Lsbcmnds.inf correctly for ndiswrapper. Before we give up on Ndiswrapper open a terminal as root, type ifconfig to see if wireless adapter is listed. If it's there make note of the name, if it's wlan0 then type iwlist wlan0 scanning and see if it can see the accesspoint.
  • SoteriologistSoteriologist December 2009
    Ya, I have a few at both home and work. I'm currently at home and right now and I see 6 right now from my work laptop which has a built in wireless card.

    When I run "ifconfig" I get the following:

    tux@slitaz:~$ ifconfig
    lo Link encap:Local Loopback
    inet addr: Mask:
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:8 errors:0 dropped:0 overruns:0 frame:0
    TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:496 (496.0 B) TX bytes:496 (496.0 B)
  • cavalier911cavalier911 December 2009
    Remove the ndiswrapper module.
    Go to, download linux-wireless.tazpkg and b43-fwcutter.tazpkg
    Copy files from USB key to /home/tux
    Open terminal , su, root
    Next tazpkg install /home/tux/linux-wireless
    Next tazpkg install /home/tux/b43-fwcutter
    Next tar xjf broadcom-wl-
    Next cd broadcom-wl-
    Next b43-fwcutter -w /lib/firmware wl_apsta_mimo.o
    Now go back to my first post, the module is b43, firmware is b43-firmware ,click the list files button to see your extracted firmware from the previous step.
    Click Load button next to Module:b43
    Then ifconfig , for the adapter
  • SoteriologistSoteriologist December 2009
    I had a hard time trying to download the linux-wireless pkg from the link you gave (the specific link that it led me to was: tazpkg:// and I couldn't grab it in either FireFox nor IE). so I googled and found it here: ( Does this pkg seems ok? I also already had downloaded linux-wireless- from another site. If needed, is it ok to use this newer one? or do I need to stay to a certain "build number" or something that only slitaz is currently at?

    I'll be following the rest of your instructions as we speak and I'll let you know how it goes in a little bit...
  • SoteriologistSoteriologist December 2009
    Nevermind... I changed the "tazpkg" at the beginning to "http"

    so this:


    became this:

    and I was able to download ok... so I'm still working through your instructions. Thanx again.
  • SoteriologistSoteriologist December 2009
    @cavalier911: I've followed all of your wonderful instructions. Thank you so much. It seems to have gotten the card up and running but I still seems to have some glitches to get past...

    First: I see local access points around me now, such as my one at work. But when I go to connect it doesn't seem to be able to make the connection. So for testing purposes I've gone into the my works Wireless Access Point and reconfigured it to be WPA (it's normally WPA2). But I'm still having issues, so I'm gonna switch it back for the time being.

    Also: When I first boot up and then click to bring up the connection properties from the bottom right of the task bar it pops up a window that's titled "Connection Properites: eth0" And listed under "Connection" / "Name" is "eth0" and "lo" and then "Status" says "Error". If I go to "Configure" at the bottom it only lists the loopback "lo" for the "Connections". When I go to the "Wireless Manger" it just lists "any *" under networks. So I go to "Drivers" where "b43" is still selected under "Module". I tell it to "Load" again. Under "Firmware", nothing about b43-firmware is listed, only a bunch of the others that I've seen in there before. After I hit "Load" for the module, back on the "Networks" tab it lists two of the connections in my area. I double-click my works connections and provide the key needed and it then brings up "Scanning Wireless interface: wlan0" and takes me back. Under status for the ESSID of my work it just has a dash "-". When I exit here, back on the "Slitaz Netbox Manager" it then lists under "Connections" both "lo" and "wlan0" where for wlan0's "Status" it lists a dash again "-".
  • SoteriologistSoteriologist December 2009
    If I go back to the "Connection Properties" window it still only lists "lo". But when I type in "wlan0" and hit enter it brings up "Status" of "Disconnenected" but then shows a "Signal Strength" of "86%" and sometimes varying. I also got it to show some activity at one point. Oh wait... while typing this I think I got it to work.

    Here's what I did: I went in and set up the "Static IP" information for "wlan0". I and told it to "start". Then I found I had to go into the "Wireless Manager" and it would re-find and connect to the wireless network (the icon at the bottom right of the taskbar would update and show connected) and then I would just exit back out of all of that. Now I'm show packets as transfered and recieved and I'm able to get to google, etc.

    Is there any site that SliTaz has setup for auto-updates where I can check for the newest firmware, software, drivers etc for my system, or is that all manual?

    Also, is there anyway that I can make this more plug and play-ish? So I don't have to do such a munual setup each time I want to get on a network?

    THANX FOR ALL OF THE WONDERFUL HELP YOU GUYS!!!! I wouldn't be here without you (^_^)
  • darkaudaxdarkaudax December 2009
    To update your system just type:

    tazpkg recharge

    tazpkg upgrade

    Any newer package will be upgraded.

    Re plug and play: You could possibly write a small script to do the steps for you.

  • florastephanieflorastephanie February 2011

    thanks for the detailed instructions :)
    they helped me configure my Belkin as well
    before that, the LED lights of my Belkin were constantly off (one for power switch, the other for the LAN), i was even planning to buy another one :P

    after having followed the first few instructions, these lights finally were on :)
    but the signal strength was SO weak at first
    although i was only 50 cms away of the router.
    I even restarted, and it led me nowhere (i had the same symptoms that @Soteriologist had)

    but weird enough, i had no need to change any setting,
    the next time i turned my laptop on, in 15 minutes it worked all by itself.
    now the signal strength is strong even when i'm many meters away from the router.

    I don't know how it happened,
    i'm just posting this so if someone crosses this post and uses the instructions here, to allow the laptop a little while before seeing the full solution of it :)

    thanks again for this forum thread :)

  • skralljtskralljt February 2011
    When dealing with slitaz I have noticed that getting wireless to work requires first accessing the wireless manager, doubleclicking on the ap you want (or doing it by command line via iwconfig --essid i believe) and then at command prompt typing "ifup wlan0" assuming your wireless device is named wlan0. I've never had a linux install not named wlan0 except when using aircrack or something esoteric. Anyway, then after ifup type "udhcpc wlan0" and it should do a dhcp script and get an ip address for you assuming your router does dhcp. Good luck! Slitaz 2.0 was quite easy to use wireless with but ever since i switched to 3.0/cooking post 3.0 i have had nothing but trouble (slim won't start login, upgrading breaks ability to even login on tty1, etc)

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social