This is the old SliTaz forum - Please use the main

lxpanel crash
  • michaelkbischofmichaelkbischof January 2011
    After having installed slitaz I boot it and login, whether as root or as tux, does not matter. The opening screen is plain black. I have to use a right click with the mouse, select ,,xterminal", type ,,lxpanel" to the panel - with a note showing to a bug file in /home/tux/.cache.
     I cannot see the Desktop surface. I have to start pcmanfm - then this Deskop shows up.

    Unfortunately this bug file does not tell me anything. Anybody around here to explain its contents?

    In this situation I cannot give slitaz to any beginner. They are just helplessly sitting in front of a black screen.

    (By the way: midori is unsuitable to write to this forum. I can try to use it. But I cannot type into its field.

    The bug file is attached. - Sorry, now, it is not possible to attach the file.

    Therefore some parts of the bug file- I have no idea what it means:

    pcmanfm --show-pref=3
    Desktop icons



    desktopbox add-icons
    Erscheinungsbild GTK+



    Favorite applications


  • mojomojo January 2011
    root@slitaz: tazpkg check
    Reinstall any packages reporting missing or corrupted files.
    root@slitaz: tazpkg get-install  --forced

    pcmanfm provides desktop management by starting in daemon mode by /home/tux/.config/openbox/

    Logout of tux and login as user: root password: root to see if desktop and lxpanel appear
    If so it's a problem in the tux account.

    Need further assistance give info on live or full install and which slitaz iso version did you install from.

  • michaelkbischofmichaelkbischof January 2011
    Thank you, mojo!

    The machine in question I gave to a pupil of mine and get it back on Friday. Immediately I wilt test your recommendations and tune in here again!
    It is a full install of Slitaz 3.0.

  • michaelkbischofmichaelkbischof January 2011
    Hallo mojo,
    it isa full harddrive install based on Slitaz 3.0. With the root account it is okay. But the user account has troubles: there is no panel at the bottom. I get the following errors:

    michael@slitaz:~$ lxpanel &

    (process:2244): Gtk-WARNING **: Locale not supported by C library.
            Using the fallback 'C' locale.
    michael@slitaz:~$ ** (lxpanel:2244): DEBUG: cache file_name = /home/michael/.cache/menus/6449b28b2230f1e67516b473d8740e08
    lxpanel: expecting Plugin section
    lxpanel: can't start panel
    ** (lxpanel:2244): DEBUG: cache file_name = /home/michael/.cache/menus/6449b28b2230f1e67516b473d8740e08
    lxpanel: can't start plugin batt

    (process:2262): Gtk-WARNING **: Locale not supported by C library.
            Using the fallback 'C' locale.

    (firefox-bin:2262): Gtk-WARNING **: cannot open shared object file: No such file or directory

    (firefox-bin:2262): Gtk-WARNING **: cannot open shared object file: No such file or directory

    (firefox-bin:2262): Gdk-CRITICAL **: gdk_x11_atom_to_xatom_for_display: assertion `atom != GDK_NONE' failed

    Anyone here to have an idea what this means and how to correct it?
  • mojomojo January 2011
    Here is the latest bug report on the issues tracker with the fix:

    I applied the fix outlined in this report to a new user account on full slitaz-3.0 install as follows.

    This is the source file which is copied when you create a new user.
    Any additional accounts made after this will work.
    Login as root
    root@slitaz:~# nano  /etc/slitaz/applications.conf
    Log out of X and back in.

    Fix  account michael :
    Login as michael
    Open with text editor:
    michael@slitaz:~$ nano .config/slitaz/applications.conf
    Logout  X session
    Login to michael

    Thank you Dominique Corbex !!!

  • michaelkbischofmichaelkbischof January 2011
    Thank you very much, mojo,

    unfortunately this is not the underlying cause of this problem: in ,,applications.conf" it is already like ,,openbox-session". The errors therefore must have another reason.
    I guess I must refresh my knowledge about setting the locale in a correct way. No particular problem of Slitaz, then. But the firefox errors I still cannot understand. Firefox works, though!


    Michael - continues to be fascinated from Slitaz!;-)
  • sanger440sanger440 January 2011

    I have been playing around with slitaz on various machines for the last few weeks.  The stable version 3.0 usually installed and had working desktop for Tux, the user account.  But cooking always had a problem similiar to what you describe. The solution for me was to install to hd, then boot to live cd, copy all files (including hidden) in the Tux directory on the cd and paste into the /home/tux directory on the hd intall and overwrite whatever is there.  I would start pcman(spell?) from xterm as root so I had permissions to do this.

    Then boot back to the hd install, get to xterm and as root: chown -R tux:tux /home/tux

    Then when I logged back as tux all would be well.  Not sure how this will work with another username other than tux. 

    Hope this helps.




  • michaelkbischofmichaelkbischof January 2011
    Yes, it helped, thanks!
    I am still fascinated with playing around with Slitaz. There are quite a number of such tricky configuration issues. Gives a kind of ,,fresh flavour" to this distro. ;.)
    But I do not mind too much...


Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social