This is the old SliTaz forum - Please use the main

UPDATE - slitaz on google cr48 notebook - Completed
  • danaff37danaff37 December 2010
    UPDATE: Someone finally found a regular legacy bios to use on this thing, so was able to boot from usb.  everything works fine once you can use the slitaz kernel and not the chrome os kernel.  The instructions were here, but the bios has been taken down since the time I used it due to security reasons, and a new one is expected soon.  Buried in the comments is an alternate download to work if you dare, but I won't post it here.

    First off, no you cannot boot to anything but a signed kernel from google on this thing.  So no using usb or cdrom.  You have to use a linux file system but the kernel (which is linux, 2.6) already present.

    Okay, I've been trying to get slitaz to boot on my google notebook, following similar directions <a href="">here</a>, but it's been a pain in the rear.  I gave up and went to ubuntu for now using those directions (although I've been using a usb stick instead of transferring a 5 gig image file over ssh), and still don't have much luck.  But I would love to use Slitaz as a much lighter alternative to ubuntu.
    The developer mode of the notebook has a basic shell on it, but only includes a few tools.  Installing slitaz from image does not work;like I said, I think it's due to issues from large file integrity with all the moving.  So I'm trying to find a way to do it in the shell.  I have formatted the partition to ext3, but there are no lzma or cpio tools to use per the instructions to a manual install on this site.  It does have tar and gzip, which I tried (although I knew it was in vein) to use to extract the rootfs.gz from the iso.

    So, what I want to know, is there some other way to transfer the necessary root filesystem without using lzma or gzip?  I can't extract to usb and then just cp -ar it all over, right?  Keep in mind I don't have to worry about grub. I have gotten it to go into shell once.  But had no xorg, and tazx came up blank.  I know some of linux, but am really just a novice.

    Please help!  I like slitaz better than ubuntu, would love to use it on this thing.

    edit: I am using stable version, by the way
  • jozeejozee December 2010

    wow, those instructions for installing ubuntu on google chrome on cr48 are so hard. Google seems to curb linux "freedom" by making your life doubly hard (special BIOS, no usb boot,no cdrom boot, hard way to partition ssd,  closed-source hardware drivers, forcing to  use chrome kernel as BIOS can reject other linux kernel not signed by google, etc etc etc).

     But I have a feeling installing slitaz, instead of ubuntu or fedora, on cr48 should be much simpler. Three  steps:

    1) Partition your ssd (as described in your link above) [you have already done that].

    2) You are right: Use installation by hand is the easiest. Instead of lzma/gzip; I will prefer ssh/scp. So, extract rootfs.gz in one of your slitaz computers. Then, ssh/scp the files from that machine (add dropbear ssh server to rcS.conf for starting ssh server). That's it.

    3) slitaz kernel should work without any recompilation as slitaz does not require initrd. You have to sign the kernel.

    EDIT: this machine has 64-bit BIOS that will require patches to Slitaz kernel as per the instructions above. 

    BTW, congrats for getting selected for the pilot program.  If you are able to get slitaz on cr48, it will be great. Let us know how we can help.

  • danaff37danaff37 December 2010
    Got it to boot to slitaz terminal.  Startx fails, gonna work on fixing that (found the solution in the forums here I think).  After that, I'lll see about getting networking going.  But I'm much closer now.

    Oh, and if anyone is interested, I extracted the rootfs.gz and then made a tar out of it, as the google dev terminal on the cr48 does have tar.  Worked great.
  • jozeejozee December 2010
    that's great. Actually, can you try the xvesa flavor too:  . Vesa driver in Xorg sucks so tazx fails sometimes. XVesa may work better on totally unknown graphic drivers. If you know what graphic driver it is, you can use tazx. also do "tazpkg upgrade" to get all the latest fixes.
  • kultexkultex December 2010
    perhaps we can help if you post the output of lspci
  • kultexkultex December 2010
    ok - I found it:

    so it is a Intel Corporation Pineview Integrated Graphics Controller

    so it is supported by the intel driver and the i915 driver

    I have no idea, if the 3.0 intel driver supports pineview, but cooking does - it is good, when it just boots to terminal

    log in as tux, get root - then
    addgroup tux video
    exit to tux - startx - it wants to install xorg again - just do it
    and it should work

    when you use Slitaz-3.0 just do one command more
    after "tazx" run "tazhw detect-pci"

  • molmol December 2010
    Hi danaff37

    Nice to heard that there is a way to use the spider, but you really succeed to remove the octopus google ?

    Did you test a frugall install of Slitaz ?
  • danaff37danaff37 December 2010
    I got a user back on here.  Tried the directions given for tazx (addgroup, blah blah), but any time I run tazx, after selecting install xorg, the next screen only has the option to quit.  And trying startx just gets error .xsession not found.  installed xorg-xf86-video-intel taz package, but still nothing.  It does show pineview intel graphics controller under lspci as stated here before.  the tazhw detect-pci command shows snd_hda_intel (sound controller?), um10_gpio (I have no idea what this is), i2c_i801 (video card?), and ath9k(wireless card).  So any ideas guys?  I'm stumped.
  • kultexkultex December 2010
    sorry, that I did not see, that you have no wired Internet - so the best thing is to connect the machine to the internet
    Your Atheros wifi card is supported by the ath9k driver - lets see if it is recogniced
    "ifconfig" should thell you -
    if it is not recogniced, try to load ath9k as root  with: "modprobe ath9k" -
    restart the network with  "/etc/init.d/ restart"

    "iwlist ath0 scan" should give the possible networks

    now follow the guid
    do "nano /etc/etc/network.conf
    "  enter your configuration - restart the network one more time and you should be connected

    now you can use the rest
  • kultexkultex December 2010
    if you dont get the machine to internet try this:

    download the following tazpkgs and put them on a stick:

    you will find them in the database:  take care to use the correct one - cooking or stable

    boot now Slitaz - put in the stick, get root, find out the name of your stick with "fdisk -l", mount the stick "mount /dev/sdxx /media/flash" - go to flash: "cd /media/flash" and install all packages with "tazpkg install xorg-libXv" and so on

    and now run all the other commands

    and take care if you use cooking, I hope you did not use that one from 4.11.2010, because this one is not working - take the core iso from
  • danaff37danaff37 January 2011
    alright, sorry for the long delay, had to go out of town for work, and had no time to play around with this.  Tried installing all the packages mentioned (although could not find a libdrm package as requested) and still  have no luck.  Anytime I run tazx then install xorg, I come up with no choices, only to quit.  tried the xvesa flavor as well, but had the same issue.  So still stuck, hoping somebody has anymore ideas.  Terminal works fine. On boot, it makes it all the way to scsi devices, and stops there till I press enter, if that gives anyone ideas as to where it might be failing to load or something...
  • kultexkultex January 2011
    did you try to connect to the internet? perhaps somebody has something like this?

    its much easier, when you are in the net
  • danaff37danaff37 January 2011
    I've tried getting on the net.  NO luck.  Don't have a usb to ethernet adapter, but did try using usb tether on my android phone, which works natively in ubuntu and the chrome os that came on the cr48, but didn't work for me on Slitaz.  I have my laptop up right here next to it though, and can download any packages needed, then transfer over through usb.  Right now I'm on the latest slitaz cooking listed at the undigest mirror you gave (dec 26 I think) and tried everything previoulsy mentioned, but still no luck.  There is some improvement though, as the the terminal now shows colors for commands like ls, and I can see a cursor (couldn't before on stable).  Xvesa and xorg give me the same results.  I tried looking at the xorg.conf on the chrome os, but it's all listed as default screen, default monitor, default everything with no real info for me to help.

    I'm thinking it may be from having to use the chrome os kernel...  it's 2.6.32, if that helps, and I've modified the config per the instructions for loading ubuntu, but maybe I need to change something there.  I don't know how hard it would be to try and load the slitaz kernel, but this is a GPT type boot loader from what I've read, and the kernel has to be on a separate partition and modified with the efi64 (since it's a 64 bit bios) as mentioned in the ubuntu instructions, but I don't know how to go about doing either of those things.

    if it helps, here's the config given to boot ubuntu that I have in there now, maybe something I can change here?

    console=tty1 init=/sbin/init add_efi_memmap boot=local rootwait ro noresume noswap i915.modeset=1 loglevel=7 kern_guid=%U tpm_tis.force=1 tpm_tis.interrupts=0 root=/dev/sda7 noinitrd

  • kultexkultex January 2011
    GPT should not be a problem, but when you use the chrome os kernel, I think, its clear, that slitaz cannot start - I think, thats quite a miracle, that you boot until the console and you get something like coulors and can see a cursor.!!!
    Reading the instructions and jozees post, it just pops to my brain, that chromium is a fork of slitaz ??? !!!
    I just thought, that slitaz was already booting.. I just think, taht you have to really follow the instructions - you have to boot the slitaz kernel and you need a use a USB-to-ethernet adapter as mentioned in the post

  • kultexkultex January 2011
    it would be interesting to see the  /var/log/xorg.0.log - perhaps you are able to save it and post it here
  • danaff37danaff37 January 2011
    there is no xorg log.  I'm assuming it's not loading any video drivers so xorg never even tries to run.  I'm at a loss.  I'll have some more time later to mess with it.  I'm thinking of trying to install it into a vm and then using dd to transfer to the cr48 (the way the instructions do ubuntu).  I may have to end up running ubuntu (probably try lubuntu) until I learn how to modify and build the slitaz kernel, then figure out how to install it onto the cr48.
  • kultexkultex January 2011
    I think, slitaz is the better alternative - I just repost Jozees sugestion:

    "2) You are right: Use
    installation by hand
    is the easiest. Instead of lzma/gzip; I will
    prefer ssh/scp. So, extract rootfs.gz in one of your slitaz computers.
    Then, ssh/scp the files from that machine (add dropbear ssh server to
    rcS.conf for starting ssh server). That's it.

    3) slitaz kernel
    should work without any recompilation as slitaz does not require initrd.
    You have to sign the kernel.

    EDIT: this machine has 64-bit BIOS
    that will require patches to Slitaz kernel as per the instructions
    above.  "

    I think, that will run without patches, because here pasted from the guide:

    "First, although the Cr-48 CPU and BIOS is 64-bit, the kernel and rootfs
    (as I understod from Chrom OS) are presently 32-bit".
  • danaff37danaff37 January 2011
    yes, but if you look down towards the end of the instructions for ubuntu on the chromium blog, there's a section that talks about modifying the ubuntu kernel, and mentions that if you use a 32 bit kernel. you have to modify it with some EMI 64 thing from a git given to work on the bios.  Plus, I'm not sure how to transfer the kernel to the partition...  the kernel partition cannot be mounted, it always says to declare a type and I can't find one that works.  I suppose a dd might work, but I still have to figure out how to build the slitaz kernel with the modifications needed.  A little beyond me at the moment.
  • royer10rroyer10r February 2011
    I have a CR-48 and will start working on this as well... 

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sign In Apply for Membership

SliTaz Social